Koozali.org formerly Contribs.org

installing sme10 as VM on hyper-v cluster

Offline magwm

  • *
  • 154
  • SmeLover
    • Gadis Tourist Service Italia SRL
installing sme10 as VM on hyper-v cluster
« on: April 12, 2018, 01:21:52 PM »
I am installing a vm on our hyperv cluster to play with suiteCRM.
this is a windows 2012R2 2-node cluster with many production VM's on it, so I want it to go as smoothly as possible.

Can anyone point me to the correct VM settings? (https://wiki.contribs.org/Switch_to_Virtual_Hardware_Drivers is not very updated maybe?)

first,  i did the netinstall and used this https://www.altaro.com/hyper-v/centos-linux-hyper-v/ for the vm settings, but it created a borked installation (bug https://bugs.contribs.org/show_bug.cgi?id=10377)

encountered the difficulty to update: https://forums.contribs.org/index.php/topic,53316.0.html

now, i downloaded the iso and am installing again. will report.

I did not know if I had to set hostname in the installer (will the sme configurator ask for that again?)?
I did not know if I had to select and activate the legacy eth0?
I did not know what to do with partitioning?

"fast tsc calibration failed" pops up at boot

in the end, SuiteCRM requires php56 a least, and I was unable to install smeserver-php-scl in Sme10 as there are no contribs and adding the sme9contribs gave me

Transaction check error:
  file /usr/bin from install of smeserver-php-scl-0.4-16.el6.sme.noarch conflicts with file from package filesystem-3.2-21.el7.x86_64

I am quitting this attempt. will retry on sme9.
a pity, as I wanted to do at least something for sme10.. :|


« Last Edit: April 12, 2018, 05:26:33 PM by magwm »
MagWm

Offline ReetP

  • *
  • 1,767
Re: installing sme10 as VM on hyper-v cluster
« Reply #1 on: April 12, 2018, 10:48:19 PM »
a pity, as I wanted to do at least something for sme10.. :|

You have - you tried to install it :-)

It is Alpha - so expect issues.

Your best bet is to open a bug on the tracker (one per issue) and someone will look at it for you.

As far as running on Hyper V check for any issues on stock RHEL 7/CentOS 7.

PHP - you may be a bit early in the game, but raise it in the bug tracker and it will get resolved.

Most importantly, please keep testing and reporting issues.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Jean-Philippe Pialasse

  • *
  • 1,199
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: installing sme10 as VM on hyper-v cluster
« Reply #2 on: April 12, 2018, 10:53:15 PM »
SME10 is still really alpha.

it is not ready to do anything in production, neither to work on contribs.

if you need SuiteCRM, yes you need to do this on SME9.

If you want to help, then you can indeed install it on a VM , I have it running under proxmox, qemu/kvm, virtualbox. Not particular trick, just create a VM, boot on cd and install.
Then you can have a look to : https://wiki.contribs.org/SME_Server_10.0_Development and help verify the bugs in verification queue.

As stated Reetp, you can also try it and seek for unreferenced bugs.

also if you feel adventurous you could also check on open bugs and see if you are able to help fixing some .