Koozali.org formerly Contribs.org

Not an April fool : smeserver-nextcloud available for you on SME9!!

Offline TerryF

  • *
  • 1,040
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #45 on: January 07, 2019, 11:38:43 PM »
OK, settings Overview no more message -  The PHP memory limit is below the recommended value of 512MB

Deals done..combination of things..
--
qui scribit bis legit

Offline Jean-Philippe Pialasse

  • *
  • 1,199
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #46 on: January 08, 2019, 12:19:29 AM »
the culprite file is /etc/e-smith/templates/etc/php-fpm.d/www.conf/15Nextcloud

it says
php_admin_value[memory_limit] = 128M

will update it tonigh after opening a bug

ideally i would add some configuration variables

Offline TerryF

  • *
  • 1,040
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #47 on: January 08, 2019, 12:24:30 AM »
JP I was keeping it as a surprise :-(, was just resetting everything to default to document.. :-) and think there may be more, time will tell, I am but a pleb :-)
« Last Edit: January 08, 2019, 12:32:06 AM by TerryF »
--
qui scribit bis legit

Offline Jean-Philippe Pialasse

  • *
  • 1,199
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #48 on: January 08, 2019, 01:12:46 AM »
JP I was keeping it as a surprise :-(, was just resetting everything to default to document.. :-) and think there may be more, time will tell, I am but a pleb :-)

oups

sorry I am slow sometime to react but was fast on this one ;)

https://bugs.contribs.org/show_bug.cgi?id=10695

Offline TerryF

  • *
  • 1,040
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #49 on: January 08, 2019, 02:03:18 AM »
na alls good mate, I was probably all day to put together a proper answer and how to temp fix, I am like a small child who is given a treat, bugger everyone else I am going to eat this all first LOL :-)
--
qui scribit bis legit

Offline TerryF

  • *
  • 1,040
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #50 on: January 08, 2019, 04:31:55 AM »
See Bug 10695 for updated package

Nextcloud configs now honour memory_Limit settinsg in config db

# config setprop php71 MemoryLimit 1024M
# expand-template /opt/remi/php71/root/etc/php.ini
# config show php71

# config show php71
php71=configuration
    AllowUrlFopen=Off
    MaxExecutionTime=30
    MaxFileUpload=20
    MaxInputTime=60
    MemoryLimit=1024M
    PhpModule=disabled
    PostMaxSize=20M
    UploadMaxFilesize=10M
--
qui scribit bis legit

Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #51 on: January 08, 2019, 11:15:38 AM »
Thank you very much. It works now.
Code: [Select]
config setprop nextcloud MemoryLimit 1024
signal event nextcloud-update

Offline edb

  • *
  • 522
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #52 on: January 09, 2019, 05:41:07 PM »

I have updated manually as per Wiki from version is 13.0.1 to Nextcloud 14.0.4.  Now I have corrected most of the errors except these:

There are some errors regarding your setup.

   
Code: [Select]
Some files have not passed the integrity check. Further information on how to resolve this issue can be found in the documentation. (List of invalid files… / Rescan…)

    Your web server is not properly set up to resolve "/.well-known/caldav". Further information can be found in the documentation.
    Your web server is not properly set up to resolve "/.well-known/carddav". Further information can be found in the documentation.
    The database is missing some indexes. Due to the fact that adding indexes on big tables could take some time they were not added automatically. By running "occ db:add-missing-indices" those missing indexes could be added manually while the instance keeps running. Once the indexes are added queries to those tables are usually much faster.
        Missing index "parent_index" in table "oc_share".
        Missing index "fs_mtime" in table "oc_filecache".
    The "Referrer-Policy" HTTP header is not set to "no-referrer", "no-referrer-when-downgrade", "strict-origin", "strict-origin-when-cross-origin" or "same-origin". This can leak referer information. See the W3C Recommendation ↗.

Has anyone else seen this and how to fix?


Thanks

edb
« Last Edit: January 09, 2019, 10:45:37 PM by edb »
......

Offline Jean-Philippe Pialasse

  • *
  • 1,199
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #53 on: January 09, 2019, 10:43:43 PM »
Is it possible to update Nextcloud directly from the GUI yet?

Current version is 13.0.1.
Update to Nextcloud 14.0.4 available. (channel: "stable")
Following file will be downloaded automatically: https://download.nextcloud.com/server/releases/nextcloud-14.0.4.zip
Start Update

If I click the Start Update will this work without issue or what is required?
Thanks

edb

what returns
Code: [Select]
rpm -qa |grep nextcloud
There are 2 known blockers depending on your current rpms : assets folder needing to be deleted, PHP 128Mo of memory or more and max execution time higher than default.

you will probably get an error as assets folder is existing during the update.
This could be fixed by

Code: [Select]
rm -rf  /usr/share/nextcloud/assets

then I suggest you to update smeserver-nextcloud to version 1.1.0-10 at least or better 1.1.0-11. This would solve the PHP needs.

Code: [Select]
yum update smeserver-nextcloud --enablerepo=smecontribs
signal-event nextcloud-update
config set UnsavedChanges no

then you should be able to upgrade at least up to 14.0.4 using webupdate.

It seems sometimes that there is a blocker from 14.0.4 to 15.0.0. Tell us when you are there.

Offline edb

  • *
  • 522
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #54 on: January 09, 2019, 11:21:42 PM »
Hi Jean

I have already attempted to manually update as in the post above but here is the results of the commands:

Code: [Select]
[root@defcon1 nextcloud]# rpm -qa |grep nextcloud
smeserver-nextcloud-1.1.0-10.el6.sme.noarch
nextcloud-13.0.1-4.el6.sme.noarch
[root@defcon1 nextcloud]# yum update smeserver-nextcloud --enablerepo=smecontrib
s
Loaded plugins: fastestmirror, post-transaction-actions, smeserver
Setting up Update Process
Loading mirror speeds from cached hostfile
 * base: mirror.csclub.uwaterloo.ca
 * smeaddons: mirror.canada.pialasse.com
 * smecontribs: mirror.canada.pialasse.com
 * smeextras: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * updates: mirror.csclub.uwaterloo.ca
No Packages marked for Update
[root@defcon1 nextcloud]#

It doesn't see any update so nothing happens.

And with the new version 14 that I updated it has some setup errors that I don't know how to resolve easily.

......

Offline TerryF

  • *
  • 1,040
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #55 on: January 09, 2019, 11:40:12 PM »
Update is in /smetest at least is is just now, JP may have started the move to /smecontribs may take a while for all mirrors to sync that up

« Last Edit: January 09, 2019, 11:42:59 PM by TerryF »
--
qui scribit bis legit

Offline edb

  • *
  • 522
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #56 on: January 09, 2019, 11:47:27 PM »
Update is in /smetest at least is is just now, JP may have started the move to /smecontribs may take a while for all mirrors to sync that up

Thanks Terry that did the trick for the updated contrib.
......

Offline edb

  • *
  • 522
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #57 on: January 10, 2019, 12:12:48 AM »
I have updated manually as per Wiki from version is 13.0.1 to Nextcloud 14.0.4.  Now I have corrected most of the errors except these:

There are some errors regarding your setup.

   
Code: [Select]
Some files have not passed the integrity check. Further information on how to resolve this issue can be found in the documentation. (List of invalid files… / Rescan…)

    Your web server is not properly set up to resolve "/.well-known/caldav". Further information can be found in the documentation.
    Your web server is not properly set up to resolve "/.well-known/carddav". Further information can be found in the documentation.
    The database is missing some indexes. Due to the fact that adding indexes on big tables could take some time they were not added automatically. By running "occ db:add-missing-indices" those missing indexes could be added manually while the instance keeps running. Once the indexes are added queries to those tables are usually much faster.
        Missing index "parent_index" in table "oc_share".
        Missing index "fs_mtime" in table "oc_filecache".
    The "Referrer-Policy" HTTP header is not set to "no-referrer", "no-referrer-when-downgrade", "strict-origin", "strict-origin-when-cross-origin" or "same-origin". This can leak referer information. See the W3C Recommendation ↗.

Has anyone else seen this and how to fix?


Thanks

edb

I have attached an image of the Security & setup warnings I am getting after upgrading to version 14.
The list of invalid files is huge?
What to do?
......

Offline Jean-Philippe Pialasse

  • *
  • 1,199
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #58 on: January 10, 2019, 06:16:06 AM »
edb,
please open a bug and attach the list of files in it.
also paste the main list of error.

Offline edb

  • *
  • 522
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #59 on: January 11, 2019, 04:39:50 AM »
Okay, I upgraded via the Web GUI from 14.0.4 to 14.0.5 and that seems to have cleared up the errors with the invalid files now. But there remains a few errors regarding caldav and carddav and "The database is missing some indexes."

It works fine but just don't know how to resolve those scan issues.
This is under Settings - Overview then it initiates a setup and security scan.
Maybe the error can just be ignored?

Not sure a bug report is necessary yet.
......