Koozali.org formerly Contribs.org

Not an April fool : smeserver-nextcloud available for you on SME9!!

Offline Jean-Philippe Pialasse

  • *
  • 1,199
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #30 on: July 17, 2018, 08:32:09 AM »
I am currently running
Code: [Select]
smeserver-nextcloud-1.1.0-8.el6.sme.noarch and I beleive it is the latest but is it safe to update from Nextcloud to the newer version 13.0.4?
I seem to remember you saying that the update had some issues but not sure if they were fixed yet or not and don't want to break anything.
Thanks

-edb

Not yet fixed, need to put some time on it in the next week

Offline edb

  • *
  • 522
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #31 on: July 17, 2018, 02:29:41 PM »
Okay thank you Jean.
No hurry of course just thought I would ask and really appreciate your work on this.
......

Offline edb

  • *
  • 522
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #32 on: September 27, 2018, 08:40:25 PM »
Not yet fixed, need to put some time on it in the next week


Sorry to bug but just curious if this has been updated at all yet? I have not seen any update yet.
I there anything I need to know prior to removing this contrib if I decide to do so?
Just don't want to damage anything on my production server.
Best regards
......

Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #33 on: January 06, 2019, 09:49:57 AM »
Many thanks for integrating Nextcloud into the SME server. From my point of view this is a real milestone!
How can I change the setting "memory_limit"?
I tried the following without success:
"config setprop php71 MemoryLimit 512M"

Offline TerryF

  • *
  • 1,040
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #34 on: January 06, 2019, 11:47:40 AM »
Did you run a signal-event and expand the template?
--
qui scribit bis legit

Offline TerryF

  • *
  • 1,040
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #35 on: January 06, 2019, 12:14:59 PM »
To be specific

# config show php71
php71=configuration
    AllowUrlFopen=Off
    MaxExecutionTime=30
    MaxFileUpload=20
    MaxInputTime=60
    MemoryLimit=128M
    PhpModule=disabled
    PostMaxSize=20M
    UploadMaxFilesize=10M


# config setprop php71 MemoryLimit 512M
# expand-template /opt/remi/php71/root/etc/php.ini
# config show php71

# config show php71
php71=configuration
    AllowUrlFopen=Off
    MaxExecutionTime=30
    MaxFileUpload=20
    MaxInputTime=60
    MemoryLimit=512M
    PhpModule=disabled
    PostMaxSize=20M
    UploadMaxFilesize=10M
--
qui scribit bis legit

Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #36 on: January 06, 2019, 05:44:39 PM »
I made it that way.
But my Nextcloud15 instance only gets 128MB memory.

Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #37 on: January 06, 2019, 05:52:50 PM »
I tried:
Code: [Select]
config setprop php71 MemoryLimit 512M
expand-template /opt/remi/php71/root/etc/php.ini
signal-event php-update
signal-event nextcloud-update

Test .php in Nextcloud root:
Code: [Select]
echo phpversion()."<br>";
echo 'memory_limit = ' . ini_get('memory_limit') ."<br>";

Result:
7.1.20
memory_limit = 128M

Offline TerryF

  • *
  • 1,040
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #38 on: January 06, 2019, 11:04:57 PM »
I don't have nextcloud installed so am unable to follow it all the way..

I would suspect Nextcloud has further configs somewhere that are part of memory settings.

--
qui scribit bis legit

Offline janet

  • ****
  • 4,682
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #39 on: January 07, 2019, 01:55:10 AM »
codework

I suggest  you do

signal-event post-upgrade
signal-event reboot

to see if a reconfigure & restart gets things working correctly.
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #40 on: January 07, 2019, 07:03:27 AM »
Hi, everyone. I am by no means very good at working out problems. I have followed this thread looking to see if the issue with php71 memory limit would help my issue an it has partly only.

I performed the NextCloud upgrade as presented. The main problem is that I found that NextCloud was not accessable, with the message that Maintenance mode was on. I have changed the maintenance mode to off, but the web browser still has the same message and I cannot get to sign in.

I used the code:
su www -s /bin/bash
cd /usr/share/nextcloud/
scl enable php71 'php occ maintenance:mode --off'
scl enable php71 'php occ maintenance:repair'
exit

Despite maintenance mode being off, there were errors with the repair part which I did understand.

I would be guided by you to see what I should present concerning logs, etc, or whether this is just something I overlooked with the upgrade. I have increased the memory to 512M.

I am happy to submit as a potential bug, but want to be sure that I have not just done something stupid

Gavan

Offline sages

Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #41 on: January 07, 2019, 07:13:53 AM »
I've done the upgrade however I did have problems with the versions of nextcloud. Nextcloud will only upgrade one major version at a time.
See my comments in this bug report https://bugs.contribs.org/show_bug.cgi?id=10670

My nextcloud install is still reporting php memory <512M but appears to be running ok.
Note I have only update to V14.04 Nextcloud. I'm now waiting till 15.1 or greater before updating nextcloud as per their inbuilt update suggestions.
Rod
...

Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #42 on: January 07, 2019, 09:29:00 AM »
Thanks for the comment. I will review my version and see if that is what I did wrong.

On the bright side, I have found NextCloud and the smeserver-nextcloud to be excellent. I have used OwnCloud for ages and this installation works better anddefinitely don't want to stop using it.

Congratulations to everyone who got this set up and going.

Gavan

Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #43 on: January 07, 2019, 11:59:36 AM »
I suggest  you do

signal-event post-upgrade
signal-event reboot

to see if a reconfigure & restart gets things working correctly.
I did. But no change.
"var_dump( get_cfg_var('cfg_file_path') );"
shows that the following php.ini is used:
"/etc/opt/remi/php71/php.ini"
and in this the memory_limit is set correctly.
The setting is obviously ignored or overwritten.
no idea where to look...

Offline TerryF

  • *
  • 1,040
Re: Not an April fool : smeserver-nextcloud available for you on SME9!!
« Reply #44 on: January 07, 2019, 09:49:59 PM »
Have got the contrib installed, rather than look to /php71 as the be all and end all.

These areas and templates

/usr/share/nextcloud
.htaccess
.user.ini

etc/php-fpm.d/www.conf

/etc/e-smith/templates/etc/php-fpm.d/
/etc/e-smith/templates/etc/php-fpm.d/www.conf
/etc/e-smith/templates/etc/php-fpm.d/custom.conf

/etc/e-smith/templates/etc/php-fpm.conf


and no still see the message in nexcloud of: The PHP memory limit is below the recommended value of 512MB." is still coming up with 1024M set in those above..

There is more to this story than my limited knowledge is up to just yet :-)

On the hunt :-)
--
qui scribit bis legit