Koozali.org formerly Contribs.org

Problème spamassassin sous SME 9.2

Offline Fredchou

  • *
  • 37
  • Use SME server at home
Re: Problème spamassassin sous SME 9.2
« Reply #15 on: February 27, 2018, 10:10:03 PM »
C'est bon. Tout a l'air de fonctionner.  :-)
Jean-Philippe, tu veux que je mette quoi sur la page du bug ?
Fred Chou

Offline Jean-Philippe Pialasse

  • *
  • 1,917
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Problème spamassassin sous SME 9.2
« Reply #16 on: February 28, 2018, 07:11:24 AM »
je pense que c'Est bon Giere a posté suffisament de retour de tests concluant, je vais mettre en place le patch

Offline Fredchou

  • *
  • 37
  • Use SME server at home
Re: Problème spamassassin sous SME 9.2
« Reply #17 on: October 10, 2021, 09:01:13 PM »
Bonjour à tous,
J'ai migré récemment vers SME 10 et j'ai à nouveau le problème...  :-(
Je vois que le bug https://bugs.koozali.org/show_bug.cgi?id=10289 est toujours ouvert. Je me demande si mon problème est dû au fait que j'avais patché SME 9 et que les templates sont restés sur mon serveur ou si le problème est réapparu dans SME 10...
Quelqu'un pour m'éclairer ?
Merci,
Fred
Fred Chou

Offline Jean-Philippe Pialasse

  • *
  • 1,917
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Problème spamassassin sous SME 9.2
« Reply #18 on: October 10, 2021, 09:18:12 PM »
le travail a ete fait a l’envers et tu vies donc une regression.
le patch a ete appliqué a la version ancienne avant que quelque chose soit fait sur la version en développement. et rien n’a ete fait sur la versione n développement. 
heureusement tu l’as vu et heureusement un bug etait toujours ouvert. 
on va appliquer le patch dans les prochains jours des que quelqu’un est disponible.

Offline Fredchou

  • *
  • 37
  • Use SME server at home
Re: Problème spamassassin sous SME 9.2
« Reply #19 on: October 10, 2021, 09:23:08 PM »
Super, merci ! C'est ce que je craignais...
Y a-t-il besoin d'ajouter un commentaire sur le bug ?
Fred Chou

Offline Jean-Philippe Pialasse

  • *
  • 1,917
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Problème spamassassin sous SME 9.2
« Reply #20 on: October 10, 2021, 09:31:37 PM »
nop c’est fait.

c’est thanksgiving en Amerique du Nord, donc de mom coté acces limité au builder pour quelques jours.

Offline TerryF

  • grumpy old man
  • *
  • 1,578
Re: Problème spamassassin sous SME 9.2
« Reply #21 on: October 12, 2021, 01:05:18 PM »
sme 10 update of smeserver-fetchmail has been done see Bug 10538
--
qui scribit bis legit

Offline Fredchou

  • *
  • 37
  • Use SME server at home
Re: Problème spamassassin sous SME 9.2
« Reply #22 on: October 14, 2021, 10:10:37 AM »
I have read https://bugs.koozali.org/show_bug.cgi?id=10538

But it seems that new package is not available in smedev nore in smecontribs :

Code: [Select]
Nom                 : smeserver-fetchmail
Architecture        : noarch
Version             : 1.6
Révision            : 19.el7.sme
Taille              : 494 k
Dépôt               : installed
Depuis le dépôt     : smecontribs
Résumé              : sme module to generate fetchmail poll
Licence             : GPL
Description         : sme server enhancement to make fetchmail more useable

Should I wait a little?
Fred Chou

Offline ReetP

  • *
  • 3,034
Re: Problème spamassassin sous SME 9.2
« Reply #23 on: October 14, 2021, 11:55:12 AM »
I think it is in smetest. brand new/experimental packages go to dev. Existing packages that are patched got to test. IIRC....

Code: [Select]
yum --enablerepo=smetest install smeserver-fetchmail
smeserver-fetchmail-1.6-20.el7.sme.noarch.rpm
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Fredchou

  • *
  • 37
  • Use SME server at home
Re: Problème spamassassin sous SME 9.2
« Reply #24 on: October 14, 2021, 01:37:23 PM »
Merci beaucoup ! J'ai pu récupéré le nouveau paquet sur le serveur smetest. Je vais vérifier si ça fonctionne.
Fred Chou

Offline ReetP

  • *
  • 3,034
Re: Problème spamassassin sous SME 9.2
« Reply #25 on: October 14, 2021, 03:30:19 PM »
Merci beaucoup ! J'ai pu récupéré le nouveau paquet sur le serveur smetest. Je vais vérifier si ça fonctionne.

You can help us.

Use the template here:

https://wiki.koozali.org/Bugzilla_Help

VERIFICATION TEMPLATE

Then add it to the bug.

Thank you.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Fredchou

  • *
  • 37
  • Use SME server at home
Re: Problème spamassassin sous SME 9.2
« Reply #26 on: October 14, 2021, 10:15:08 PM »
Fix does not work on my server...  :-(

/var/service/qpsmtpd/config/forcespamcheck stays empty after expand-template. What seems strange is that fetchmail status is "disabled" in config... Even if my e-mails are correctly retrieved from my external POP server.

Code: [Select]
config show fetchmail
fetchmail=service
    FreqOffice=every15min
    FreqOutside=every15min
    FreqWeekend=every15min
    Method=standard
    SecondaryMailAccount=popaccount
    SecondaryMailPassword=poppassword
    SecondaryMailServer=mail.myisp.xxx
    status=disabled
Fred Chou

Offline TerryF

  • grumpy old man
  • *
  • 1,578
Re: Problème spamassassin sous SME 9.2
« Reply #27 on: October 15, 2021, 02:26:18 AM »
Fix does not work on my server...  :-(

/var/service/qpsmtpd/config/forcespamcheck stays empty after expand-template. What seems strange is that fetchmail status is "disabled" in config... Even if my e-mails are correctly retrieved from my external POP server.

Code: [Select]
config show fetchmail
fetchmail=service
    FreqOffice=every15min
    FreqOutside=every15min
    FreqWeekend=every15min
    Method=standard
    SecondaryMailAccount=popaccount
    SecondaryMailPassword=poppassword
    SecondaryMailServer=mail.myisp.xxx
    status=disabled

For the template to create the config forcespamcheck fetchmail must be enabled - # config setprop fetchmail status enabled

--
qui scribit bis legit

Offline TerryF

  • grumpy old man
  • *
  • 1,578
Re: Problème spamassassin sous SME 9.2
« Reply #28 on: October 15, 2021, 02:26:54 AM »
and just adding this has only be done for SME10, NOT SME9
--
qui scribit bis legit

Offline Jean-Philippe Pialasse

  • *
  • 1,917
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: Problème spamassassin sous SME 9.2
« Reply #29 on: October 15, 2021, 02:39:40 AM »
si tu as des messages rentrant en pop sans que fetchmail soit activé tu as aoit des templates custom bypassant la contrib, soit tu utilose autre chose que fetchmail.


que dit

/sbin/e-smith/audittools/templates