Koozali.org formerly Contribs.org

Microsoft SMB1 no longer installed: how can we help with SME10?

Offline stabilys

  • **
  • 67
  • Ah din't do it!!
    • http://stabilys.com
Microsoft SMB1 no longer installed: how can we help with SME10?
« on: December 08, 2017, 02:24:14 PM »
A note and request to developers: I have reported to Bugzilla  (for possible documentation, not a fix) the issue raised by this:

https://support.microsoft.com/en-gb/help/4034314/smbv1-is-not-installed-windows-10-and-windows-server-version-1709

The solution really is SME 10 released with current Samba 4 fully working with supported protocols.

(We have already had to start replacing SME 9 with a QNAP in some smaller applications, as it supports Samba 4 properly. This is not helpful for the project!)

The request: what can we as users of the system do to help you, the few in number and very time-pressed and not paid at all developers, to get SME 10 out of the door?

- is the testing regime as laid out here https://wiki.contribs.org/SME10.0_QA primary?

- anything else we can do to help?

MeJ
This, too, will pass ;)

Offline ReetP

  • *
  • 1,593
Re: Microsoft SMB1 no longer installed: how can we help with SME10?
« Reply #1 on: December 08, 2017, 08:46:23 PM »
For ref this is the bug:

https://bugs.contribs.org/show_bug.cgi?id=10480

There is link on how to add SMB V1 support if required.

Re v10 it depends a lot on you all.

The wiki page is a good start.

Install, test, report new bugs, look for existing v10 bugs and try to replicate them. Even better if you can help fix them !

Every little helps, seriously.

Just wade in and have a go and you will get help.

I learned more about Linux & SME during the period we developed v9 than I had in all the preceding years I used it. And now proudly have build perms on th system ! If I can do that, so can you.

Just shout if you want a hand.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline Franco

  • *
  • 1,170
    • http://contribs.org
Re: Microsoft SMB1 no longer installed: how can we help with SME10?
« Reply #2 on: January 07, 2018, 11:05:23 PM »
Hi,

I installed SME10 alpha3 and at first all the connections, including from "appliance's like" devices worked perfectly.
This is without setting the version as provided on the reply above.

Thanks,

Online TerryF

  • *
  • 976
Re: Microsoft SMB1 no longer installed: how can we help with SME10?
« Reply #3 on: January 08, 2018, 12:43:30 AM »
Forum discussion re issue, not a lot we can do..up to samba cause Mr MS won't change

https://forums.contribs.org/index.php/topic,53323.0/topicseen.html
--
qui scribit bis legit

Offline Franco

  • *
  • 1,170
    • http://contribs.org
Re: Microsoft SMB1 no longer installed: how can we help with SME10?
« Reply #4 on: January 09, 2018, 02:41:50 AM »
Forum discussion re issue, not a lot we can do..up to samba cause Mr MS won't change

https://forums.contribs.org/index.php/topic,53323.0/topicseen.html

Works for me, for Win10 you NEED to apply the regedit in https://IP/server-resources/
I have from earlier boxee devices to Macs, Windows and linux boxes logging in without problems!

After you apply the updates, there's a catch with libtevent breaking NMB, see my other post.

Thanks,

Offline brianr

  • *
  • 856
Re: Microsoft SMB1 no longer installed: how can we help with SME10?
« Reply #5 on: January 09, 2018, 09:16:43 AM »
After you apply the updates, there's a catch with libtevent breaking NMB, see my other post.

Note that this problem with "libtevent breaking NMB" is with SME10alpha3, NOT with SME9.
Brian j Read
(retired, but still looking after 5 SME installations)
.........

Offline Franco

  • *
  • 1,170
    • http://contribs.org
Re: Microsoft SMB1 no longer installed: how can we help with SME10?
« Reply #6 on: January 09, 2018, 11:19:55 AM »
Note that this problem with "libtevent breaking NMB" is with SME10alpha3, NOT with SME9.
But this is the SME 10 section of the Forum, NOT SME9.

Thanks,

Offline brianr

  • *
  • 856
Re: Microsoft SMB1 no longer installed: how can we help with SME10?
« Reply #7 on: January 09, 2018, 11:24:37 AM »
But this is the SME 10 section of the Forum, NOT SME9.

Thanks,

True, but I was afraid of someone coming across this and thinking that it applied to SME9!! I think probably we've made that quite clear now!!  :-)
Brian j Read
(retired, but still looking after 5 SME installations)
.........