Contribs.org

Please login or register.

Login with username, password and session length

News:

Remember SME Server is currently free to download and use. But it is not free to build. You can help by making a donation of time OR money from the links below.

Pages: [1]   Go Down

Author Topic: Problem mit SMTP / SSL  (Read 44 times)

mdombrowski

  • Just popping in
  • Offline Offline
  • Posts: 3
Problem mit SMTP / SSL
« on: December 06, 2017, 03:57:16 PM »

Hallo zusammen,
auf meinem SME 9.2 (Privater Server und Gateway) habe ich seit heute ein Problem:

nach ein paar Versuchen mit dem Mailversand (große Anhänge, automatisches senden mit sendEmail) kann ich plötzlich keine Mails mehr per SMTP an den Server senden (vom LAN aus). Alle Versuche von Thunderbird aus werden mit einem (Timeout)-Abbruch quittiert.
Die qpsmtpd-Logdatei gibt folgende Fehlermeldung aus:

3595 Accepted connection 0/40 from 192.168.10.102 / pc-00102.falamb.local
3595 Connection from pc-00102.falamb.local [192.168.10.102]
Could not create SSL context: Inappropriate ioctl for device at /usr/share/qpsmtpd/plugins/tls line 110.
2256 cleaning up after 3595


Ich habe schon versucht, die relevanten Pakete (qpsmtpd, qmail, perl-IO-Socket-SSL, perl-net-SMTP_SSL, perl-net-SSLeay
u. a. neu zu installieren (yum reinstall), aber das hat bisher keinen Erfolg gebracht.

Hat jemand vielleicht eine Idee, welche Ursache der Fehler haben kann bzw. wie die Installation wieder in einen funktionsfähigen Zustand gebracht werden kann.

LG
Michael


Logged

mmccarn

  • Wiki & Docs Team
  • *
  • Offline Offline
  • Posts: 2,220
Re: Problem mit SMTP / SSL
« Reply #1 on: December 07, 2017, 01:30:42 PM »

Maybe something related to the SSL configuration or certificate file has become damaged.

Check that your settings for TLS Ciphers are OK, and check that your certificate files are in the correct location and look OK.

For qpsmtpd, tls_ciphers is loaded from /var/service/qpsmtpd/config/tls_ciphers, which is built using this template:
Quote
{
    # When updating CipherSuite both e-smith-apache and smeserver-qpsmtpd templates should be updated.
    return $qpsmtpd{tlsCipher} || $modSSL{CipherSuite} || 'HIGH:!SSLv2:!ADH:!aNULL:!MD5:!RC4';
}

Take a look at the settings for qpsmtpd tlsCipher:
Code: [Select]
config show qpsmtpd
And for modSSL CipherSuite:
Code: [Select]
config show modSSL
Check out the certificate used by qpsmtpd for TLS:
* It is located at /var/service/qpsmtpd/ssl/cert.pem
* It is created using template "metadata" from /etc/e-smith/templates.metadata/var/service/qpsmtpd/ssl/cert.pem
* It should look like a chain of cerficates
* It should contain entries for "RSA PRIVATE KEY" and at least one "CERTIFICATE":
Code: [Select]
-----BEGIN RSA PRIVATE KEY-----
[block of text here]
-----END RSA PRIVATE KEY-----
-----BEGIN CERTIFICATE-----
[another block of text]
-----END CERTIFICATE-----

Logged

mdombrowski

  • Just popping in
  • Offline Offline
  • Posts: 3
Re: Problem mit SMTP / SSL
« Reply #2 on: December 07, 2017, 02:17:35 PM »

Thanks,

issue is solved. I think, I had installed a perl-module (IO::SOCKET::SSL?) from CPAN, that does not match with SME. After deleteing directory usr/local/share/perl5/IO it works again.


Logged
Pages: [1]   Go Up
 

Page created in 0.038 seconds with 24 queries.