Koozali.org formerly Contribs.org

Who gave SME Sever 10Alpha3 a test run?

Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #30 on: October 17, 2018, 10:25:04 AM »
Short story, this is a bug because I've edit the grub menu entry and replace the two "cdrom" occurence by "usb" and it's work  :smile:
I've mounted the media on my pc to browse the usb-key files : /sme-server/isolinux/isolinux.cfg doen't contain any option for usb

« Last Edit: October 17, 2018, 11:49:56 AM by TerryF »

Offline TerryF

  • *
  • 975
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #31 on: October 17, 2018, 11:43:00 AM »
No exp with the hardware, others may have..

I am not familiar with using Gnome Disk Tools, again others may..

You could try creating the usb using dd as described in the wiki Creating the USB stick on Linux

--
qui scribit bis legit

Offline TerryF

  • *
  • 975
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #32 on: October 17, 2018, 11:50:16 AM »
Short story, this is a bug because I've edit the grub menu entry and replace the two "cdrom" occurence by "usb" and it's work  :smile:
I've mounted the media on my pc to browse the usb-key files : /sme-server/isolinux/isolinux.cfg doen't contain any option for usb

I think you are getting ahead of yourself :-) try dd first as described in the wiki
--
qui scribit bis legit

Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #33 on: October 17, 2018, 03:06:07 PM »
I think you are getting ahead of yourself :-) try dd first as described in the wiki
Seriously ?  :shock:
For your pleasure, to keep doubts and even if this not my first usb-key challenge, I've tried this 10 min ago, it is the same situation : the system asks for a cd-rom source, nothing asks for an usb ressource, something missing in the "isolinux.cfg" file.
I've opened a bug report this morning : https://bugs.contribs.org/show_bug.cgi?id=10632

But now, it is another problem  :-? : I'm unable to assign an ip address in the server configuration (not server-manager)
I've to run "dhclient" to obtain it (this server standalone behind a sme9.2 gateway-server)

Offline TerryF

  • *
  • 975
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #34 on: October 17, 2018, 07:51:34 PM »
Seriously ?  :shock:

Yes, just stabs in the dark, from what I can recall the last usb install I tried would have to be two years ago back in alpha2, have used ISOs for VMS and testing since so certainly just making sure and it saves me doing it :-) lazy? yes,

I do think it is broken

For your pleasure, to keep doubts and even if this not my first usb-key challenge, I've tried this 10 min ago, it is the same situation : the system asks for a cd-rom source, nothing asks for an usb ressource, something missing in the "isolinux.cfg" file.
I've opened a bug report this morning : https://bugs.contribs.org/show_bug.cgi?id=10632

Certainly not for my pleasure, saves questions later.

Raised a Bug? Good

As for the rest, much the same as to date, can't offer a solution sorry.

Hope you continue the testing, keep an eye on bugzilla as there are a lot of issues already reported there further info would be invaluable
--
qui scribit bis legit

Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #35 on: October 18, 2018, 04:28:51 PM »
Don't worry be happy, I will continue  8)
To respond to the post question, I achevied like this and then arrive to connect to server-manager (my choice is server only) :
  • test installation failed with usb key (try many solution to build, same issue, missing redirection on usb media)
  • unable to register setup in config manager, it's bugged, it asks for reboot when setup is finished but recame on it after reboot
  • solution is to fix the ip address => go in tty and type "dhclient" then "yum update" then "reboot" after what the setup is registered and server-manager is accessible

Offline ReetP

  • *
  • 1,593
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #36 on: October 18, 2018, 07:33:13 PM »
We're hoping to get a new ISO out in the not to distant future.

I think the installer issues are down to hacking anaconda which is tricky (way beyongld my pay grade) but will be investigated.

Please keep bashing away and finding/reporting issues.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline TerryF

  • *
  • 975
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #37 on: October 18, 2018, 07:55:37 PM »
Don't worry be happy, I will continue  8)

Fantastic, we are a little short of competent helpers :-)

Yes, definitely a bug in the installer, makes me wonder how long the usb install has been borked for, all testing has been exclusively VM based of recent times or dvd installs were used in early days to hardware.

I hope you are interested enough to want to dig in and help.
--
qui scribit bis legit

Offline TerryF

  • *
  • 975
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #38 on: October 18, 2018, 08:20:53 PM »
Have now also run into this issue due to my testing hardware:

https://bugs.centos.org/view.php?id=9860

https://bugzilla.redhat.com/show_bug.cgi?id=1285235

--
qui scribit bis legit

Offline ReetP

  • *
  • 1,593
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #39 on: October 18, 2018, 08:29:30 PM »
Joy :-)
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline TerryF

  • *
  • 975
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #40 on: October 18, 2018, 09:11:09 PM »
Joy :-)

and you know what my first response is :-)

Resolved that by adding boot time parameter 'initcall_blacklist=clocksource_done_booting this is a known issue and effects other hardware as well, a newer kernel is supposed to fix it

and as krisden did above edited isolinux.cfg from:

label linux
  menu label ^Install Koozali SME Server 10
  kernel vmlinuz
  append initrd=initrd.img inst.stage2=hd:LABEL=SME\x20Server inst.ks=cdrom:/dev/cdrom:/Packages/base/sme-kickstart.cfg quiet

to

label linux
  menu label ^Install Koozali SME Server 10
  kernel vmlinuz
  append initrd=initrd.img initcall_blacklist=clocksource_done_booting inst.stage2=hd:LABEL=SME\x20Server inst.ks=hd:/dev/sdb1:/Packages/base/sme-kickstart.cfg quiet

Now have a running Koozali SME Server 10, server only mode, on my N54L test box that has only seen VMs of late :-)  now to reconfigure box back to using prox :-) details added to bug krisden raised.

Added: Wiki https://wiki.contribs.org/SME_Server:10.0Alpha3#Notes modified re USB install not supported in this release

Didn't have the network problems
« Last Edit: October 19, 2018, 03:32:32 AM by TerryF »
--
qui scribit bis legit

Offline Franco

  • *
  • 1,170
    • http://contribs.org
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #41 on: November 07, 2018, 02:02:47 AM »
Great guys, I have a IBM X3200M running 9.2, maybe it's time for me to test 10  :razz:
I have to say that this machine is a bit fussy on what it runs.

Thanks,

Offline ReetP

  • *
  • 1,593
Re: Who gave SME Sever 10Alpha3 a test run?
« Reply #42 on: November 07, 2018, 10:36:49 AM »
The more testing, the more it helps.

A simple compatibility test is to try a stock CentOS 7 install (check the hardware compatibility lists).

If that runs then SME should.

We hope to get an updated test version out soon. Keep an eye out.
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation