Koozali.org formerly Contribs.org

smdb no access to shares

Offline p1ur

smdb no access to shares
« on: June 07, 2017, 04:42:46 PM »
Hi
I've just discovered that I have a problem with samba i guess. I can't access shares on the server.
I did an update to version 9.2, but there is still no access to shares :-(
This is what I have found in the logfiles:

View log files
/var/log/messages: Viewed at Wed 07 Jun 2017 04:03:17 PM CEST.
Displaying lines matching: "smbd".
Jun  5 11:08:41 server smbd[2587]: [2017/06/05 11:08:41.334237,  0] smbd/server.c:1110(main)
Jun  5 11:08:41 server smbd[2587]:   standard input is not a socket, assuming -D option
Jun  7 15:25:16 server smbd[31098]: [2017/06/07 15:25:16.125969,  0] smbd/process.c:525(init_smb_request)
Jun  7 15:25:16 server smbd[31098]:   init_smb_request: invalid wct number 255 (size 178)
Jun  7 15:25:17 server smbd[31099]: [2017/06/07 15:25:17.138009,  0] smbd/process.c:525(init_smb_request)
Jun  7 15:25:17 server smbd[31099]:   init_smb_request: invalid wct number 255 (size 178)


NEW(after update):
Jun  7 16:33:34 server smbd[2686]: [2017/06/07 16:33:34.827191,  0] smbd/server.c:1110(main)
Jun  7 16:33:34 server smbd[2686]:   standard input is not a socket, assuming -D option
Jun  7 16:34:24 server smbd[3001]: [2017/06/07 16:34:24.652795,  0] smbd/process.c:525(init_smb_request)
Jun  7 16:34:24 server smbd[3001]:   init_smb_request: invalid wct number 255 (size 178)
Jun  7 16:34:25 server smbd[3002]: [2017/06/07 16:34:25.781734,  0] smbd/process.c:525(init_smb_request)
Jun  7 16:34:25 server smbd[3002]:   init_smb_request: invalid wct number 255 (size 178)
Jun  7 16:34:27 server smbd[3003]: [2017/06/07 16:34:27.031948,  0] smbd/process.c:525(init_smb_request)
Jun  7 16:34:27 server smbd[3003]:   init_smb_request: invalid wct number 255 (size 17

Any idea what to do now?

Regards
P1ur
......

Offline p1ur

[Solved (sort off)] smdb no access to shares
« Reply #1 on: June 07, 2017, 05:43:44 PM »
Hi
Just an update to inform, that it is only my own PC (Windos 10) that have the problem. Other pc (including Windows 10 pc's) have access. So I guess this is a problem with my on pc.
/P1ur
......

Re: smdb no access to shares
« Reply #2 on: August 04, 2017, 04:55:34 PM »
Having the same issue, did you ever find a solution?

Offline p1ur

Re: smdb no access to shares
« Reply #3 on: August 04, 2017, 05:43:19 PM »
Hi'
My problem was - i think - that I disabled SMBv1 in Windows 10 due to security issues.
Regards
P1ur
......

guest22

Re: smdb no access to shares
« Reply #4 on: August 04, 2017, 05:49:46 PM »
Hi'
My problem was - i think - that I disabled SMBv1 in Windows 10 due to security issues.
Regards
P1ur


Please inform others what exactly you did to solve your issue. You now say 'was' so it is solved?

Offline p1ur

Re: smdb no access to shares
« Reply #5 on: August 04, 2017, 05:52:07 PM »
A total reinstall of Windows 10 solved the problem.
......

guest22

Re: smdb no access to shares
« Reply #6 on: August 04, 2017, 05:57:45 PM »
So actually not a SME Server problem at all?

Offline p1ur

Re: smdb no access to shares
« Reply #7 on: August 04, 2017, 06:01:15 PM »
Just like I wrote:
"So I guess this is a problem with my on pc."
......

Re: smdb no access to shares
« Reply #8 on: August 05, 2017, 02:01:38 PM »
A total reinstall of Windows 10 solved the problem.
As sure... :D
Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Offline Fredchou

  • *
  • 25
  • Use SME server at home
Re: smdb no access to shares
« Reply #9 on: November 28, 2020, 10:51:57 AM »
I had the same problem with my PC on W10. I managed to solve the problem more simply (without reinstalling W10). If it can help, here is my solution :

1. Use PowerShell in admin mode
2. Check SMB v1 status with command :
Code: [Select]
Get-WindowsOptionalFeature –Online –FeatureName SMB1Protocol3. Disable  SMB v1 with command :
Code: [Select]
Disable-WindowsOptionalFeature -Online -FeatureName SMB1Protocol4. Restart the PC
5. Enable SMB v1 with command :
Code: [Select]
Enable-WindowsOptionalFeature -Online -FeatureName SMB1Protocol6. Restart the PC

https://docs.microsoft.com/fr-fr/windows-server/storage/file-server/troubleshoot/detect-enable-and-disable-smbv1-v2-v3

After this, I could fin again the shared folders of my SME server in the file explorer.
« Last Edit: November 28, 2020, 10:54:13 AM by Fredchou »
Fred Chou

Re: smdb no access to shares
« Reply #10 on: November 28, 2020, 06:13:06 PM »
My solution is a little script restoreshare.cmd
Code: [Select]
net use * /delete /yes
net use z: \\__IP__\__share__ /user:username password /persistent:yes
net use x: \\192.168.50.2\scanner /user:info Passw0rd /persistent:yes
Smeserver.it -  Soluzioni e supporto su Sme server in Italia