Contribs.org

Please login or register.

Login with username, password and session length

News:

We need you! Please help us to make SME Server a better product. More info here

Pages: [1]   Go Down

Author Topic: CLAMD using 100% CPU  (Read 922 times)

edb

  • Wiki & Docs Team
  • *
  • Offline Offline
  • Posts: 488
CLAMD using 100% CPU
« on: January 21, 2017, 04:54:25 AM »

Noticed that my test SME server 10 test server is using 100% CPU by clamd?
Is there a solution for this problem?
I tried stopping clamd and that solves it but a reboot and it is back to 100% cpu usage again.
thanks

-edb
Logged
......

Jean-Philippe Pialasse

  • Site Administrator
  • *
  • Offline Offline
  • Posts: 723
  • aka Unnilennium
    • http://smeserver.pialasse.com
Re: CLAMD using 100% CPU
« Reply #1 on: January 21, 2017, 06:10:00 AM »

Hi,
this should be reported to bugzilla. https://bugs.contribs.org

Please dig some relevant logs  from the situation so we can investigate.
Logged

edb

  • Wiki & Docs Team
  • *
  • Offline Offline
  • Posts: 488
Re: CLAMD using 100% CPU
« Reply #2 on: March 24, 2017, 09:45:47 PM »

Ok after some searching I seem to have found the resolve for this issue on my server.
It appears to have been a permissions issue on the var/clamav folder.

The default install apparently had the permissions on var/clamav as follows:
Group: input [395]
Owner: saslauth [397]

I had to change this to:
Group: clamav [499]
Owner: clamav [499]

Once I changed the permissions and did a
Code: [Select]
freshclam - update virus databases then everything updated fine and the high CPU usage disappeared.
Problem solved!

-edb
Logged
......

georgios

  • Quite a regular
  • **
  • Offline Offline
  • Posts: 62
Re: CLAMD using 100% CPU
« Reply #3 on: May 23, 2017, 01:53:53 PM »

Noticed that my test SME server 10 test server is using 100% CPU by clamd?
Is there a solution for this problem?
I tried stopping clamd and that solves it but a reboot and it is back to 100% cpu usage again.
thanks

-edb

Hi, I dont know if it will help you :

One time I spent one weekend to see why my SME Server was 75% to 100% for 2 days every 30 minutes (CPU used from Sme9Admin).
After checking the logs, I found that one of our user was sending to a university group a news with file attached. And because all the university had a big email problem they were answering us that the message could not be delivered with all the file attached !

in 1 day, our user had +3 giga in his mailbox.

The fact was that there email server was sending us back our mail +100 times in the same time...then CLAMD was scanning the mail and that's why the processus was so ++ HIGH.

did you have checked the logs of your incoming emails?
Logged

Stefano

  • Site Administrator
  • *
  • Offline Offline
  • Posts: 10,393
  • Skype account: maghissimo
    • Smeserver italian community
Re: CLAMD using 100% CPU
« Reply #4 on: May 24, 2017, 10:46:39 AM »

Ok after some searching I seem to have found the resolve for this issue on my server.
It appears to have been a permissions issue on the var/clamav folder.

The default install apparently had the permissions on var/clamav as follows:
Group: input [395]
Owner: saslauth [397]

I had to change this to:
Group: clamav [499]
Owner: clamav [499]

Once I changed the permissions and did a
Code: [Select]
freshclam - update virus databases then everything updated fine and the high CPU usage disappeared.
Problem solved!

-edb

please, report this in Bugzilla, thank you
Logged
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia
Pages: [1]   Go Up
 

Page created in 0.044 seconds with 26 queries.