Koozali.org formerly Contribs.org

Zabbix - missing RPM

Offline Jáder

  • *
  • 1,075
    • LinuxFacil
Zabbix - missing RPM
« on: March 13, 2016, 03:42:34 PM »
I'm trying to restore my ZABBIX config, so I did all install as wiki page but:

Code: [Select]
[root@leopardo ~]# rpm -qa|grep zabbix
zabbix-proxy-2.4.7-1.el5.fws
zabbix-server-mysql-2.4.7-1.el5.fws
zabbix-agent-2.4.7-1.el5.fws
zabbix-proxy-mysql-2.4.7-1.el5.fws
zabbix-2.4.7-1.el5.fws
zabbix-server-2.4.7-1.el5.fws
smeserver-zabbix-agent-0.3.8-1.el5.fws
smeserver-zabbix-proxy-0.2.2-1.el5.fws
zabbix-agent-addons-0.2.7-1


There are no smeserver-zabbix-server anymore ?
I cannot run signal-event signal-event zabbix-server-update because it do not exist!

Can someone tell me what I did wrong ?
Regards.
...

guest22

Re: Zabbix - missing RPM
« Reply #1 on: March 13, 2016, 08:29:58 PM »
You have to wait for Daniel to attend to this question.

Offline Jáder

  • *
  • 1,075
    • LinuxFacil
Re: Zabbix - missing RPM
« Reply #2 on: March 28, 2016, 03:35:37 PM »
Daniel,

Can you help me ?

Regards

You have to wait for Daniel to attend to this question.
...

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
Re: Zabbix - missing RPM
« Reply #3 on: March 29, 2016, 04:34:11 PM »
I do not maintain smeserver-zabbix-server anymore as I do not use it. I still maintain core zabbix RPMS (which BTW are now at version 3.0.1, where the frontend requires PHP 5.4 which won't run on EL5, or on EL6 without the SCL). I also still maintain smeserver-zabbix-agent and smeserver-zabbix-proxy packages.

You should either install Zabbix on a CentOS box, or manually add the missing bits so it starts on SME (symlinks in the rc7.d dir for example). Anyway, last version won't work on SME8 because of the PHP requirements.

Cheers,
Daniel
C'est la fin du monde !!! :lol:

Offline Jáder

  • *
  • 1,075
    • LinuxFacil
Re: Zabbix - missing RPM
« Reply #4 on: March 29, 2016, 06:13:47 PM »
Daniel

That's a REALLY SAD notice: you do not maintain Zabbix packages! :(
I'd like to use Zabbix on my unique server (SME)... now I'm not sure if right path is not migrate to VMWARE (or similar) and install many virtual servers.

Anyways, could you share the src packages from earlier versions (pre-3) so I can learn what need to be done ?

Regards

Jáder
...

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
Re: Zabbix - missing RPM
« Reply #5 on: March 30, 2016, 09:47:32 AM »
That's a REALLY SAD notice: you do not maintain Zabbix packages! :(
No, that's wrong. I still maintain Zabbix packages, except smeserver-zabbix-server. And this for several reasons as I already explained

  • I don't use it anymore so it wasn't tested (it probably required several modifications to work with the latest Zabbix versions)
  • Last Zabbix version requires PHP 5.4, which is not available on el5
  • el5 is reaching EOL, and is missing several features (for example it's not possible to compile Zabbix with encryption support)

You can find the last smeserver-zabbix-server package in the smedev repo (both SRPM and RPM) for SME9. You should first migrate to SME9, then try to see what changes are required.
C'est la fin du monde !!! :lol:

Offline Jáder

  • *
  • 1,075
    • LinuxFacil
Re: Zabbix - missing RPM
« Reply #6 on: April 01, 2016, 11:47:03 AM »
Daniel

There are any ways to use an old version of Zabbix (2.4.x) till I move to SME9?

Thanks

Jáder
...