Koozali.org formerly Contribs.org

phpvirtualbox-5.0 and VirtualBox-5.0

Offline DanB35

  • ****
  • 764
    • http://www.familybrown.org
Re: phpvirtualbox-5.0 and VirtualBox-5.0
« Reply #30 on: August 27, 2015, 09:53:13 PM »
Here's the config information:
Code: [Select]
[root@e-smith ~]# config show vboxweb-service
vboxweb-service=service
    TCPPort=18083
    access=localhost
    status=enabled
[root@e-smith ~]# config show phpvirtualbox
phpvirtualbox=service
    Group=
    Name=phpvirtualbox
    URL=VB
    User=
    status=enabled
    webauth=enabled
......

Offline stephdl

  • *
  • 1,500
    • Linux et Geekeries
Re: phpvirtualbox-5.0 and VirtualBox-5.0
« Reply #31 on: August 29, 2015, 09:00:30 AM »
Here's the config information:
Code: [Select]
[root@e-smith ~]# config show vboxweb-service
vboxweb-service=service
    TCPPort=18083
    access=localhost
    status=enabled
[root@e-smith ~]# config show phpvirtualbox
phpvirtualbox=service
    Group=
    Name=phpvirtualbox
    URL=VB
    User=
    status=enabled
    webauth=enabled

sorry for the delay of my answer, all above looks fine.

I don't know/understand what is occuring, I suppose that your problem is not fixed and after a reboot or a reconfiguration the vboxweb-service must be restarted. Right ?
In fact that service is not a part of phpvirtualbox, but from virtualbox, omething has changed between the version 4.3 to 5. Before the service was launched at S35 without problem.

maybe a (bad) trick could be done in that case of non opened port, put in  /etc/rc.d/rc.local : /etc/init.d/vboxweb-service restart

keep me in touch
See http://wiki.contribs.org/Koozali_Foundation
irc : Freenode #sme_server #sme-fr

!!! Please write your knowledge to the Wiki !!!

Offline DanB35

  • ****
  • 764
    • http://www.familybrown.org
Re: phpvirtualbox-5.0 and VirtualBox-5.0
« Reply #32 on: August 30, 2015, 09:08:10 PM »
I didn't get a chance to reboot until just a few minutes ago.  It's now been two+ minutes since I logged in via ssh, and the watch nmap is still showing port 18083 as closed.  After manually restarting the vboxweb-service, the port is open immediately.
......

Offline Stefano

  • *
  • 10,779
  • Skype account: maghissimo
    • Smeserver italian community
Re: phpvirtualbox-5.0 and VirtualBox-5.0
« Reply #33 on: August 31, 2015, 10:32:40 AM »
I didn't get a chance to reboot until just a few minutes ago.  It's now been two+ minutes since I logged in via ssh, and the watch nmap is still showing port 18083 as closed.  After manually restarting the vboxweb-service, the port is open immediately.

that suggests me that something is failing during the execution of the startup script.. env variable? is there anything relevant in the logs?
what about dmesg?
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Offline stephdl

  • *
  • 1,500
    • Linux et Geekeries
Re: phpvirtualbox-5.0 and VirtualBox-5.0
« Reply #34 on: August 31, 2015, 02:02:38 PM »
I would be interested by

/etc/init.d/vboxweb-service status

just after the reboot

Hard to debug something not reproducible here, what is the history of your server ?
See http://wiki.contribs.org/Koozali_Foundation
irc : Freenode #sme_server #sme-fr

!!! Please write your knowledge to the Wiki !!!