Koozali.org formerly Contribs.org

cannot send or receive emailes

cannot send or receive emailes
« on: July 14, 2015, 11:50:48 AM »
Hi I have problem in sending and receiving emails by sme but i don't know why
I run this command

[root@mserver ~]# tail -f /var/log/qpsmtpd/current | tai64nlocal
2015-07-14 12:44:24.645000500 6072 virus::clamav plugin (data_post): Changing permissions on file to permit scanner access
2015-07-14 12:44:24.648962500 6072 virus::clamav plugin (data_post): clamscan results: ERROR: Can't send to clamd: Broken pipe
2015-07-14 12:44:24.649062500 6072 virus::clamav plugin (data_post): ClamAV error: /usr/bin/clamdscan --stdout  --config-file=/etc/clamd.conf --no-summary /var/spool/qpsmtpd/1436867049:6072:0 2>&1: 2
2015-07-14 12:44:24.649067500
2015-07-14 12:44:24.649855500 6072 logging::logterse plugin (deny): ` 192.168.1.84      pc-00084.altawi.com.sa  puradnanjed     <sohail@altawi.com.sa>  <arif@altawi.com.sa>,<control@altawi.com.sa>    virus::clamav   902             msg denied before queued
2015-07-14 12:44:24.650138500 6072 452 Message denied temporarily
2015-07-14 12:44:27.148556500 6072 dispatching QUIT
2015-07-14 12:44:27.148562500 6072 221 altawi.com.sa closing connection. Have a wonderful day.
2015-07-14 12:44:27.148565500 6072 click, disconnecting
2015-07-14 12:44:28.056648500 4410 cleaning up after 6072

and when i run this command
Last login: Tue Jul 14 12:44:27 2015 from 192.168.1.105
[root@mserver ~]# tail -f /var/log/sqpsmtpd/current | tai64nlocal
2015-07-14 12:18:53.575997500 4407 tls plugin (init): ciphers: HIGH
2015-07-14 12:18:53.957795500 4407 Listening on 0.0.0.0:465
2015-07-14 12:18:53.958179500 4407 Running as user qpsmtpd, group qpsmtpd
2015-07-14 12:18:53.958261500 4407 Initializing spool_dir
2015-07-14 12:18:54.095362500 4407 Permissions on spool_dir /var/spool/qpsmtpd/ are not 0700
2015-07-14 12:18:54.095567500 4407 size_threshold set to 0
What the problem
i test status of server the internet success connected to server
I can send locally
but outside cannot send or receive


Re: cannot send or receive emailes
« Reply #1 on: July 14, 2015, 11:59:54 AM »
Im sorry this post is wrong
thanks
i will added again but in success formate

Offline Stefano

  • *
  • 10,796
  • Skype account: maghissimo
    • Smeserver italian community
Re: cannot send or receive emailes
« Reply #2 on: July 14, 2015, 12:04:57 PM »

Quote
2015-07-14 12:44:24.649062500 6072 virus::clamav plugin (data_post): ClamAV error: /usr/bin/clamdscan --stdout  --config-file=/etc/clamd.conf --no-summary /var/spool/qpsmtpd/1436867049:6072:0 2>&1:2015-07-14 12:44:24.6490675002015-07-14 12:44:24.649855500 6072 logging::logterse plugin (deny): ` 192.168.1.84      pc-00084.altawi.com.sa  puradnanjed     <sohail@altawi.com.sa>  <arif@altawi.com.sa>,<control@altawi.com.sa>    virus::clamav   902             msg denied before queued



in bold you see the error.. search the wiki, bugzilla and forums
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

guest22

Re: cannot send or receive emailes
« Reply #3 on: July 14, 2015, 12:17:33 PM »
2015-07-14 12:44:24.648962500 6072 virus::clamav plugin (data_post): clamscan results: ERROR: Can't send to clamd: Broken pipe


This tells me something is wrong.... Clam will not relay messages until this is solved.

Re: cannot send or receive emailes
« Reply #4 on: July 14, 2015, 12:29:00 PM »
Thank you for reply
My problem i don't have send or receive the emails to outside domain
what command show to me error in sending or recieving

Offline Stefano

  • *
  • 10,796
  • Skype account: maghissimo
    • Smeserver italian community
Re: cannot send or receive emailes
« Reply #5 on: July 14, 2015, 12:34:38 PM »
ahmedsa: you already told us your issue and you've got some advices to solve your issue..

you ask for the error.. well.. you can see it (read it) in your original post, in mine and in RequestedDeletion's one..
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Re: cannot send or receive emailes
« Reply #6 on: July 14, 2015, 12:54:55 PM »
OK can you permit for me to close this post
i will add in new post because
error above in message different about what i need

Offline Stefano

  • *
  • 10,796
  • Skype account: maghissimo
    • Smeserver italian community
Re: cannot send or receive emailes
« Reply #7 on: July 14, 2015, 01:04:19 PM »
no need to close anything..
proceed
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Re: cannot send or receive emailes
« Reply #8 on: July 14, 2015, 01:46:28 PM »
Let us start from this point
I face problem in sending and receiving to outside my domain what i check now

Re: cannot send or receive emailes
« Reply #9 on: July 14, 2015, 02:24:28 PM »
ahmedsa: you already told us your issue and you've got some advices to solve your issue..

you ask for the error.. well.. you can see it (read it) in your original post, in mine and in RequestedDeletion's one..

Stefano, I searched for the term you highlighted above, and don't find any obviously relevant posts. If you know what the problem is, please state it plainly.

Otherwise ahmedsa should be posting a good clear problem description to bugzilla. Yes, there is a problem with clamav scanning, but I don't know what it is or how to fix it. Do you?

It seems to me that ahmedsa doesn't have English as a first language. Please bear that in mind.

Re: cannot send or receive emailes
« Reply #10 on: July 14, 2015, 02:27:29 PM »
ahmedsa, look in the logfile /var/log/clamd/current. You may find important information there.

Also, show the output of:

sv status /service/clamd
config show clamd
« Last Edit: July 14, 2015, 02:32:51 PM by CharlieBrady »

Re: cannot send or receive emailes
« Reply #11 on: July 15, 2015, 12:03:08 PM »
until now no send or receive
Yesterday from 11 to 2 not work MEANING NO SEND NO RECEIVE
after that work
Today
from 11 until now not working
i need to know what is the problem

Re: cannot send or receive emailes
« Reply #12 on: July 15, 2015, 12:04:56 PM »
the output of command
[root@mserver ~]# sv status /service/clamd
run: /service/clamd: (pid 11805) 80681s, normally down; run: log: (pid 3434) 89119s

[root@mserver ~]# config show clamd
clamd=service
    MemLimit=600000000
    status=enabled
[root@mserver ~]#

Offline Stefano

  • *
  • 10,796
  • Skype account: maghissimo
    • Smeserver italian community
Re: cannot send or receive emailes
« Reply #13 on: July 15, 2015, 12:53:47 PM »
ok, my bad :-)

ahmedsa, please post here the result of
Code: [Select]
grep -i denied /var/log/clamd/current

are you using Clamav unofficial sigs on your server?
did you try to increase MemLimit value (for example to 700000000)?
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Re: cannot send or receive emailes
« Reply #14 on: July 15, 2015, 02:42:51 PM »
i need to know what is the problem

And if you want us to help you find that, you need to provide the information which we request. Did look in the logfile /var/log/clamd/current as requested?

Restarting clamd might help. You can do that with 'sv t /service/clamd'.

All we know is "clamscan results: ERROR: Can't send to clamd: Broken pipe". That means that when qpsmtpd was sending the message content to clamd via a socket, clamd closed the socket before reading the full message.

We need to know what is in the clamd logs.