Koozali.org formerly Contribs.org

SOLVED - yum and webmail broken

SOLVED - yum and webmail broken
« on: July 08, 2015, 11:54:45 AM »
I probably broke something while doing some contrib updates. The first I found out that webmail wasn't working. log files gave the following:

Code: [Select]
Jul  8 09:56:10 [servername] httpd: PHP Warning:  require_once(DB.php) [<a href='function.require-once'>function.require-once</a>]: failed to open stream: File or Folder doen't excist in /home/httpd/html/horde/lib/Horde/DataTree/sql.php on line 1881
Jul  8 09:56:10 [servername] httpd: PHP Fatal error:  require_once() [<a href='function.require'>function.require</a>]: Failed opening required 'DB.php' (include_path='/home/httpd/html/horde/lib:/usr/share/pear-addons:/usr/share/pear') in /home/httpd/html/horde/lib/Horde/DataTree/sql.php on line 1881

yum doesn't seem to be working either. Trying to run it in a shell gives:

Code: [Select]
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was:

   No module named cElementTree

Please install a package which provides this module, or
verify that the module is installed correctly.

It's possible that the above module doesn't match the
current version of Python, which is:
2.4.3 (#1, Jan  9 2013, 06:47:03)
[GCC 4.1.2 20080704 (Red Hat 4.1.2-54)]

If you cannot solve this problem yourself, please go to
the yum faq at:
  http://wiki.linux.duke.edu/YumFaq

Running SME Server 8.1 x64
Any suggestions would be helpfull
« Last Edit: July 08, 2015, 06:56:17 PM by TerryF »
...
Yes, I can ask more questions then you can answer  8-)
...

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
Re: yum and webmail broken
« Reply #1 on: July 08, 2015, 12:23:12 PM »
It'd help to know what you did, but it looks like you messed up your server. Can you check the last yum transactions:

Code: [Select]
grep yum /var/log/messages
C'est la fin du monde !!! :lol:

Re: yum and webmail broken
« Reply #2 on: July 08, 2015, 12:34:24 PM »
This is from a few days ago. I didn't pick up on the problem until today, since server-manager is working as are the other websites I am running. Mail is still being processed and I can receive by pop.

Entry at Jul  3 09:07:45 does mention python-elementtree

Code: [Select]
Jul  3 09:03:23 nathan yum: Updated: 2:irqbalance-0.55-16.el5_11.x86_64
Jul  3 09:03:25 nathan yum: Updated: qpsmtpd-0.84-9.el5.sme.noarch
Jul  3 09:03:27 nathan yum: Updated: e-smith-hosts-2.2.0-13.el5.sme.noarch
Jul  3 09:03:29 nathan yum: Updated: e-smith-ldap-5.2.0-81.el5.sme.noarch
Jul  3 09:03:31 nathan yum: Updated: smeserver-support-2.2.0-28.el5.sme.noarch
Jul  3 09:03:40 nathan /etc/e-smith/events/actions/initialize-default-databases[15816]: /home/e-smith/db/yum_repositories: OLD base=repository|EnableGroups|no|Exclude|initscripts,libgsf,openssl|GPGCheck|yes|MirrorList|http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os|Name|CentOS - os|Visible|yes|status|enabled
Jul  3 09:03:40 nathan /etc/e-smith/events/actions/initialize-default-databases[15816]: /home/e-smith/db/yum_repositories: NEW base=repository|EnableGroups|no|Exclude|initscripts,libgsf|GPGCheck|yes|MirrorList|http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os|Name|CentOS - os|Visible|yes|status|enabled
Jul  3 09:03:40 nathan /etc/e-smith/events/actions/initialize-default-databases[15816]: /home/e-smith/db/yum_repositories: OLD updates=repository|EnableGroups|no|Exclude|initscripts,libgsf,openssl|GPGCheck|yes|MirrorList|http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates|Name|CentOS - updates|Visible|yes|status|enabled
Jul  3 09:03:40 nathan /etc/e-smith/events/actions/initialize-default-databases[15816]: /home/e-smith/db/yum_repositories: NEW updates=repository|EnableGroups|no|Exclude|initscripts,libgsf|GPGCheck|yes|MirrorList|http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates|Name|CentOS - updates|Visible|yes|status|enabled
Jul  3 09:07:11 nathan yum: Installed: perl-Params-Util-1.00-1.el4.rf.x86_64
Jul  3 09:07:15 nathan yum: Installed: openssl097a-0.9.7a-12.el5_10.1.x86_64
Jul  3 09:07:16 nathan yum: Updated: perl-Net-SSLeay-1.36-1.el4.rf.x86_64
Jul  3 09:07:18 nathan yum: Installed: radiusclient-ng-0.5.6-5.el4.rf.x86_64
Jul  3 09:07:19 nathan yum: Installed: perl-Algorithm-Dependency-1.110-1.el4.rf.noarch
Jul  3 09:07:20 nathan yum: Installed: perl-File-Remove-1.42-1.el4.rf.noarch
Jul  3 09:07:21 nathan yum: Installed: perl-Config-Tiny-2.12-1.el4.rf.noarch
Jul  3 09:07:22 nathan yum: Installed: perl-File-chmod-0.32-1.el4.rf.noarch
Jul  3 09:07:23 nathan yum: Installed: perl-Test-Pod-1.40-1.el4.rf.noarch
Jul  3 09:07:24 nathan yum: Updated: perl-MailTools-2.12-1.el4.rf.noarch
Jul  3 09:07:24 nathan yum: Installed: perl-File-Slurp-9999.13-1.el4.rf.noarch
Jul  3 09:07:26 nathan yum: Installed: php-pear-db-1.7.13-2.el4.rf.noarch
Jul  3 09:07:27 nathan yum: Updated: perl-BSD-Resource-1.2903-1.el4.rf.x86_64
Jul  3 09:07:27 nathan yum: Installed: radiusclient-ng-utils-0.5.6-5.el4.rf.x86_64
Jul  3 09:07:31 nathan yum: Updated: proftpd-1.3.4a-1.el4.rf.x86_64
Jul  3 09:07:32 nathan yum: Updated: perl-Test-Inline-2.210-1.el4.rf.noarch
Jul  3 09:07:36 nathan yum: Updated: awstats-7.1-1.el4.rf.noarch
Jul  3 09:07:37 nathan yum: Installed: perl-Date-Manip-5.56-1.el4.rf.noarch
Jul  3 09:07:37 nathan yum: Updated: fping-3.10-1.el4.rf.x86_64
Jul  3 09:07:43 nathan yum: Updated: phpvirtualbox-4.3.3-1.el5.sme.noarch
Jul  3 09:07:43 nathan yum: Updated: perl-Convert-TNEF-0.18-1.el4.rf.noarch
Jul  3 09:07:45 nathan yum: Updated: python-elementtree-1.2.6-7.el4.rf.x86_64
Jul  3 09:07:46 nathan yum: Erased: php-pear-DB
Jul  3 09:07:49 nathan yum: Erased: radiusclient
Jul  3 09:07:56 nathan yum: Erased: perl-DateManip
Jul  3 09:30:40 nathan esmith::event[17244]: Migrating existing database yum_available 
Jul  3 09:30:40 nathan esmith::event[17244]: Migrating existing database yum_updates 
Jul  3 09:30:40 nathan esmith::event[17244]: Migrating existing database yum_repositories 
Jul  3 09:30:40 nathan esmith::event[17244]: Migrating existing database yum_installed
...
Yes, I can ask more questions then you can answer  8-)
...

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
Re: yum and webmail broken
« Reply #3 on: July 08, 2015, 12:41:07 PM »
You have:

- Removed php-pear-DB which is required for the webmail
- Your python-elementtree is an el4 version. I have no idea where this comes from, but as you're running an x86_64 system, it cannot be from an upgraded SME7

You most likely have badly configured some repository, or you ran a dangerous

Code: [Select]
yum --enablerepo=rpmforge update

(or similar)

Please, show your yum config:
Code: [Select]
db yum_repositories show

And look in your bash history (/root/.bash_history) the exact yum command you typed
C'est la fin du monde !!! :lol:

Re: yum and webmail broken
« Reply #4 on: July 08, 2015, 12:44:57 PM »
I ran:
Code: [Select]
yum update --enablerepo=stephd1,virtualbox,dag
db yum_repositories show:
Code: [Select]
addons=repository
    EnableGroups=no
    GPGCheck=yes
    MirrorList=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=addons
    Name=CentOS - addons
    Visible=no
    status=disabled
base=repository
    EnableGroups=no
    Exclude=initscripts,libgsf
    GPGCheck=yes
    MirrorList=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=os
    Name=CentOS - os
    Visible=yes
    status=enabled
centosplus=repository
    EnableGroups=no
    GPGCheck=yes
    MirrorList=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=centosplus
    Name=CentOS - centosplus
    Visible=no
    status=disabled
contrib=repository
    EnableGroups=no
    GPGCheck=yes
    MirrorList=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=contrib
    Name=CentOS - contrib
    Visible=no
    status=disabled
dag=repository
    BaseURL=http://apt.sw.be/redhat/el4/en/$basearch/dag
    EnableGroups=no
    Exclude=freetype,htop,iptraf,rsync,syslinux
    GPGCheck=yes
    GPGKey=http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt
    Name=Dag - EL4
    Visible=no
    status=disabled
epel=repository
    BaseUrl=http://download.fedoraproject.org/pub/epel/5/$basearch
    EnableGroups=no
    GPGCheck=yes
    GPGKey=http://dl.fedoraproject.org/pub/epel/RPM-GPG-KEY-EPEL
    MirrorList=http://mirrors.fedoraproject.org/mirrorlist?repo=epel-5&arch=$basearch
    Name=Epel - EL5
    Visible=no
    status=disabled
extras=repository
    EnableGroups=no
    GPGCheck=yes
    MirrorList=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=extras
    Name=CentOS - extras
    Visible=no
    status=disabled
fws=repository
    BaseURL=http://repo.firewall-services.com/centos/$releasever
    EnableGroups=no
    GPGCheck=yes
    GPGKey=http://repo.firewall-services.com/RPM-GPG-KEY
    Name=Firewall Services
    Visible=yes
    status=disabled
smeaddons=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeaddons-8
    Name=SME Server - addons
    Visible=yes
    status=enabled
smecontribs=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smecontribs-8
    Name=SME Server - contribs
    Visible=no
    status=disabled
smedev=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smedev-8
    Name=SME Server - dev
    Visible=no
    status=disabled
smeextras=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeextras-8
    Name=SME Server - extras
    Visible=yes
    status=enabled
smeos=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeos-8
    Name=SME Server - os
    Visible=yes
    status=enabled
smetest=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smetest-8
    Name=SME Server - test
    Visible=no
    status=disabled
smeupdates=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeupdates-8
    Name=SME Server - updates
    Visible=yes
    status=enabled
smeupdates-testing=repository
    EnableGroups=yes
    GPGCheck=yes
    MirrorList=http://mirrorlist.contribs.org/mirrorlist/smeupdates-testing-8
    Name=SME Server - updates testing
    Visible=yes
    status=disabled
stephdl=repository
    BaseURL=http://mirror.de-labrusse.fr/smeserver/$releasever
    EnableGroups=no
    GPGCheck=yes
    GPGKey=http://mirror.de-labrusse.fr/RPM-GPG-KEY
    Name=Mirror de Labrusse
    Visible=yes
    status=disabled
updates=repository
    EnableGroups=no
    Exclude=initscripts,libgsf
    GPGCheck=yes
    MirrorList=http://mirrorlist.centos.org/?release=$releasever&arch=$basearch&repo=updates
    Name=CentOS - updates
    Visible=yes
    status=enabled
virtualbox=repository
    BaseURL=http://download.virtualbox.org/virtualbox/rpm/rhel/$releasever/$basearch
    EnableGroups=no
    GPGCheck=yes
    GPGKey=http://download.virtualbox.org/virtualbox/debian/oracle_vbox.asc
    Name=RHEL/CentOS-$releasever / $basearch - VirtualBox
    Visible=no
    status=disabled
...
Yes, I can ask more questions then you can answer  8-)
...

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
Re: yum and webmail broken
« Reply #5 on: July 08, 2015, 12:52:29 PM »
Well, this is your problem:

- You have badly configured the dag repo (configured for el4 while SME8 is based on el5)
- Do not, ever, under any circumstances run a global yum update with 3rd party repo enabled (like dag, epel, atrpms etc...). Only enable those repo to update specific rpm (specified on the command line)

Now, you should:

- Fix your dag repo config, see http://wiki.contribs.org/Dag#tab=For_SME_8
- Try to downgrade python-elementtree which should be version 1.2.6-5.0, and all your perl modules you've wrongly upgraded

Code: [Select]
yum downgrade python-elementtree perl-Net-SSLeay perl-MailTools proftpd perl-BSD-Resource perl-Test-Inline perl-Convert-TNEF fping

- Try to reinstall php-pear-DB:

Code: [Select]
yum install php-pear-DB

You'll most likely have dependencies issue you'll have to deal with. Unless you're comfortable with yum and manually playing with rpm, you should reinstall your server and restore a backups

C'est la fin du monde !!! :lol:

Re: yum and webmail broken
« Reply #6 on: July 08, 2015, 01:46:46 PM »
yum downgrade didn't work, since yum isn't working.

Used ftp to get the python-elementtree rpm
ran rpm -qa | grep python-elementtree  to find out the package name

rpm -e python-elementree-1.2.6-7.el4.rf --nodeps
rpm -ivh python-elementtree-1.2.6-5.0.X86_64.rpm
This got yum running again

After reboot I ran (reboot wasn't needed, but it felt right):
yum install php-pear-DB
This fixed webmail

ran yum downgrade python-elementtree perl-Net-SSLeay perl-MailTools proftpd perl-BSD-Resource perl-Test-Inline perl-Convert-TNEF fping

THANKS!
...
Yes, I can ask more questions then you can answer  8-)
...