Koozali.org formerly Contribs.org

FOP2 needs dial plan options, how?

Offline psoren

  • *
  • 368
FOP2 needs dial plan options, how?
« on: December 16, 2014, 10:39:09 PM »
Hi

I have installed the FOP2 panel and in order to get that fully functional, i need to "enable tT as dial option".
I have no clue what that is and can not find it in the SAIL panel.

Can anyone help?

Per

Offline SARK devs

  • ****
  • 2,806
    • http://sarkpbx.com
Re: FOP2 needs dial plan options, how?
« Reply #1 on: December 19, 2014, 04:17:25 PM »
Hi Per

SAIL will use Tt on an internal dial,  t on an inbound dial and T on an outbound dial.

These parameters control which end of a call (T -> send, t -> receive) can initiate a transfer using DTMF tones.   I'm not a FOP expert but I'm surprised it needs or uses this method of transfer. 

Kind Regards

S

Offline psoren

  • *
  • 368
Re: FOP2 needs dial plan options, how?
« Reply #2 on: December 19, 2014, 06:47:23 PM »
Hi,

Yes it seems a little "out of date" on a new version like that.
Here is excactly what i got from the guys at FOP2 support:

"you must enable tT as dial options for transfers to work"

So how do i get around this?

Thanks

Per

Offline SARK devs

  • ****
  • 2,806
    • http://sarkpbx.com
Re: FOP2 needs dial plan options, how?
« Reply #3 on: December 20, 2014, 01:17:28 PM »
I don't think you need to.   SAIL is doing what they ask I think.  The two "T"s are independent.  Let me exemplify.  Here are the three dials sail will do (these aren't syntactically correct but you get the idea).

internal call

Code: [Select]
dial 401,Tt
This allows either end to transfer the call using DTMF

outbound (from internal to external)

Code: [Select]
dial somenumber,T
This allows the caller ONLY to transfer the call using DTMF.  This is correct when you think about it since you don't want the external callee to be able to initiate a transfer

inbound (from external to extension)

Code: [Select]
dial 401,t
This allows the callee (extension) ONLY to transfer the call using DTMF.  This is correct when you think about it since you don't want the external caller to be able to initiate a transfer.

In any event, it is my understanding that FOP initiates transfers using the AMI so I think this is all irrelevant, at least as far as FOP is concerned, but as I said I'm not an expert.

SAIL can/does generate the control files for FOP when it creates sip.conf and we have quite a few customers who use FOP2.  However, having said that, I can't think of any who use it to do drag/drop transfers and this is why I can't give you an absolutely definitive answer.  Have you spun it up and tried it yourself or are you still in the planning stage?

Offline psoren

  • *
  • 368
Re: FOP2 needs dial plan options, how?
« Reply #4 on: December 30, 2014, 12:14:47 AM »
Hi again, hope you had some good holiday :)

Here is the reply from the FOP2 support regarding the info you provided:



Hi,

FOP2 uses the manager AtxFer command, that command requires the tT options in the Dial command for it to work, otherwise, you will actually hear the DTMF on the phone (the sympton you described when attempted an attendant transfer). So, my guess is that the relevant t or T option is not set for the dial command.

For blind transfers, then FOP2 uses a different command (Redirect) that does not require any special option in dial, and is irrelevant as the sail developer points out, but for attendant transfer, it is mandatory as the asterisk function requires it.

So, if you hear DTMF when trying an attendant transfer, then the t option is not set.

Best regards,

Nicolás Gudiño


This system is already up running and have been running for a year or so and it's SAIL 3.1.1-27


Thanks
Per



Offline SARK devs

  • ****
  • 2,806
    • http://sarkpbx.com
Re: FOP2 needs dial plan options, how?
« Reply #5 on: December 31, 2014, 07:23:12 PM »
OK the next step is to send me a copy of the asterisk console showing the sail dial that isn't doing what you want.

You may need to turn agi debugging on with

Code: [Select]
agi set debug on
Turn it off when you've finished with

Code: [Select]
agi set debug off
Kind Regards
S


Offline psoren

  • *
  • 368
Re: FOP2 needs dial plan options, how?
« Reply #6 on: February 05, 2015, 08:56:17 PM »
Hi again

Sorry for the long reply time, but i do a lot of travelling in my job

The output on the console with "agi set debug on", is absolutely nothing........
I only hear DTMF tones in the phone i dial in from and they correspond to the ext. i am trying to transfer to.

Per

Offline SARK devs

  • ****
  • 2,806
    • http://sarkpbx.com
Re: FOP2 needs dial plan options, how?
« Reply #7 on: February 14, 2015, 07:04:47 PM »
Hi Per

More recently, we've had some further experience with blind and attended transfer using the AMI.   We integrated a product called iSymphony for a UK customer.    It transfers just fine using the AMI and an unmodified SARK V4.0.0.   I mention this as a control reference to demonstrate that we do set the Tt correctly for hash transfer on inbound and outbound calls. 

There must be something happening at the asterisk console when the call arrives or else Asterisk isn't processing it. We do set the dial parameters when the initial outbound call is made or the internal extension is initially called and that's what I wanted to see.  Can you send me that?

Another thought occurs.   On older systems, you were able to turn hash transfer on and off; there was a switch in globals panel called "allow hash transfer".   This was removed in later releases and all new installs defaulted to allowing it.   Now, it may be disabled on your system.

check it with this command at the console

Code: [Select]
sqlite3 /opt/sark/db/sark.db 'select ALLOWHASHXFER from globals;'
It should be set to enabled

Kind Regards

S