Koozali.org formerly Contribs.org

Security Update - Moderate - RH EL5 - libxml2 packages

Offline TerryF

  • grumpy old man
  • *
  • 1,527
Security Update - Moderate - RH EL5 - libxml2 packages
« on: November 21, 2014, 08:31:48 PM »
Red Hat has released a security update for EL5 that will apply to SME8.

Update will be available from upstream repos as appropriate.

For full notice go to:
https://www.redhat.com/archives/rhsa-announce/2014-November/msg00043.html

and CentOS:
http://lists.centos.org/pipermail/centos-announce/2014-November/020775.html

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Moderate: libxml2 security update
Advisory ID:       RHSA-2014:1885-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://rhn.redhat.com/errata/RHSA-2014-1885.html
Issue date:        2014-11-20
CVE Names:         CVE-2014-3660
=====================================================================

1. Summary:

Updated libxml2 packages that fix one security issue are now available for
Red Hat Enterprise Linux 5.

Red Hat Product Security has rated this update as having Moderate security
impact. A Common Vulnerability Scoring System (CVSS) base score, which
gives a detailed severity rating, is available from the CVE link in the
References section.

2. Relevant releases/architectures:

RHEL Desktop Workstation (v. 5 client) - i386, x86_64
Red Hat Enterprise Linux (v. 5 server) - i386, ia64, ppc, s390x, x86_64
Red Hat Enterprise Linux Desktop (v. 5 client) - i386, x86_64

3. Description:

The libxml2 library is a development toolbox providing the implementation
of various XML standards.

A denial of service flaw was found in libxml2, a library providing support
to read, modify and write XML and HTML files. A remote attacker could
provide a specially crafted XML file that, when processed by an application
using libxml2, would lead to excessive CPU consumption (denial of service)
based on excessive entity substitutions, even if entity substitution was
disabled, which is the parser default behavior. (CVE-2014-3660)

All libxml2 users are advised to upgrade to these updated packages, which
contain a backported patch to correct this issue. The desktop must be
restarted (log out, then log back in) for this update to take effect.
--
qui scribit bis legit