Koozali.org formerly Contribs.org

SoGo unable to access users email after upgrade to 2.2.7-1

Re: SoGo unable to access users email after upgrade to 2.2.7-1
« Reply #30 on: August 19, 2014, 09:16:01 AM »
This is not obviously a regular behaviour of Sogo; I'll investigate in SOGo forum if this is a known issue or something affecting only the sme install.
Maybe we can add it as a warning in wiki page concerning SOGo.

Nicola

P.S.: le cul bordé de nouille = avere un culo grosso come una casa  :-D
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia.

Re: SoGo unable to access users email after upgrade to 2.2.7-1
« Reply #31 on: August 19, 2014, 09:39:31 AM »
Added:
http://wiki.contribs.org/Sogo#Mixed_warnings

Please check if I get the correct interpretation.

Nicola
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia.

Re: SoGo unable to access users email after upgrade to 2.2.7-1
« Reply #32 on: August 19, 2014, 10:34:12 AM »
Nicola

That looks good to me.

Cheers
Tony
...

Offline stephdl

  • *
  • 1,507
    • Linux et Geekeries
Re: SoGo unable to access users email after upgrade to 2.2.7-1
« Reply #33 on: August 19, 2014, 05:32:00 PM »
Your Italian translation is really close than mine, funny to see foreign expressions  :lol:

In order to be serious one minute and no more, I would share some thoughts

-why the admin user wasn't affected : maybe the admin user is not a full ldap user ????
-why this bug occured : I have no ideas and I would to try to recreate it
-which events I could add to sogo-modify in order to solve automatically this bug :
group-create or group-modify
password-modify
or maybe simply call an action S95ldap-update-simple

Look the /var/log/messages snippet i did

The goal is 'clear' for me, I would avoid to see again that bug
See http://wiki.contribs.org/Koozali_Foundation
irc : Freenode #sme_server #sme-fr

!!! Please write your knowledge to the Wiki !!!

Re: SoGo unable to access users email after upgrade to 2.2.7-1
« Reply #34 on: August 19, 2014, 06:13:49 PM »
- admin is assigned by default to root/admin group;
- I've found some issue in SOGo bugtracker concerning ldap group but nothing really similar to our issue; I'll dig again;

But . . . . . the issue affects only not grouped users or all of them until there's at least one not grouped ? I hope the first.

A user not in a group is an unusual condition, I'll focus how to work-around this; maybe all is originated by the fact that we do not really use LDAP for user auth for Samba, Mail & company.

Nicola
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia.

Offline stephdl

  • *
  • 1,507
    • Linux et Geekeries
Re: SoGo unable to access users email after upgrade to 2.2.7-1
« Reply #35 on: August 19, 2014, 06:55:57 PM »
- admin is assigned by default to root/admin group;
- I've found some issue in SOGo bugtracker concerning ldap group but nothing really similar to our issue; I'll dig again;
Thanks to dig nicola

Quote
But . . . . . the issue affects only not grouped users or all of them until there's at least one not grouped ? I hope the first.
In fact Tony is a lucky man, Three servers affected by the same bug

One sme8  production server with smeserver (and sogo ?) upgraded to my rpm but with existent group(s) and users. I believe in microsoft worksgroup (in  server and gateway ?)
One sme8 server at home, first installation of smeserver-sogo, without group and users. I believe in microsoft master of domains  (in  server and gateway ?)
One sme9 test server , first installation of  smeserver-sogo, without group and users.  I believe in microsoft worksgroup in  server and gateway.

There is not shared configuration :( : @Tony can you confirm these configurations

Quote
A user not in a group is an unusual condition, I'll focus how to work-around this; maybe all is originated by the fact that we do not really use LDAP for user auth for Samba, Mail & company.

Yes you are right I would that all users are in a group, it makes me sense, but I'm not sure that it is the cause. I need the feedback of Daniel, it is my Ldap man and moreover one of my sme guru.

Of course if someone gets the solution, please shout :)

Nicola
[/quote]
See http://wiki.contribs.org/Koozali_Foundation
irc : Freenode #sme_server #sme-fr

!!! Please write your knowledge to the Wiki !!!

Re: SoGo unable to access users email after upgrade to 2.2.7-1
« Reply #36 on: August 19, 2014, 10:07:14 PM »
Just to confirm what my setup is:
You were almost correct.

One sme8  production server (at Home) with smeserver (and sogo ?) upgraded to my rpm but with existent group(s) and users. In microsoft master of domains (in  server and gateway ?)
One sme9 test server , first installation of  smeserver-sogo, without group and users.  In microsoft workgroup in  server only mode. (This is the server that will replace my current home production server)
One sme9 server at work, first installation of smeserver-sogo, without group and users. In microsoft workgroup inside a full windows AD domain  (in  server and gateway ?)

If you need further clarification just ask.

Cheers
Tony
...