Koozali.org formerly Contribs.org

SME Server 9 - System Encryption ?

Offline fpausp

  • *
  • 728
SME Server 9 - System Encryption ?
« on: October 06, 2013, 07:44:35 PM »
Hi, I was able to install sme9 as a vm under proxmox. At the moment there is a gui to install the server, I tried to use the point for system encryption and it worked very well.

Is this feature also available in the final version of sme9 ?


regards
frank
Viribus unitis

Offline wellsi

  • *
  • 475
    • http://www.wellsi.com
Re: SME Server 9 - System Encryption ?
« Reply #1 on: October 09, 2013, 04:36:40 AM »
No decision yet.

Personally I like the GUI option.
............

Offline fpausp

  • *
  • 728
Re: SME Server 9 - System Encryption ?
« Reply #2 on: October 10, 2013, 04:40:02 PM »
OK, thanks ...
Viribus unitis

Offline fpausp

  • *
  • 728
Re: SME Server 9 - System Encryption ?
« Reply #3 on: November 11, 2013, 09:59:41 AM »
Tried to install sme9b2 on cryptfs, sme9 beta 2 has the textinstaller as default but it is possible to modify the bootoptions (deleted the option "text" to get the gui-installer).

I got the gui-installation but failed to install it on ...,

Code: [Select]
'LVMPhysicalVolume' object has no attribute 'mapName'

can anyone confirm with me that the cryptofs installation is not possible yet ?
« Last Edit: November 11, 2013, 10:05:25 AM by fpausp »
Viribus unitis

Re: SME Server 9 - System Encryption ?
« Reply #4 on: November 19, 2013, 07:37:45 PM »
can anyone confirm with me that the cryptofs installation is not possible yet ?

You've verified that yourself.

The python exception you've shown indicates a bug in anaconda - a mismatch in API between calling code and the called code.

And I find it here - closed "WONTFIX" by Red Hat:

https://bugzilla.redhat.com/show_bug.cgi?id=526975

Offline fpausp

  • *
  • 728
Re: SME Server 9 - System Encryption ?
« Reply #5 on: November 19, 2013, 08:27:59 PM »
Thank you for your info, I just wondered because I was able to do it with beta 1 ...
Viribus unitis

Offline Daniel B.

  • *
  • 1,697
    • Firewall Services, la sécurité des réseaux
Re: SME Server 9 - System Encryption ?
« Reply #6 on: December 03, 2013, 07:47:03 PM »
Don't expect this to be supported, but FYI I have no problem installing SME 9.0b3 with LUKS. I used a ext4 over LUKS over LVM over RAID setup (only tried to crypt / and swap)
C'est la fin du monde !!! :lol: