Koozali.org formerly Contribs.org

Update failed because of postgresql

Update failed because of postgresql
« on: September 20, 2013, 11:58:57 AM »
Hello!

I am trying to update from 7.6 to SME 8, but there is a problem with postgresql:

Error: Missing Dependency: libssl.so.4 is needed by package postgresql-contrib
Error: Missing Dependency: libcrypto.so.4 is needed by package postgresqlclient7
Error: Missing Dependency: libreadline.so.4 is needed by package postgresql-server
Error: Missing Dependency: libssl.so.4 is needed by package postgresqlclient7
Error: Missing Dependency: libcrypto.so.4 is needed by package postgresql-devel
Error: Missing Dependency: libssl.so.4 is needed by package postgresql-server
Error: Missing Dependency: libcrypto.so.4 is needed by package postgresql-server
Error: Missing Dependency: libssl.so.4 is needed by package postgresql
Error: Missing Dependency: libcrypto.so.4 is needed by package postgresql-contrib
Error: Missing Dependency: libpython2.3.so.1.0 is needed by package postgresql-pl
Error: Missing Dependency: libreadline.so.4 is needed by package postgresql-contrib
Error: Missing Dependency: libcrypto.so.4 is needed by package postgresql
Error: Missing Dependency: libreadline.so.4 is needed by package postgresql-devel
Error: Missing Dependency: libssl.so.4 is needed by package postgresql-devel
Error: Missing Dependency: postgresql-libs = 8.1.11-1.el4s1.1 is needed by package postgresql-devel
Error: Missing Dependency: libreadline.so.4 is needed by package postgresql

How can I resolve it?

Re: Update failed because of postgresql
« Reply #1 on: September 20, 2013, 02:54:25 PM »
How can I resolve it?

Remove all the postgresql packages, then upgrade, then find and install new postgresql if you still need it.

rpm -e postgresql-contrib postgresqlclient7 postgresql-devel postgresql-pl postgresql-server postgresql-libs

Re: Update failed because of postgresql
« Reply #2 on: September 20, 2013, 03:00:48 PM »
Then I will have to make all the postgresql configuration again or it will come back automatically?

Re: Update failed because of postgresql
« Reply #3 on: September 20, 2013, 03:51:27 PM »
Then I will have to make all the postgresql configuration again or it will come back automatically?

I've no idea. postgresql is not part of SME server.

Offline Stefano

  • *
  • 10,800
  • Skype account: maghissimo
    • Smeserver italian community
Re: Update failed because of postgresql
« Reply #4 on: September 21, 2013, 12:21:44 AM »
I don't know postgresql but I would be surprised if its conf file arent in /etc/tree

backup your database, follow Charlie's advice.. when you reinstall via rpm/yum, your old conf file should be used automagically

if you are unsure, try on a virtual machine before..
google, as usual, will help you
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia