Koozali.org formerly Contribs.org

SME 8 and apcupsd

SME 8 and apcupsd
« on: June 24, 2013, 06:45:25 AM »
I recently migrated to SME 8 via a clean install.

I installed apcupsd from the contrib. Installation was straight forward.

When I issue '/etc/init.d/apcupsd status' I get the following:

apcupsd (pid 14420) is running...
Error contacting apcupsd @ localhost:3551: Connection refused

I have previously installed and used apcupsd with SME 7. I am running on the same physical server as the prior SME 7 install and the same APC UPS via USB.

I did disable and stop nut, and pull the cable as per the how-to suggestion. I also did post-upgrade and reboot.

I still get the error.

Any ideas?

Thanks.
« Last Edit: June 24, 2013, 06:49:05 AM by tgminc »

Offline TerryF

  • grumpy old man
  • *
  • 1,444
Re: SME 8 and apcupsd
« Reply #1 on: June 24, 2013, 07:46:24 AM »
There does not appear to be a SME8 contrib, what did you use?

and, why not just use nut
« Last Edit: June 24, 2013, 07:51:41 AM by TerryF »
--
qui scribit bis legit

Offline Jáder

  • *
  • 1,077
    • LinuxFacil
Re: SME 8 and apcupsd
« Reply #2 on: June 24, 2013, 12:41:14 PM »
(...)
When I issue '/etc/init.d/apcupsd status' I get the following:

apcupsd (pid 14420) is running...
Error contacting apcupsd @ localhost:3551: Connection refused
(...)
Any ideas?

It must be your config file.
This is mine apcupsd.conf , working for SUA1500 on SME8:

UPSNAME NoBreak_SUA1500
UPSCABLE usb
UPSTYPE usb

DEVICE
LOCKFILE /var/lock
SCRIPTDIR /etc/apcupsd
PWRFAILDIR /etc/apcupsd
NOLOGINDIR /etc
ONBATTERYDELAY 6
BATTERYLEVEL 5
MINUTES 3
TIMEOUT 0
ANNOY 300
ANNOYDELAY 60
NOLOGON disable
KILLDELAY 0
NETSERVER on
NISIP 0.0.0.0
NISPORT 3551
EVENTSFILE /var/log/apcupsd.events
EVENTSFILEMAX 10
UPSCLASS standalone
UPSMODE disable
STATTIME 0
STATFILE /var/log/apcupsd.status
LOGSTATS off
DATATIME 0

I think it must be one of thos two bold parameters: UPSTYPE or UPSCABLE
...

Re: SME 8 and apcupsd
« Reply #3 on: June 24, 2013, 02:20:29 PM »
It's the SME 7 contrib. I have used it in the past an liked it so though I'd try it out on SME 8.

I reviewed the config file and although it was not the UPSCABLE param, others were off (too late at night).

It is working now. Below are the non-default settings.

UPSNAME brains
UPSCABLE usb
UPSTYPE usb
DEVICE
LOCKFILE /var/lock
SCRIPTDIR /etc/apcupsd
PWRFAILDIR /etc/apcupsd
NOLOGINDIR /etc
ONBATTERYDELAY 6
BATTERYLEVEL 50
MINUTES 30
TIMEOUT 30
ANNOY 0
ANNOYDELAY 60
NOLOGON disable
KILLDELAY 0
NETSERVER on
NISIP 0.0.0.0
EVENTSFILE /var/log/apcupsd.events
UPSCLASS standalone
UPSMODE disable
STATTIME 0
STATFILE /var/log/apcupsd.status
LOGSTATS off
DATATIME 0

And as expected, produces the following:

# /etc/init.d/apcupsd status
apcupsd (pid  8204) is running...
APC      : 001,036,0910
DATE     : 2013-06-24 08:17:07 -0400
HOSTNAME : brains
VERSION  : 3.14.10 (13 September 2011) redhat
UPSNAME  : brains
CABLE    : USB Cable
DRIVER   : USB UPS Driver
UPSMODE  : Stand Alone
STARTTIME: 2013-06-24 08:08:08 -0400
MODEL    : Back-UPS XS  900
STATUS   : ONLINE
LINEV    : 118.0 Volts
LOADPCT  :  10.0 Percent Load Capacity
BCHARGE  : 100.0 Percent
TIMELEFT :  88.1 Minutes
MBATTCHG : 50 Percent
MINTIMEL : 30 Minutes
MAXTIME  : 30 Seconds
SENSE    : Medium
LOTRANS  : 088.0 Volts
HITRANS  : 139.0 Volts
ALARMDEL : 30 seconds
BATTV    : 26.7 Volts
LASTXFER : Unacceptable line voltage changes
NUMXFERS : 0
TONBATT  : 0 seconds
CUMONBATT: 0 seconds
XOFFBATT : N/A
SELFTEST : NO
STATFLAG : 0x07000008 Status Flag
SERIALNO : BQ0822002284
BATTDATE : 2010-05-29
NOMINV   : 120 Volts
NOMBATTV :  24.0 Volts
NOMPOWER : 540 Watts
FIRMWARE : 830.E8 .D USB FW:E8
END APC  : 2013-06-24 08:17:42 -0400