Koozali.org formerly Contribs.org

Unable to connect to ntop web server

Unable to connect to ntop web server
« on: May 25, 2013, 02:39:33 PM »
Hi all,
I've installed ntop following this:
http://wiki.contribs.org/Ntop
But I am unable to connect to the ntop web gui from a browser or via telnet.  Ntop is running and listening as far as I can see:
Code: [Select]
[root@supportserv ~]# tail -100 /var/log/messages | grep -i ntop
May 25 13:07:55 supportserv ntop[2584]:   RRD: Welcome to Round-Robin Databases. (C) 2002-07 by Luca Deri.
May 25 13:07:55 supportserv ntop[2584]:   Calling plugin start functions (if any)
May 25 13:07:55 supportserv ntop[2584]:   RRD: Welcome to the RRD plugin
May 25 13:07:55 supportserv ntop[2584]:   RRD: Mask for new directories is 0700
May 25 13:07:55 supportserv ntop[2584]:   RRD: Mask for new files is 0066
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG: Parameters:
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpInterval 300 seconds
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpShortInterval 10 seconds
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpHours 72 hours by 300 seconds
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpDays 90 days by hour
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpMonths 36 months by day
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpDomains no
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpFlows no
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpSubnets no
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpHosts no
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpInterfaces yes
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpASs no
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpMatrix no
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     dumpDetail medium
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     hostsFilter
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     rrdPath /var/ntop/rrd [normal]
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     rrdPath /var/ntop/rrd [dynamic/volatile]
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     umask 0066
May 25 13:07:55 supportserv ntop[2584]:   RRD_DEBUG:     DirPerms 0700
May 25 13:07:55 supportserv ntop[2584]:   THREADMGMT: RRD: Started thread (t2994514832) for data collection
May 25 13:07:55 supportserv ntop[2584]:   INIT: Created pid file (/var/run/ntop.pid)
May 25 13:07:55 supportserv ntop[2584]:   THREADMGMT[t2994514832]: RRD: Data collection thread starting [p2584]
May 25 13:07:55 supportserv ntop[2584]:   THREADMGMT[t3086280400]: ntop RUNSTATE: INITNONROOT(3)
May 25 13:07:55 supportserv ntop[2584]:   Now running as requested user 'ntop' (455:455)
May 25 13:07:55 supportserv ntop[2584]:   Note: Reporting device initally set to 0 [eth0] (merged)
May 25 13:07:55 supportserv ntop[2584]:   THREADMGMT[t3086280400]: ntop RUNSTATE: RUN(4)
May 25 13:07:55 supportserv ntop[2584]:   THREADMGMT[t2984024976]: NPS(1): Started thread for network packet sniffing [eth0]
May 25 13:07:55 supportserv ntop[2584]:   THREADMGMT[t2984024976]: NPS(eth0): pcapDispatch thread starting [p2584]
May 25 13:07:55 supportserv ntop[2584]:   THREADMGMT[t2984024976]: NPS(eth0): pcapDispatch thread running [p2584]
May 25 13:07:55 supportserv ntop[2584]:   THREADMGMT[t3046964112]: SIH: Idle host scan thread running [p2584]
May 25 13:07:55 supportserv ntop[2584]:   THREADMGMT[t3057453968]: SFP: Fingerprint scan thread running [p2584]
May 25 13:08:05 supportserv ntop[2584]:   THREADMGMT[t2973535120]: RRD: Started thread for throughput data collection
May 25 13:08:05 supportserv ntop[2584]:   THREADMGMT[t2994514832]: RRD: Data collection thread running [p2584]
May 25 13:08:05 supportserv ntop[2584]:   THREADMGMT[t2973535120]: RRD: Throughput data collection: Thread starting [p2584]
May 25 13:08:05 supportserv ntop[2584]:   THREADMGMT[t2973535120]: RRD: Throughput data collection: Thread running [p2584]

and:
Code: [Select]
[root@supportserv ~]# netstat -ntlup | grep -i 3000
tcp        0      0 0.0.0.0:3000                0.0.0.0:*                   LISTEN      2584/ntop   

and:
Code: [Select]
[root@supportserv ~]# telnet localhost 3000
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
Connection closed by foreign host.


The server is running in server-only mode.

Can anyone help please?

Thanks for reading

NTB
8o)

Re: Unable to connect to ntop web server
« Reply #1 on: May 26, 2013, 05:36:27 PM »
I've installed ntop following this:
http://wiki.contribs.org/Ntop
But I am unable to connect to the ntop web gui from a browser or via telnet.

That issue is already documented in the wiki:

Quote
Note that manually starting ntop works, and it listens on port 3000, but if you connect
(even from localhost), it aborts with a RST packet and logs nothing.

Re: Unable to connect to ntop web server
« Reply #2 on: May 26, 2013, 05:57:17 PM »
Hi Charlie,
Thanks for the reply.  Yep, I saw that but was hoping that it might have been resolved.  I followed the links to the discussions here (I had to edit the startup script as well) and was hoping that there might have been some progress.

Googling doesn't turn up anything very much more recent than 2008-ish (AFAIR) and I'm a bit stuck now.

Thanks anyway,

NTB
8o)