Koozali.org formerly Contribs.org

Console backup to USB function not writing file to pen drive

Console backup to USB function not writing file to pen drive
« on: April 15, 2013, 04:13:14 PM »
On 7.6*, the backup process appears to work and the progress bar slowly goes to 100%. It indicates that it has successfully completed; however, during the step where it dismounts the drive, the console screen turns black and briefly flashes a message saying that the drive is not mounted.

Is there anything I can look at to find more information as to why it is failing (log file, temp file, Etc.)?

I'm concerned that this might be a size issue with the pen drive because it worked OK a few week ago but hasn't worked in several attempts since then. Is there a way to see how big the backup file is that its trying to write?

*I'm trying to upgrade from 7.6 to 8.0. In order to do a clean install, my plan is to backup, do a clean install, and then restore back.

Offline Stefano

  • *
  • 10,782
  • Skype account: maghissimo
    • Smeserver italian community
Re: Console backup to USB function not writing file to pen drive
« Reply #1 on: April 15, 2013, 05:40:33 PM »
do not use a pen drive, use an hd

this will likely solve your problem and will be pretty faster.

in any case, the first place to search for issues is /var/log/messages
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Re: Console backup to USB function not writing file to pen drive
« Reply #2 on: April 15, 2013, 06:12:54 PM »
I failed to mention that I'm having the same problem with a USB hard drive (it was NTFS, though). The one time this worked was on a NTFS-formatted pen drive.  My most recent attempt was a ext3-formatted pen drive.

Here's a snippet from the log. Looks like it had an error backing up an email (which was probably POP'd in the middle of the backup). That shouldn't make the entire backup fail, should it?

Apr 15 08:03:42 mail esmith::event[28113]: Running event handler: /etc/e-smith/e
vents/pre-backup/S50rewind-tape
Apr 15 08:03:42 mail esmith::event[28113]: S50rewind-tape=action|Event|pre-backu
p|Action|S50rewind-tape|Start|1366031022 819043|End|1366031022 910321|Elapsed|0.
091278
Apr 15 08:09:32 mail console_backup: tar: home/e-smith/files/users/tonyahudson/M
aildir/cur/1364821747.12900.mail\:2,: Cannot stat: No such file or directory

Apr 15 08:29:56 mail console_backup: tar: Error exit delayed from previous error
s

Apr 15 08:29:56 mail console_backup: status from tar was 512
Apr 15 08:32:43 mail esmith::event[1948]: Processing event: post-backup
Apr 15 08:32:43 mail esmith::event[1948]: Running event handler: /etc/e-smith/ev
ents/post-backup/S10mysql-delete-dumped-tables
Apr 15 08:32:43 mail esmith::event[1948]: S10mysql-delete-dumped-tables=action|E
vent|post-backup|Action|S10mysql-delete-dumped-tables|Start|1366032763 502718|En
d|1366032763 604234|Elapsed|0.101516
Apr 15 08:32:43 mail esmith::event[1948]: Running event handler: /etc/e-smith/ev
ents/post-backup/S50rewind-tape
Apr 15 08:32:43 mail esmith::event[1948]: S50rewind-tape=action|Event|post-backu
p|Action|S50rewind-tape|Start|1366032763 604589|End|1366032763 701569|Elapsed|0.
09698
Apr 15 08:32:43 mail esmith::event[1948]: Running event handler: /etc/e-smith/ev
ents/post-backup/S90eject-tape
Apr 15 08:32:43 mail esmith::event[1948]: S90eject-tape=action|Event|post-backup
|Action|S90eject-tape|Start|1366032763 701902|End|1366032763 786157|Elapsed|0.08
4255
Apr 15 08:32:49 mail kernel: usb 1-8: USB disconnect, address 4
Apr 15 08:32:50 mail last message repeated 2 times
Apr 15 08:32:59 mail udevd[1265]: udev done!


Re: Console backup to USB function not writing file to pen drive
« Reply #3 on: May 10, 2013, 04:38:26 PM »
A bug has been opened in Bugzilla:
http://bugs.contribs.org/show_bug.cgi?id=7580
Please follow there.
Thanks.
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Re: Console backup to USB function not writing file to pen drive
« Reply #4 on: May 10, 2013, 04:41:40 PM »
A bug has been opened in Bugzilla:
http://bugs.contribs.org/show_bug.cgi?id=7580
Please follow there.
Thanks.

No, that bug concerns media I/O errors during restore. We need a separate bug for tracking issues during creation of a backup.

Re: Console backup to USB function not writing file to pen drive
« Reply #5 on: May 10, 2013, 04:56:15 PM »
Here's a snippet from the log. Looks like it had an error backing up an email (which was probably POP'd in the middle of the backup). That shouldn't make the entire backup fail, should it?

No, the backup should still be usable after that error - but possibly with one missing email message.

Re: Console backup to USB function not writing file to pen drive
« Reply #6 on: May 10, 2013, 04:58:57 PM »
No, that bug concerns media I/O errors during restore. We need a separate bug for tracking issues during creation of a backup.

Not so sure about this.  If you check the bug, you will see that there is no solid evidence of I/O errors during restore.  All indications are that the USB stick used in the process may have been incorrectly formatted or faulty - to follow.
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Re: Console backup to USB function not writing file to pen drive
« Reply #7 on: May 10, 2013, 07:38:46 PM »
Not so sure about this.  If you check the bug, you will see that there is no solid evidence of I/O errors during restore.  All indications are that the USB stick used in the process may have been incorrectly formatted or faulty - to follow.

The issues are most definitely different. Bug 7580 concerns I/O errors on a backup device. The issue here relates to changes in the file system taking place while a backup is in progress.