Koozali.org formerly Contribs.org

Windows 98 "The domain Password you supplied is not correct"

Windows 98 "The domain Password you supplied is not correct"
« on: November 07, 2012, 01:55:13 AM »
I have successfully upgraded our SME server from 7.5.1 to 7.6 to 8.0.  Since the upgrade all of our XPpro PCs are able login (authenticate) to connect to our local network and access our network drives (ibays) just fine.   I've been wanting to do this upgrade for quite some time so that I can have a stable server that will accept logins from Windows 7 PCs. However after the upgrade I have found that our Windows 98 PC will no longer login to the upgraded server.  Entering a Username and Password with the correct domain on our Windows 98 PCs generates a <Microsoft Networking> window with the message "The domain password you supplied is not correct or access to your login server has been denied"

I've searched this forum for hints of a solution but only found Bug 6812,
  http://bugs.contribs.org/show_bug.cgi?id=6812
Marked as WONT FIX.

I tried 
   db configuration setprop smb LanManPasswords yes
   signal-event workgroup-update

That didn't fix my problem.

I also found reference to editing smb.conf and adding the lines to the [Global] section
   client lanman auth = [Yes,True]
   client plaintext auth = [Yes,True]
but when I look at smb.conf on the server there is a warning at the top of the file not to edit the file as it will be overwritten when re-generated.

I can not update the Windows 98 machines to XP as they are machine controllers with special hardware and software installed that will not work in an XP box.

Is there a solution to successfully have Windows 98 PCs login to SME 8.0 and access the network drives (ibays)?

Thanks,

John.


 
 

Offline janet

  • ****
  • 4,736
Re: Windows 98 "The domain Password you supplied is not correct"
« Reply #1 on: November 07, 2012, 02:27:47 AM »
RF_Guy

Ah the "joys" of upgrading & superseded technology, always biting us in one way or another !!!

Quote
I also found reference to editing smb.conf and adding the lines to the [Global] section
   client lanman auth = [Yes,True]
   client plaintext auth = [Yes,True]
but when I look at smb.conf on the server there is a warning at the top of the file not to edit the file as it will be overwritten when re-generated.

You can temporarily ignore the warning and edit the smb.conf file as required, then restart smb, then logoff & re login with those Win 98 machines and see if your problem is resolved.

During this process do not make any other changes or reconfiguration on your server, as the temporary smb.conf changes will be overwritten.

If the temporary fix works, then you can create a custom template that will make those changes "permanent" and survive any server upgrades or reconfigurations etc.
Ask again if you need more advice on doing that, but take a look at
http://wiki.contribs.org/Template_Tutorial
« Last Edit: November 10, 2012, 06:17:15 AM by mary »
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Re: Windows 98 "The domain Password you supplied is not correct"
« Reply #2 on: November 10, 2012, 01:41:12 AM »
Thanks for replying Mary, here's what I've found out.

I went back to check the source of what was needed in the smb.conf file.  My source was the Ubuntu forum page at:
   http://ubuntuforums.org/showthread.php?t=1617097

There it said to follow the steps below:
Code: [Select]
   1. Add these three lines to the [globals] section of your smb.conf:

      lanman auth = Yes
      client lanman auth = Yes
      client plaintext auth = Yes

   2. Restart the Samba server
   3. Re input passwords for every Win9x user:
      smbpasswd -a username
   4. Have every Win9x user log out and then log in again

I found that the first line . . .  lanman auth = yes . . .   was already in the smb.conf file.   I edited the file and added the remaining two lines, then did step 2), step 3), and step 4).

The windows98 machines are then successfully loging into the SME8 server and are able to access the network drives again.  Hooray !!! it works.

Next I checked the /etc/samba/smbpasswd file.  It had entries like:
  guyl:5002:6FABC9D42A9BCCB3C2265B23734E0DAC:1C8AB43BCF66D8109C8B0AF06D972C0F:[UX         ]:LCT-4AB7DE35:
which used to look like:
  guyl:5002:XXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:1C8AB43BCF66D8109C8B0AF06D972C0F:[UX         ]:LCT-4AB7DE35:

I don't know how the password incription got changed to X's but the above procedure seems to have fixed it.

Next I tried to make a new custom-template for the smb.conf.  Using the tutorial you linked to, I found that the smb.conf template fragments are located at:
  /etc/e-smith/templates/etc/smb.conf
I did a grep for anything containing  . . .  lanman . . .  and found the fragment 11lanmanPasswords. I figured this must be the fragment that puts the . . .  lanman auth = Yes  . . . line in the smb.conf file so I copied 11lanmanPasswords to a new file at /etc/e-smith/custom-templates/etc/smb.conf/11lanmanPasswords.  Edited the new file and appending the last two lines so the file now looks like:
Code: [Select]
{

$OUT .= "lanman auth = $smb{'LanManPasswords'}\n" if $smb{'LanManPasswords'};

client lanman auth = Yes
client plaintext auth = Yes

}

I continued the tutorial example and ran
  expand-template /etc/smb.conf

I then checked the /etc/samba/smb.conf file and the last two lines were not included.  The custom-template did not work. 

I then decided to check the Windows 98 PCs.  I logged out on each Windows 98 machine and was successfully able log back in.

Next using the SME8 Server Manager to download a SME update then re-configured and re-booted the server.

After the server re-boot I'm still able to login from the Window 98 PCs

The /etc/samba/smb.conf file contains the line
Code: [Select]
     lanman auth = Yes
but does not contain the lines
Code: [Select]
     client lanman auth = Yes
     client plaintext auth = Yes

Since it is all working now I'll stop where I'm at.  It appears that the X's in the encrypted password field in the /etc/samba/smbpasswd file was the blocking agent in not allowing the Windows98 PCs to login.  The four step procedure above appears to have fixed that so I'm stopping any further action now.

Thanks again for your help.

John.

Offline janet

  • ****
  • 4,736
Re: Windows 98 "The domain Password you supplied is not correct"
« Reply #3 on: November 10, 2012, 05:31:39 AM »
RF_Guy

Quote
I then checked the /etc/samba/smb.conf file and the last two lines were not included.  The custom-template did not work.

You missed the point to use the correct syntax & use the db command to control the values
Something like this works OK for me, although I did not test Win98 functionality.

Edit /etc/e-smith/custom-templates/etc/smb.conf/11lanmanPasswords to show the following & Save it

{

$OUT .= "lanman auth = $smb{'LanManPasswords'}\n" if $smb{'LanManPasswords'};
$OUT .= "client lanman auth = $smb{'ClientLanManPasswords'}\n" if $smb{'ClientLanManPasswords'};
$OUT .= "client plaintext auth = $smb{'ClientPlaintextPasswords'}\n" if $smb{'ClientPlaintextPasswords'};
}

Then use db commands to set yes or no

Firstly check current settings
config show smb

Then
config setprop smb LanManPasswords yes
config setprop smb ClientLanManPasswords yes
config setprop smb ClientPlaintextPasswords yes
signal-event workgroup-update

Then review settings
config show smb
& then check /etc/samba/smb.conf to see all changes & settings are present

PS Doing the above, just makes the necessary changes to sme server config.
I assume you still need to carry out steps 3 & 4 mentioned previously ie
3. Re input passwords for every Win9x user:
      smbpasswd -a username
4. Have every Win9x user log out and then log in again

Edit:
PPS
As pointed out by mmccarn in a later post, you could simply have added the text you require in the correct location, & "hard coded" the fragment with values, rather than use perl code to facilate control using db entries & commands
eg

the fragment code would simply be
{
$OUT .= "lanman auth = $smb{'LanManPasswords'}\n" if $smb{'LanManPasswords'};
}
client lanman auth = yes
client plaintext auth = yes

or even more simply (which would remove the default db control of lanman auth)

lanman auth = yes
client lanman auth = yes
client plaintext auth = yes
« Last Edit: November 11, 2012, 03:23:13 AM by mary »
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Offline mmccarn

  • *
  • 2,427
Re: Windows 98 "The domain Password you supplied is not correct"
« Reply #4 on: November 10, 2012, 04:32:23 PM »
I've added a paragraph to the template tutorial talking about perl vs text template fragments:
Quote
Some templates are inserted as literal text into the output files, and some templates are actually running perl code to generate the output text.  The perl templates will include braces ("{" and "}") and will likely contain lines beginning with $OUT .= "blah, blah, blah";.  If the template you've decided to copy includes perl code, you will need to write perl code to create your new output or place your changes after the final closing brace ("}") of the perl commands.

http://wiki.contribs.org/Template_Tutorial#Detailed_generic_troubleshooting_.26_configuration_steps

Re: Windows 98 "The domain Password you supplied is not correct"
« Reply #5 on: November 12, 2012, 10:37:36 PM »
Moving the lines I wanted in the smb.conf file outside of the currly brackets in 11lanmanPasswords file works.  The 11lanmanPasswords file now looks like:
Code: [Select]
{

$OUT .= "lanman auth = $smb{'LanManPasswords'}\n" if $smb{'LanManPasswords'};

}
client lanman auth = Yes
client plaintext auth = Yes

Thanks,

John.