Koozali.org formerly Contribs.org

Error: Missing Dependencies when installing SquidGuard on SME SERVER 7.6

I am trying to install SquidGuard on one of my SME Servers ver 7.6.  I am using the guidelines provided by SME on this page wiki.contribs.org/SquidGuard.

I am getting the following Dependency issues and I have searched the net and cannot fix this issue.

Any help is appreciated.


12:01:38 (75.08 KB/s) - `smeserver-squidguard-1.0-35.noarch.rpm.1' saved [43699/43699]

[root@data ~]# yum localinstall smeserver-squidguard*.rpm --enablerepo=dag
Loading "protect-packages" plugin
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading "smeserver" plugin
Setting up Local Package Process
Examining smeserver-squidguard-1.0-35.noarch.rpm: smeserver-squidguard - 1.0-35.noarch
Marking smeserver-squidguard-1.0-35.noarch.rpm to be installed
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package smeserver-squidguard.noarch 0:1.0-35 set to be updated
--> Running transaction check
Setting up repositories
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Excluding Packages from Dag - EL4
Finished
Excluding Packages from Dag - EL4
Finished
--> Processing Dependency: squidguard >= 1.2 for package: smeserver-squidguard
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package squidguard.i386 0:1.3-2.el5.rf set to be updated
--> Running transaction check
--> Processing Dependency: libdb-4.3.so for package: squidguard
--> Processing Dependency: rtld(GNU_HASH) for package: squidguard
--> Processing Dependency: libc.so.6(GLIBC_2.4) for package: squidguard
--> Finished Dependency Resolution
Error: Missing Dependency: libdb-4.3.so is needed by package squidguard
Error: Missing Dependency: rtld(GNU_HASH) is needed by package squidguard
Error: Missing Dependency: libc.so.6(GLIBC_2.4) is needed by package squidguard

« Last Edit: October 16, 2012, 08:37:35 PM by bhay3s »

Offline Stefano

  • *
  • 10,790
  • Skype account: maghissimo
    • Smeserver italian community
Re: Error: Missing Dependencies when installing SquidGuard on SME SERVER 7.6
« Reply #1 on: October 16, 2012, 08:04:02 PM »
first of all, please don't use bold and big chars, we're able to read, thank you

check your repo info, you are trying to instal a el5 (i.e. Centos5) rpm in a Centos4 environment
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Re: Error: Missing Dependencies when installing SquidGuard on SME SERVER 7.6
« Reply #2 on: October 16, 2012, 08:12:04 PM »
Are the directions for the squidguard installation correct on the wiki?  Which version of SME Server is the wiki for ?

wiki.contribs.org/SquidGuard

« Last Edit: October 16, 2012, 08:13:57 PM by bhay3s »

Re: Error: Missing Dependencies when installing SquidGuard on SME SERVER 7.6
« Reply #3 on: October 16, 2012, 08:41:31 PM »
Le indicazioni per l'installazione corretta squidguard sul wiki? Quale versione di SME Server รจ il wiki per?

Re: Error: Missing Dependencies when installing SquidGuard on SME SERVER 7.6
« Reply #4 on: October 16, 2012, 08:58:37 PM »
12:01:38 (75.08 KB/s) - `smeserver-squidguard-1.0-35.noarch.rpm.1' saved [43699/43699]

This indicates that you already had the smeserver-squidguard rpm downloaded. When you downloaded it a second time, the second copy was saved with a .1 filename.

Quote
---> Package squidguard.i386 0:1.3-2.el5.rf set to be updated

This indicates that you have an error in your yum repository configuration, and yum is finding a CentOS5 version of squidguard. Fix the yum configuration, do "yum clean all", then try again.

Re: Error: Missing Dependencies when installing SquidGuard on SME SERVER 7.6
« Reply #5 on: October 17, 2012, 04:07:14 PM »
Charlie,

Thanks for your reply.


http://wiki.contribs.org/SquidGuard

To me there appears to be an issue with the documentation and I will explain why as follows:

1. First of all I am running 7.6
2. The documentation does not make a declaration for which version it applies to

Here is the first part of the documentation:

***********************************
SquidGuard
smeserver packaged version

J Bennett has packaged squidguard into a sme server compatible application.

If you have not installed the Dag repository please follow this instruction.

The following command will configure the Dag repository on SME Server.

/sbin/e-smith/db yum_repositories set dag repository \
Name 'Dag - EL5' \
BaseURL 'http://apt.sw.be/redhat/el5/en/$basearch/dag' \
EnableGroups no \
GPGCheck yes \
GPGKey http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt \
Visible no \
Exclude freetype,htop,iptraf,rsync,syslinux \
status disabled
***********************************

If you notice, it this wants the dag repo pointing at Centos5 packages? Right? I am not sure but asking....

Okay, now if you look below here is the part that makes no sense to me:


***********************************
If you run this command the resulting output should look like:

db yum_repositories show dag

   dag=repository
   BaseURL=http://apt.sw.be/redhat/el4/en/$basearch/dag
   EnableGroups=no
   Exclude=freetype,htop,iptraf,rsync,syslinux
   GPGCheck=yes
   GPGKey=http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt
   Name=Dag - EL4
   Visible=no
   status=disabled
***********************************

This makes no sense to me since this says you should now see dag pointing at the el4 url???


Will so let me explain further, I followed this documentation from top to bottom and also did a yum clean all beforehand.  I had an error which said it was missing dependencies.

My logic which could entirely be incorrect because I am still learning SME Server was that if your telling me to download el5 packages and then do yum_repositories show dag I should see el4 then that loses me.  I then decided to modify the documentation to what I would think would work and so what I did was the following:

# yum clean all

/sbin/e-smith/db yum_repositories set dag repository \
Name 'Dag - EL4' \  ((( I changed EL5 to EL4)))
BaseURL 'http://apt.sw.be/redhat/el4/en/$basearch/dag' \   ((( I changed el5 to el4)))
EnableGroups no \
GPGCheck yes \
GPGKey http://dag.wieers.com/packages/RPM-GPG-KEY.dag.txt \
Visible no \
Exclude freetype,htop,iptraf,rsync,syslinux \
status disabled

and followed the rest of the documentation and everything worked.  If this worked isn't the documentation incorrect?  Also would it help to mention what version it applies to?  Just trying to help myself as well as offering anything I see that could be an issue.  If this is incorrect then I stand corrected.

Thanks.

Re: Error: Missing Dependencies when installing SquidGuard on SME SERVER 7.6
« Reply #6 on: October 17, 2012, 05:13:15 PM »
To me there appears to be an issue with the documentation ...

Any deficiencies in documentation should be reported via the bug tracker. Anyone wishing to help with improvements in the documentation should go to the bug tracker to see what needs to be done.

Alternatively, anything wrong in the wiki you can just correct.


Offline janet

  • ****
  • 4,810
Re: Error: Missing Dependencies when installing SquidGuard on SME SERVER 7.6
« Reply #8 on: October 17, 2012, 05:41:23 PM »
bhay3s

What you did appears to be correct.
Someone updated the first part of the wiki re dag repo for el5 to suit the current release of sme server being v8.0. They overlooked updating the second reference to dag which still refers to el4.
I suppose the wiki should/could show different dag repo setups for sme7.x and 8.x, some articles do this already.
The issue is really should documentation cater for superseded and current sme releases, and this question would apply to all wiki articles.

If you want to update the wiki article with both el4 & el5 dag repos, please do, it's easy.
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Re: Error: Missing Dependencies when installing SquidGuard on SME SERVER 7.6
« Reply #9 on: October 17, 2012, 05:47:06 PM »
Mary (and bhay3s), please followup to the bug tracker, not here.