Koozali.org formerly Contribs.org

[SOLVED] md2 missing, main LVM not found

[SOLVED] md2 missing, main LVM not found
« on: August 19, 2012, 05:46:25 PM »
This one is actually already solved, but I just spent an hour on it and it was really stupid so I thought I'd put a note here.

I just finished upgrading to SME8 and apparently at some point in the past the physical devices under /dev/md2 (sda2 and sdb2 here) got changed from type 'fd' linux raid autodetect to just linux. I'm sure I did it as I've had issues with the RAID before and had to fix it, mostly stuff I caused.  :-D

In any case for some reason v7.6 didn't seem to mind and 8 choked on it. I had no issues when booting up Knoppix to check the arrays but during normal boot there was no md2 and hence no 'main' LVM. When I would load up the rescue mode on the CD it told me there were no installs of SME found (which the rescue issue I did not confirm was due to the partition type, I just suspect it).

Using fdisk with the 't' command to change the types to 'fd' fixed it right up.
« Last Edit: August 19, 2012, 05:50:42 PM by nekatreven »