Koozali.org formerly Contribs.org

[SOLVED] SME 8 on VMware Player - Please Wait - Yum Running (prereposetup)

Hi, just done a clean install of 8.0 on VMware Player and do not appear to be able to run updates, the management panel says

Code: [Select]
Please Wait - Yum Running (prereposetup)
When trying to run yum update I get

Code: [Select]
Another app is currently holding the yum lock; wait for it to exit...
   The other application is: yum
      Memory :  13 M RSS ( 22 MB VSZ)
      Started : Wed Jul 18 16:20:37 2012 - 22:11 ago
      Sate     : Sleeping, pid: 3696

If I kill the processes holding the yum lock I get

Code: [Select]
Loaded plugins: fastestmirror, protect-packages, smeserver
Loading mirror speeds from cached hostfile

At this point it hangs and appears to make no progress.

Been through the forums and can't find anything related, am I missing something?

I noticed on the SME 8 sticky it says

Quote
3. Please note it may take up to 48 hours for mirrors to finish syncing,
   during this time you may experience problems.
   You can download SME8.0 from
   http://mirror.contribs.org/smeserver/releases/8/iso/i386/
   or for other methods see http://wiki.contribs.org/SME_Server_8

Is this related to my issue?
« Last Edit: July 19, 2012, 04:29:33 PM by Bozely »

Offline Stefano

  • *
  • 10,805
  • Skype account: maghissimo
    • Smeserver italian community
Re: SME 8 on VMware Player - Please Wait - Yum Running (prereposetup)
« Reply #1 on: July 18, 2012, 08:07:02 PM »
did you test internet connectivity from SME's console?

anyway, login as root and
Code: [Select]
echo 1 > /proc/sys/net/ipv4/tcp_syncookie
echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
echo 0 > /proc/sys/net/ipv4/tcp_ecn

and try again with you

if it works, create a custom fragment for /etc/sysctl.conf with this content:
Code: [Select]
net.ipv4.tcp_syncookies = 1
net.ipv4.tcp_window_scaling = 0
net.ipv4.tcp_ecn= 0

expand the template with
Code: [Select]
expand-template /etc/sysctl.conf

no need to reboot

HTH
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Re: SME 8 on VMware Player - Please Wait - Yum Running (prereposetup)
« Reply #2 on: July 19, 2012, 12:33:55 PM »
Thanks Stefano, I ran those commands to no avail. I also ran the test internet connection from admin via a terminal, this hangs and I have to cancel and in turn failing the test, but when pinging URLs (not IPs) from root I get a replies so it would suggest connectivity can be established and DNS is resolving correctly.

Offline Stefano

  • *
  • 10,805
  • Skype account: maghissimo
    • Smeserver italian community
Re: SME 8 on VMware Player - Please Wait - Yum Running (prereposetup)
« Reply #3 on: July 19, 2012, 12:44:35 PM »
from root shell, try to download a file (at least 3 mb).. if the download starts and then "die", it could be a packet fragmentation issue

is your virtual machine in bridged or nat mode?

did you install vmware tools?
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Re: SME 8 on VMware Player - Please Wait - Yum Running (prereposetup)
« Reply #4 on: July 19, 2012, 01:41:22 PM »
Currently using bridged mode and have vmware tools installed.

Tried downloading a file and it resolves the website but hangs on "Connecting to ".

Offline Stefano

  • *
  • 10,805
  • Skype account: maghissimo
    • Smeserver italian community
Re: SME 8 on VMware Player - Please Wait - Yum Running (prereposetup)
« Reply #5 on: July 19, 2012, 02:42:15 PM »
try nat mode and let us know..

Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Stefano, made some exceptions on my firewall and I was up and running. DOH! Wood through trees comes to mind!  :oops:

Thanks anyway.