Koozali.org formerly Contribs.org

Cannot connect to ejabberd

Cannot connect to ejabberd
« on: June 27, 2012, 03:28:51 AM »
Hi all
   I have installed smeserver-ejabberd.noarch 0:2.0.1-18.el4.sme and followed the contrib instructions closely. I checked the bugs and searched here.
 config show ejabberd
ejabberd=service
    Domain=mydomain.local
    Notify=disabled
    Register=all
    TCPPorts=5222,5223,5269,5280
    WebAdmin=disabled
    WelcomeSubject=
    WelcomeText=
    XMPPAccess=notls
    access=private
    status=enabled

telnet myserver.ip 5222
telnet: connect to address myserver.ip: Connection refused

telnet to port 25 and some others ok. So I am thinking it is a firewall issue. I also did the same on a VM  sme8 server with the same results.

 service ejabberd restart
Restarting ejabberd  ok   --- so I believe the service is running

 ejabberdctl always gives this message
RPC failed on the node ejabberd@myserver.name: nodedown

on my network there another 2.4 linux server with a jabber service. It does respond to telnet on 5222.

Any help as always is greatly appreciated.

         

Offline janet

  • ****
  • 4,806
Re: Cannot connect to ejabberd
« Reply #1 on: June 27, 2012, 04:08:17 AM »
Catton

Open ports in the firewall using the server manager Port Forwarding (and opening) panel

From a workstation behind your sme server, open a browser and go to
grc.com
to run a port scan to check what ports are open on your sme server.

You will also need to check other firewalls if there are any between your sme server & the Internet.
« Last Edit: June 27, 2012, 04:12:38 AM by mary »
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Re: Cannot connect to ejabberd
« Reply #2 on: June 27, 2012, 08:30:33 PM »
Hi Marry
   I created a port forward
TCP    5222    localhost    5222         jabber   (GRC shows it closed same as before the forward created)
and again with but to my machine
TCP    5222    MyMachine    5222    jabber   (GRC shows it open stealth)
No firewall between server & the Internet. It seems sme is blocking 5222 and if I understand that function is done through iptables. Right?
# config show masq
masq=service
    DenylogTarget=drop
    Logging=most
    Stealth=no
    TCPBlocks=
    Trace=disabled
    UDPBlocks=
    UDPOpens=
    pptp=yes
    status=enabled