Koozali.org formerly Contribs.org

Unable to mount NFS share from a qnap nas

Re: Unable to mount NFS share from a qnap nas
« Reply #15 on: July 11, 2012, 12:59:46 PM »
Google is your friend (well, not for its privacy policy) or DuckDuckGo
Christ, what is this DuckDuckGo thing? I've been rendered obsolete, that's a certainty :D

Quote
http://nfs.sourceforge.net/
http://www.brennan.id.au/19-Network_File_System.html
http://www.centos.org/docs/5/html/Deployment_Guide-en-US/ch-nfs.html
http://www.cyberciti.biz/faq/centos-fedora-rhel-nfs-v4-configuration/

This is just a standard mount.
I do have some basic knowledge on NFS mounts. The question here is:
Quote
...provide information in what exactly I should do, after I install nfs-utils, in order to mount a remote NFS system? Should some config take place? Have some daemons automatically start up perhaps?
... all in the context of SME. For example, if it was my FreeBSD box, I'd just have to modify /etc/fstab for the mounting of the remote NFS share to take place. What should be done in the case of SME, considering the SME configuration specifics and templating?

Offline ReetP

  • *
  • 2,874
Re: Unable to mount NFS share from a qnap nas
« Reply #16 on: July 11, 2012, 02:00:16 PM »
Christ, what is this DuckDuckGo thing? I've been rendered obsolete, that's a certainty :D

Hehehehe.... I feel the same these days :-) Must be getting old cos I've got more cynical with the data thieves. Google are one of the worst IMHO so I rarely use it these days. There are a few newer search engines about that are a bit more privacy orientated so I prefer them......

Quote
I do have some basic knowledge on NFS mounts. The question here is:... all in the context of SME. For example, if it was my FreeBSD box, I'd just have to modify /etc/fstab for the mounting of the remote NFS share to take place. What should be done in the case of SME, considering the SME configuration specifics and templating?

If you search the forums, it would appear that fstab is one file you can manually edit and it shouldn't lose the changes. Suggest you put your mount line/s in there and give it a whirl :-)



...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Offline janet

  • ****
  • 4,812
Re: Unable to mount NFS share from a qnap nas
« Reply #17 on: July 12, 2012, 05:11:57 AM »
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Re: Unable to mount NFS share from a qnap nas
« Reply #18 on: July 14, 2012, 05:30:00 PM »
@mary: I have not forgotten to use google, my comment above was more of a joke :)

BTW, is it possible to move this thread back to the SME 8? This is not about a contrib, but rather for the base system.

Now, I don't know if this is useful (and correct for that matter), but I did find what should be done in order to be able to mount foreign NFS shares
Code: [Select]
yum install nfs-utils
ln -s /etc/init.d/portmap /etc/rc7.d/S92portmap

The first command is definitely needed, not sure about the second one though at least in the context of SME templating etc. What is certain is that if portmap is not running, I can not mount anything... The choice of rc7.d and S92 (in S92portmap) were arbitraty: when bug 7006 is fixed, I'm certain that proper choices will be made :)

Offline ReetP

  • *
  • 2,874
Re: Unable to mount NFS share from a qnap nas
« Reply #19 on: July 15, 2012, 02:07:11 AM »

Now, I don't know if this is useful (and correct for that matter), but I did find what should be done in order to be able to mount foreign NFS shares
Code: [Select]
yum install nfs-utils
ln -s /etc/init.d/portmap /etc/rc7.d/S92portmap

The first command is definitely needed, not sure about the second one though at least in the context of SME templating etc. What is certain is that if portmap is not running, I can not mount anything... The choice of rc7.d and S92 (in S92portmap) were arbitraty: when bug 7006 is fixed, I'm certain that proper choices will be made :)

Would suggest you add this to your bug (which is where any bug related info should really go).

B. Rgds
John
...
1. Read the Manual
2. Read the Wiki
3. Don't ask for support on Unsupported versions of software
4. I have a job, wife, and kids and do this in my spare time. If you want something fixed, please help.

Bugs are easier than you think: http://wiki.contribs.org/Bugzilla_Help

If you love SME and don't want to lose it, join in: http://wiki.contribs.org/Koozali_Foundation

Re: Unable to mount NFS share from a qnap nas
« Reply #20 on: July 17, 2012, 10:23:57 AM »
Would suggest you add this to your bug (which is where any bug related info should really go).

B. Rgds
John
Done.