Koozali.org formerly Contribs.org

Hylafax install won't recognize modem when probed (SME server 7.5.1)

Just installed hylafax from contribs and the install when through ok, however, when running the "faxaddmodem", "faxaddmodem" can't communicate with my modem.  The modem is a USR 5686-05R external modem.  (Also tried the "-s" option and set static speed manually)

 To troubleshoot and verify the modem is operating properly for SME7,  I installed "minicom" and am able to initialize the modem and dial out to a working phone number sucessfully.  The external modem is connected to COM1 which is /dev/ttyS0.

Not sure how to troubleshoot further.  Any help would be appreciated.





Offline Jáder

  • *
  • 1,059
    • LinuxFacil
So your problem is not in your SME server.
Maybe it's a Hylafax bug... but is not an SME bug. Maybe try at Hylafax forums.
...

Thanks for reply.  I found the answer.   So, for other people who might run into the same problem here's the answer.  Use the dip switch config on the USR 5686 modem as follows:  1,4,6,8 up and 2,4,5,7 down.   After setting the switches in this config instead of the default I found in the manual for this modem, the "faxaddmodem" was able to probe the modem sucessfully.

Offline Jáder

  • *
  • 1,059
    • LinuxFacil
please verify your answer:"there are no 3 and there are two 4s!!
Thanks for reply.  I found the answer.   So, for other people who might run into the same problem here's the answer.  Use the dip switch config on the USR 5686 modem as follows:  1,4,6,8 up and 2,4,5,7 down.   After setting the switches in this config instead of the default I found in the manual for this modem, the "faxaddmodem" was able to probe the modem sucessfully.
...

Re: Hylafax install won't recognize modem when probed (SME server 7.5.1)
« Reply #4 on: June 12, 2012, 12:32:54 PM »
Thanks for the reply, here's the correct dip switch settings:     Use the dip switch config on the USR 5686 modem as follows:  1,4,6,8 down and 2,3,5,7 up