Koozali.org formerly Contribs.org

memcached missing Dependency for SMEServer-SOGO on SME 8b7 [Solved]

Hi,

I am trying to install Sogo on SMEServer 8 beta 7 like it is described here http://wiki.contribs.org/Sogo.

Unfortunately the installation is stopping because of  Missing Dependency:
Code: [Select]
memcached is needed by package sogo-1.3.14-1.el5.i386
I already tried to install memcaches manually but it is still not working. I also tried --exclude=memcached

Do you have any ideas?

Regards,
Holger

Code: [Select]
[root@server ~]# yum install smeserver-sogo --enablerepo=nethsme --enablerepo=sogo
Loaded plugins: fastestmirror, protect-packages, smeserver
Loading mirror speeds from cached hostfile
 * base: centos.psw.net
 * smeaddons: sme-mirror.firewall-services.com
 * smeextras: sme-mirror.firewall-services.com
 * smeos: sme-mirror.firewall-services.com
 * smeupdates: sme-mirror.firewall-services.com
 * updates: centos.psw.net
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package smeserver-sogo.noarch 0:0.6-1.el5.nh set to be updated
--> Processing Dependency: sogo >= 1.3.4 for package: smeserver-sogo
--> Processing Dependency: sogo-tool for package: smeserver-sogo
--> Processing Dependency: sope49-gdl1-mysql for package: smeserver-sogo
--> Running transaction check
---> Package sogo.i386 0:1.3.14-1.el5 set to be updated
--> Processing Dependency: gnustep-base >= 1.23 for package: sogo
--> Processing Dependency: sope49-gdl1-contentstore >= 1.3.14 for package: sogo
--> Processing Dependency: sope49-cards >= 1.3.14 for package: sogo
--> Processing Dependency: sope49-ldap for package: sogo
--> Processing Dependency: sope49-appserver for package: sogo
--> Processing Dependency: sope49-core for package: sogo
--> Processing Dependency: memcached for package: sogo
--> Processing Dependency: sope49-sbjson for package: sogo
--> Processing Dependency: libmemcached for package: sogo
---> Package sogo-tool.i386 0:1.3.14-1.el5 set to be updated
---> Package sope49-gdl1-mysql.i386 0:4.9-20120323_1664.el5.1 set to be updated
--> Processing Dependency: sope49-gdl1 for package: sope49-gdl1-mysql
--> Running transaction check
---> Package gnustep-base.i386 0:1.23.0-1 set to be updated
--> Processing Dependency: gnustep-make >= 2.6.0 for package: gnustep-base
--> Processing Dependency: libffi.so.5 for package: gnustep-base
--> Processing Dependency: libobjc.so.1 for package: gnustep-base
---> Package libmemcached.i386 0:0.34-1 set to be updated
---> Package sogo.i386 0:1.3.14-1.el5 set to be updated
--> Processing Dependency: memcached for package: sogo
---> Package sope49-appserver.i386 0:4.9-20120323_1664.el5.1 set to be updated
--> Processing Dependency: sope49-xml for package: sope49-appserver
--> Processing Dependency: sope49-mime for package: sope49-appserver
---> Package sope49-cards.i386 0:1.3.14-1.el5 set to be updated
---> Package sope49-core.i386 0:4.9-20120323_1664.el5.1 set to be updated
---> Package sope49-gdl1.i386 0:4.9-20120323_1664.el5.1 set to be updated
---> Package sope49-gdl1-contentstore.i386 0:1.3.14-1.el5 set to be updated
---> Package sope49-ldap.i386 0:4.9-20120323_1664.el5.1 set to be updated
---> Package sope49-sbjson.i386 0:2.3.1-20120323_1664.el5.1 set to be updated
--> Running transaction check
---> Package gnustep-make.i386 0:2.6.1-1 set to be updated
---> Package libffi.i386 0:3.0.10-1 set to be updated
---> Package libobjc.i386 0:4.1.2-52.el5 set to be updated
---> Package sogo.i386 0:1.3.14-1.el5 set to be updated
--> Processing Dependency: memcached for package: sogo
---> Package sope49-mime.i386 0:4.9-20120323_1664.el5.1 set to be updated
---> Package sope49-xml.i386 0:4.9-20120323_1664.el5.1 set to be updated
--> Finished Dependency Resolution
sogo-1.3.14-1.el5.i386 from sogo has depsolving problems
  --> Missing Dependency: memcached is needed by package sogo-1.3.14-1.el5.i386 (sogo)
Error: Missing Dependency: memcached is needed by package sogo-1.3.14-1.el5.i386 (sogo)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.
« Last Edit: April 25, 2012, 01:55:31 AM by chris burnat »


Re: memcached missing Dependency for SMEServer-SOGO on SME 8b7
« Reply #2 on: April 25, 2012, 12:24:57 AM »
Thank you, it's working now!  :-P

Re: memcached missing Dependency for SMEServer-SOGO on SME 8b7
« Reply #3 on: April 25, 2012, 01:53:22 AM »
Moving to contrib section of the Forum and marking [solved].
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.