Koozali.org formerly Contribs.org

ruby on rails

Offline HACKERSOFT2011

  • *
  • 31
  • HACKERSOFT
    • Adventist International Mission School
ruby on rails
« on: January 19, 2012, 08:14:49 AM »
Hi! I am trying to follow the steps here on latest 8 beta for installing ruby on rails:

http://wiki.contribs.org/RubyOnRails

but I'm having dependency problems.

Quote
Resolving Dependencies
--> Running transaction check
---> Package ruby-mysql.i386 0:2.7-8.el4.centos set to be updated
--> Processing Dependency: libmysqlclient.so.14 for package: ruby-mysql
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: ruby-mysql
--> Processing Dependency: libssl.so.4 for package: ruby-mysql
--> Processing Dependency: libcrypto.so.4 for package: ruby-mysql
---> Package ruby-postgres.i386 0:0.7.1-4.el4.centos set to be updated
--> Processing Dependency: libpq.so.3 for package: ruby-postgres
--> Running transaction check
---> Package openssl097a.i386 0:0.9.7a-9.el5_4.2 set to be updated
---> Package ruby-mysql.i386 0:2.7-8.el4.centos set to be updated
--> Processing Dependency: libmysqlclient.so.14 for package: ruby-mysql
--> Processing Dependency: libmysqlclient.so.14(libmysqlclient_14) for package: ruby-mysql
---> Package ruby-postgres.i386 0:0.7.1-4.el4.centos set to be updated
--> Processing Dependency: libpq.so.3 for package: ruby-postgres
--> Finished Dependency Resolution
ruby-mysql-2.7-8.el4.centos.i386 from centos-testing has depsolving problems
  --> Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package ruby-mysql-2.7-8.el4.centos.i386 (centos-testing)
ruby-postgres-0.7.1-4.el4.centos.i386 from centos-testing has depsolving problems
  --> Missing Dependency: libpq.so.3 is needed by package ruby-postgres-0.7.1-4.el4.centos.i386 (centos-testing)
ruby-mysql-2.7-8.el4.centos.i386 from centos-testing has depsolving problems
  --> Missing Dependency: libmysqlclient.so.14 is needed by package ruby-mysql-2.7-8.el4.centos.i386 (centos-testing)
Error: Missing Dependency: libpq.so.3 is needed by package ruby-postgres-0.7.1-4.el4.centos.i386 (centos-testing)
Error: Missing Dependency: libmysqlclient.so.14 is needed by package ruby-mysql-2.7-8.el4.centos.i386 (centos-testing)
Error: Missing Dependency: libmysqlclient.so.14(libmysqlclient_14) is needed by package ruby-mysql-2.7-8.el4.centos.i386 (centos-testing)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

Any solution on this?


Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: ruby on rails
« Reply #1 on: January 19, 2012, 06:14:04 PM »
Any solution on this?
You fail to mention the commands you are using, you only show the output.

From the output it appears that you already have a ruby installation on your system as yum thinks it necessary to update ruby-mysql, it seems no package for this is available in centos-testing.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline Stefano

  • *
  • 10,805
  • Skype account: maghissimo
    • Smeserver italian community
Re: ruby on rails
« Reply #2 on: January 19, 2012, 06:19:24 PM »
Hi! I am trying to follow the steps here on latest 8 beta for installing ruby on rails:

http://wiki.contribs.org/RubyOnRails


did you modify the db command to reflect the fact you are using SME8 (Centos5.x based) instead of SME7 (Centos4.x based)?
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Offline HACKERSOFT2011

  • *
  • 31
  • HACKERSOFT
    • Adventist International Mission School
Re: ruby on rails
« Reply #3 on: January 20, 2012, 02:27:38 AM »
Yes, I actually change the 4 to 5 for the repo...

I am on my path on installing Canvas LMS in smeserver.

It has the following prerequisites to work properly:

ruby
ruby-dev
zlib1g-dev
rake
rubygems
libxml2-dev
libmysqlclient-dev
libxslt1-dev
libsqlite3-dev
libhttpclient-ruby
nano
imagemagick
irb 
libpq-dev
nodejs


Hope it is possible to work with smeserver.

Thanks!

Offline HACKERSOFT2011

  • *
  • 31
  • HACKERSOFT
    • Adventist International Mission School
Re: ruby on rails
« Reply #4 on: January 20, 2012, 04:19:30 AM »
With the following steps I was able to install ruby and gems but could not install rails:

Quote
yum install gcc-c++ libxml2-devel bzip2-devel curl-devel

wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-1.8.6-1.i386.rpm
wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-devel-1.8.6-1.i386.rpm
wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-docs-1.8.6-1.i386.rpm
wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-irb-1.8.6-1.i386.rpm
wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-libs-1.8.6-1.i386.rpm
wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-mode-1.8.6-1.i386.rpm
wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-ri-1.8.6-1.i386.rpm
wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-tcltk-1.8.6-1.i386.rpm
wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-rdoc-1.8.6-1.i386.rpm
wget http://www.swabe.org/files/redhat/RPMS/i386/ruby-mysql-2.7.4-1.i386.rpm

yum localinstall ruby*

ruby -v

mkdir downloads
cd downloads

wget -c http://rubyforge.org/frs/download.php/60718/rubygems-1.3.5.tgz
tar xzvf rubygems-1.3.5.tgz
cd rubygems-1.3.5
ruby setup.rb
cd ..

gem -v


The error for:

gem install rails


is:
Quote
gem install rails
*** buffer overflow detected ***: /usr/bin/ruby terminated
======= Backtrace: =========
/lib/libc.so.6(__chk_fail+0x41)[0x8ea971]
/usr/lib/ruby/1.8/i386-linux/syck.so(rb_syck_mktime+0x505)[0xb7d8acc5]
/usr/lib/ruby/1.8/i386-linux/syck.so(yaml_org_handler+0x838)[0xb7d8b5e8]
/usr/lib/ruby/1.8/i386-linux/syck.so(syck_defaultresolver_node_import+0x3f)[0xb7d8b94f]
/usr/lib/libruby.so.1.8[0xb7e54bfa]
/usr/lib/libruby.so.1.8[0xb7e5c79b]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8[0xb7e5dade]
/usr/lib/libruby.so.1.8(rb_funcall+0x20)[0xb7e5dc70]
/usr/lib/ruby/1.8/i386-linux/syck.so(rb_syck_load_handler+0x69)[0xb7d8a6e9]
/usr/lib/ruby/1.8/i386-linux/syck.so(syck_hdlr_add_node+0x4a)[0xb7d905ea]
/usr/lib/ruby/1.8/i386-linux/syck.so(syckparse+0xb98)[0xb7d94f38]
/usr/lib/ruby/1.8/i386-linux/syck.so(syck_parse+0x32)[0xb7d8edd2]
/usr/lib/ruby/1.8/i386-linux/syck.so(syck_parser_load+0x112)[0xb7d8a532]
/usr/lib/libruby.so.1.8[0xb7e54c18]
/usr/lib/libruby.so.1.8[0xb7e5c79b]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8[0xb7e6530e]
/usr/lib/libruby.so.1.8[0xb7e63aed]
/usr/lib/libruby.so.1.8[0xb7e5d086]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8[0xb7e6530e]
/usr/lib/libruby.so.1.8[0xb7e63aed]
/usr/lib/libruby.so.1.8[0xb7e5d086]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8[0xb7e6530e]
/usr/lib/libruby.so.1.8[0xb7e65e0e]
/usr/lib/libruby.so.1.8[0xb7e5d086]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8[0xb7e65434]
/usr/lib/libruby.so.1.8[0xb7e63805]
/usr/lib/libruby.so.1.8[0xb7e66179]
/usr/lib/libruby.so.1.8[0xb7e67fd6]
/usr/lib/libruby.so.1.8[0xb7e650ad]
/usr/lib/libruby.so.1.8[0xb7e67fd6]
/usr/lib/libruby.so.1.8[0xb7e6928d]
/usr/lib/libruby.so.1.8[0xb7e54c05]
/usr/lib/libruby.so.1.8[0xb7e5c79b]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8[0xb7e65434]
/usr/lib/libruby.so.1.8[0xb7e667a0]
/usr/lib/libruby.so.1.8[0xb7e5d086]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8[0xb7e6530e]
/usr/lib/libruby.so.1.8[0xb7e667a0]
/usr/lib/libruby.so.1.8[0xb7e5d086]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8(rb_obj_call_init+0x57)[0xb7e5d7d7]
/usr/lib/libruby.so.1.8(rb_class_new_instance+0x3a)[0xb7e8b74a]
/usr/lib/libruby.so.1.8[0xb7e54c18]
/usr/lib/libruby.so.1.8[0xb7e5c79b]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8(rb_call_super+0xaa)[0xb7e5e4ba]
/usr/lib/libruby.so.1.8[0xb7e5c8b2]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8[0xb7e65434]
/usr/lib/libruby.so.1.8[0xb7e63aed]
/usr/lib/libruby.so.1.8[0xb7e66179]
/usr/lib/libruby.so.1.8[0xb7e5d086]
/usr/lib/libruby.so.1.8[0xb7e5d4d8]
/usr/lib/libruby.so.1.8[0xb7e6530e]
/usr/lib/libruby.so.1.8[0xb7e66ebd]
/usr/lib/libruby.so.1.8[0xb7e646e4]
======= Memory map: ========
00607000-0069b000 r-xp 00000000 fd:00 12950284   /usr/lib/libkrb5.so.3.3
0069b000-0069e000 rwxp 00093000 fd:00 12950284   /usr/lib/libkrb5.so.3.3
006a0000-006a8000 r-xp 00000000 fd:00 12955377   /usr/lib/libkrb5support.so.0.1
006a8000-006a9000 rwxp 00007000 fd:00 12955377   /usr/lib/libkrb5support.so.0.1
006ab000-006d8000 r-xp 00000000 fd:00 12952055   /usr/lib/libgssapi_krb5.so.2.2
006d8000-006d9000 rwxp 0002d000 fd:00 12952055   /usr/lib/libgssapi_krb5.so.2.2
006db000-00701000 r-xp 00000000 fd:00 12952835   /usr/lib/libk5crypto.so.3.1
00701000-00702000 rwxp 00025000 fd:00 12952835   /usr/lib/libk5crypto.so.3.1
00704000-00748000 r-xp 00000000 fd:00 28606539   /lib/libssl.so.0.9.8e
00748000-0074c000 rwxp 00043000 fd:00 28606539   /lib/libssl.so.0.9.8e
007e5000-00800000 r-xp 00000000 fd:00 28606486   /lib/ld-2.5.so
00800000-00801000 r-xp 0001a000 fd:00 28606486   /lib/ld-2.5.so
00801000-00802000 rwxp 0001b000 fd:00 28606486   /lib/ld-2.5.so
00804000-00957000 r-xp 00000000 fd:00 28607359   /lib/libc-2.5.so
00957000-00959000 r-xp 00153000 fd:00 28607359   /lib/libc-2.5.so
00959000-0095a000 rwxp 00155000 fd:00 28607359   /lib/libc-2.5.so
0095a000-0095d000 rwxp 0095a000 00:00 0
0095f000-00962000 r-xp 00000000 fd:00 28608079   /lib/libdl-2.5.so
00962000-00963000 r-xp 00002000 fd:00 28608079   /lib/libdl-2.5.so
00963000-00964000 rwxp 00003000 fd:00 28608079   /lib/libdl-2.5.so
00966000-00978000 r-xp 00000000 fd:00 28608080   /lib/libz.so.1.2.3
00978000-00979000 rwxp 00011000 fd:00 28608080   /lib/libz.so.1.2.3
0097b000-009a2000 r-xp 00000000 fd:00 28608077   /lib/libm-2.5.so
009a2000-009a3000 r-xp 00026000 fd:00 28608077   /lib/libm-2.5.so
009a3000-009a4000 rwxp 00027000 fd:00 28608077   /lib/libm-2.5.so
009a6000-009e1000 r-xp 00000000 fd:00 28608086   /lib/libsepol.so.1
009e1000-009e2000 rwxp 0003b000 fd:00 28608086   /lib/libsepol.so.1
009e2000-009ec000 rwxp 009e2000 00:00 0
009ee000-00a03000 r-xp 00000000 fd:00 28608084   /lib/libpthread-2.5.so
00a03000-00a04000 r-xp 00015000 fd:00 28608084   /lib/libpthread-2.5.so
00a04000-00a05000 rwxp 00016000 fd:00 28608084   /lib/libpthread-2.5.so
00a05000-00a07000 rwxp 00a05000 00:00 0
00a09000-00a1f000 r-xp 00000000 fd:00 28608087   /lib/libselinux.so.1
00a1f000-00a21000 rwxp 00015000 fd:00 28608087   /lib/libselinux.so.1
00a23000-00b4d000 r-xp 00000000 fd:00 28608081   /lib/libcrypto.so.0.9.8e
00b4d000-00b60000 rwxp 00129000 fd:00 28608081   /lib/libcrypto.so.0.9.8e
00b60000-00b64000 rwxp 00b60000 00:00 0
00b66000-00b6f000 r-xp 00000000 fd:00 28608110   /lib/libcrypt-2.5.so
00b6f000-00b70000 r-xp 00008000 fd:00 28608110   Aborted




Re: ruby on rails
« Reply #5 on: January 20, 2012, 11:10:33 AM »
Seems like a square peg in a round hole....

I'd use Ubuntu..... The install looks complicated enough for a platform they recommend...

 8-)
Kevin in WV 8-)......

Re: ruby on rails
« Reply #6 on: April 23, 2012, 12:15:13 PM »
Does this mean that Ruby on Rails won't work on SME-server 8 ?

Offline Stefano

  • *
  • 10,805
  • Skype account: maghissimo
    • Smeserver italian community
Re: ruby on rails
« Reply #7 on: April 23, 2012, 12:25:39 PM »
what version of ruby are you trying to install?
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Re: ruby on rails
« Reply #8 on: April 23, 2012, 02:05:51 PM »
Stefano

Good question ...

I am actually planning on a trial install of Fat Free CRM - a Customer Realations Software written in RubyOnRails. It is often held up as a good example of a successful Ruby project. Unfortunately the demo site is very slow (not such a good example) hence I feel the only way to properly evaluate it is my doing trial install.

'Fat Free CRM' System Requirements
https://github.com/fatfreecrm/fat_free_crm
    * Ruby v1.8.7 or v1.9.2
    * MySQL v4.1.1 or later (v5+ is recommended), SQLite v3.4 or later, or Postgres 8.4.8 or later.
    * ImageMagick (optional, only needed if you would like to use avatars)
(Ruby on Rails and other gem dependencies will be installed automatically by Bundler.)

This had been my planned route:
https://github.com/joshfng/railsready - Rails Ready: Ruby and Rails setup script for Linux and OSX
Distros supported:
    * Ubuntu 10.04 LTS, 10.10 and 11.04
    * CentOS 5 (utilizes the Fedora EPEL repo)        ... same as SME server v8b7   8)
    * OSX (requires XCode to be installed)
Run this on a fresh install. It WILL update your system!

SME Server v8b7 - is it compatible?
http://wiki.contribs.org/RubyOnRails - Ruby on Rails Wiki page - RubyOnRails 2.0 on the SME Server 7 - ruby 1.8.5 (2006-08-25), rubygems-1.3.5
http://wiki.contribs.org/MythTV - "MySQL version 4.1 is the default version with default SME Server 7.3 "

I know that MySQL versions 5.0 to 5.5 are available for download (http://dev.mysql.com/downloads/mysql/), but I can't find which MySQL version is the 'default version' for SMEv8b7. It doesn't seem to be mentioned in the SMEv8 Release Notes.

I had planned on downloading and installing all the latest components.

However, this has got me wondering if my plan is workable - ..."Seems like a square peg in a round hole  ....  I'd use Ubuntu."

Hence my question.

BTW, will I need 'Apache with Passenger' (Phusion Passenger® — a.k.a. mod_rails or mod_rack — makes deployment of Ruby web applications, such as those built on the revolutionary Ruby on Rails web framework, a breeze), or  'WebbBrick' (what is webbrick?)?

Is my plan a sensible one?

Charles

Re: ruby on rails
« Reply #9 on: April 23, 2012, 08:07:06 PM »
Moving to contribs 8.xx section of the Forums where it is more appropriate.
- chris
If it does not work out of the box, please fill in a Bug Report @ Bugzilla (http://bugs.contribs.org)  - check: http://wiki.contribs.org/Bugzilla_Help .  Thanks.

Re: ruby on rails
« Reply #10 on: April 23, 2012, 09:13:39 PM »
deleted
« Last Edit: April 25, 2012, 12:21:14 PM by Charles2008 »

Re: ruby on rails
« Reply #11 on: January 07, 2013, 04:41:58 PM »
I thought this might be worth posting for others to use, although it would be useful also if someone could tell me if I'm doing something awfully bad for an sme server 8 setup.
I needed to use "gem install sass" for a web project. I realised that it wouldn't work with the current ruby contrib and needed a more up to date version.

I followed this tutorial
http://blog.nexcess.net/2011/05/27/ruby-1-8-7-on-centos-5-with-rvm/

This worked for me perfectly.