Koozali.org formerly Contribs.org

Broken LDAP Server?

Offline maicz

Broken LDAP Server?
« on: January 07, 2012, 12:27:32 AM »
Hi all,
I have installed SOGo on SME8b7, and in order to add multiple mail senders in it, i noticed that my LDAP Server is broken.
If i log on phpldapadmin, i see only this message:

   dc=(mydomain),dc=it
   This base entry does not exist.Create it?

And surely can't view schema. If manually try to create this entry, it says that already exists.
For test, i've create an address book in thunderbid connected to SME Local Users, and it doesn't work. Apparently, Thunderbird successfully connect to SME, but this:

Code: [Select]
2012-01-06 23:50:12.452151500 conn=12 fd=13 ACCEPT from IP=10.1.1.2:53315 (IP=0.0.0.0:389)
2012-01-06 23:50:12.452209500 conn=12 op=0 BIND dn="" method=128
2012-01-06 23:50:12.452251500 conn=12 op=0 RESULT tag=97 err=0 text=
2012-01-06 23:50:12.452833500 conn=12 op=1 SRCH base="dc=<mydomain>,dc=it" scope=2 deref=0 filter="(|(mail=*mi*)(cn=*mi*)(givenName=*mi*)(sn=*mi*))"
2012-01-06 23:50:12.452856500 conn=12 op=1 SRCH attr=birthday o company mail modifytimestamp mozillaHomeCountryName mozillaUseHtmlMail xmozillausehtmlmail mozillaCustom2 custom2 mozillaCustom4 custom4 ou department departmentnumber orgunit mobile cellphone carphone telephoneNumber title mozillaCustom1 custom1 sn surname mozillaNickname xmozillanickname mozillaWorkUrl workurl labeledURI facsimiletelephonenumber fax mozillaSecondEmail xmozillasecondemail nsAIMid nscpaimscreenname street streetaddress postOfficeBox l locality homePhone mozillaHomeUrl homeurl mozillaHomeStreet givenName mozillaHomePostalCode mozillaHomeLocalityName mozillaCustom3 custom3 mozillaWorkStreet2 mozillaHomeStreet2 postalCode zip birthmonth c countryname pager pagerphone mozillaHomeState st region description notes birthyear cn commonname objectClass
2012-01-06 23:50:12.453029500 conn=12 op=1 SEARCH RESULT tag=101 err=32 nentries=0 text=

...appears in LDAP logfile when i search on LDAP Address book.
So, what can i check for restore or regenerate LDAP schema?
Note that the rest of services on server works great!

Code: [Select]
[root@sme ~]# config show ldap
ldap=service
    Authentication=disabled
    TCPPort=389
    TCPPorts=389,636
    access=public
    defaultCity=<some data>
    defaultCompany=
    defaultDepartment=
    defaultPhoneNumber=<some data>
    defaultStreet=<some data>
    status=enabled

Thank you in advance