Koozali.org formerly Contribs.org

yum update dependency ?

Offline fpausp

  • *
  • 728
yum update dependency ?
« on: May 19, 2010, 02:42:22 PM »
Hi All,

I have problems to get updates on a sme8b5 server with a few contribs installed.

The contribs are:

crontab
fetchmail
phpmyadmin
sogo
tw-logonscript

Code: [Select]
[root@server ~]# yum update
Loaded plugins: fastestmirror, protect-packages, smeserver
Determining fastest mirrors
 * base: centos.mirroraustria.at
 * smeaddons: smemirror.fullnet.co.uk
 * smeextras: smemirror.fullnet.co.uk
 * smeos: smemirror.fullnet.co.uk
 * smeupdates: smemirror.fullnet.co.uk
 * updates: centos.mirroraustria.at
base                                                                                                   | 1.1 kB     00:00
base/primary                                                                                           | 920 kB     00:01
base                                                                                                                2599/2599
smeaddons                                                                                              | 1.9 kB     00:00
smeaddons/primary_db                                                                                   | 1.1 kB     00:00
smeextras                                                                                              | 1.9 kB     00:00
smeextras/primary_db                                                                                   |  75 kB     00:00
smeos                                                                                                  | 2.1 kB     00:00
smeos/primary_db                                                                                       | 625 kB     00:01
smeupdates                                                                                             | 1.9 kB     00:00
smeupdates/primary_db                                                                                  | 1.1 kB     00:00
updates                                                                                                | 1.9 kB     00:00
updates/primary_db                                                                                     |  74 kB     00:00
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package apr-util.i386 0:1.2.7-11.el5 set to be updated
---> Package at.i386 0:3.1.8-84.el5 set to be updated
---> Package audit.i386 0:1.7.17-3.el5 set to be updated
---> Package audit-libs.i386 0:1.7.17-3.el5 set to be updated
---> Package audit-libs-python.i386 0:1.7.17-3.el5 set to be updated
---> Package automake.noarch 0:1.9.6-2.3.el5 set to be updated
---> Package binutils.i386 0:2.17.50.0.6-14.el5 set to be updated
---> Package centos-release.i386 10:5-5.el5.centos set to be updated
---> Package centos-release-notes.i386 0:5.5-0 set to be updated
---> Package chkconfig.i386 0:1.3.30.2-2.el5 set to be updated
---> Package cpuspeed.i386 1:1.2.1-9.el5 set to be updated
---> Package cups-libs.i386 1:1.3.7-18.el5 set to be updated
---> Package curl.i386 0:7.15.5-9.el5 set to be updated
---> Package dbus.i386 0:1.1.2-14.el5 set to be updated
---> Package dbus-libs.i386 0:1.1.2-14.el5 set to be updated
---> Package device-mapper.i386 0:1.02.39-1.el5 set to be updated
---> Package device-mapper-event.i386 0:1.02.39-1.el5 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-34.el5 set to be updated
---> Package dhclient.i386 12:3.0.5-23.el5 set to be updated
---> Package dhcp.i386 12:3.0.5-23.el5 set to be updated
---> Package dmidecode.i386 1:2.10-3.el5 set to be updated
---> Package dmraid.i386 0:1.0.0.rc13-63.el5 set to be updated
---> Package dmraid-events.i386 0:1.0.0.rc13-63.el5 set to be updated
---> Package dosfstools.i386 0:2.11-9.el5 set to be updated
---> Package ethtool.i386 0:6-4.el5 set to be updated
---> Package filesystem.i386 0:2.4.0-3.el5 set to be updated
---> Package freeradius.i386 0:1.1.3-1.6.el5 set to be updated
---> Package glibc.i686 0:2.5-49 set to be updated
---> Package glibc-common.i386 0:2.5-49 set to be updated
---> Package hal.i386 0:0.5.8.1-59.el5 set to be updated
---> Package hmaccalc.i386 0:0.9.6-3.el5 set to be updated
---> Package httpd.i386 0:2.2.3-43.el5.centos set to be updated
---> Package hwdata.noarch 0:0.213.18-1.el5.1 set to be updated
---> Package iproute.i386 0:2.6.18-11.el5 set to be updated
---> Package iptstate.i386 0:1.4-2.el5 set to be updated
---> Package kernel-PAE.i686 0:2.6.18-194.3.1.el5 set to be installed
---> Package kpartx.i386 0:0.4.7-34.el5 set to be updated
---> Package kudzu.i386 0:1.2.57.1.24-1.el5.centos set to be updated
---> Package less.i386 0:436-2.el5 set to be updated
---> Package libXt.i386 0:1.0.2-3.2.el5 set to be updated
---> Package libacl.i386 0:2.2.39-6.el5 set to be updated
--> Processing Dependency: libevent-1.1a.so.1 for package: memcached
---> Package libevent.i386 0:1.4.13-1 set to be updated
---> Package libgcc.i386 0:4.1.2-48.el5 set to be updated
---> Package libobjc.i386 0:4.1.2-48.el5 set to be updated
---> Package libpcap.i386 14:0.9.4-15.el5 set to be updated
---> Package libsepol.i386 0:1.15.2-3.el5 set to be updated
---> Package libstdc++.i386 0:4.1.2-48.el5 set to be updated
---> Package lm_sensors.i386 0:2.10.7-9.el5 set to be updated
---> Package lvm2.i386 0:2.02.56-8.el5_5.1 set to be updated
---> Package mdadm.i386 0:2.6.9-3.el5 set to be updated
---> Package microcode_ctl.i386 1:1.17-1.50.el5 set to be updated
---> Package mkinitrd.i386 0:5.1.19.6-61.el5_5.1 set to be updated
---> Package mod_ssl.i386 1:2.2.3-43.el5.centos set to be updated
---> Package module-init-tools.i386 0:3.3-0.pre3.1.60.el5 set to be updated
---> Package nash.i386 0:5.1.19.6-61.el5_5.1 set to be updated
---> Package net-snmp.i386 1:5.3.2.2-9.el5 set to be updated
---> Package net-snmp-libs.i386 1:5.3.2.2-9.el5 set to be updated
---> Package net-snmp-utils.i386 1:5.3.2.2-9.el5 set to be updated
---> Package net-tools.i386 0:1.60-81.el5 set to be updated
---> Package newt.i386 0:0.52.2-15.el5 set to be updated
---> Package openldap.i386 0:2.3.43-12.el5 set to be updated
---> Package openldap-servers.i386 0:2.3.43-12.el5 set to be updated
---> Package openssh.i386 0:4.3p2-41.el5 set to be updated
---> Package openssh-clients.i386 0:4.3p2-41.el5 set to be updated
---> Package openssh-server.i386 0:4.3p2-41.el5 set to be updated
---> Package pciutils.i386 0:2.2.3-8.el5_4 set to be updated
---> Package perl-XML-SAX.noarch 0:0.14-8 set to be updated
---> Package policycoreutils.i386 0:1.33.12-14.8.el5 set to be updated
---> Package procps.i386 0:3.2.7-16.el5 set to be updated
---> Package shadow-utils.i386 2:4.0.17-15.el5 set to be updated
---> Package squid.i386 7:2.6.STABLE21-6.el5 set to be updated
---> Package sudo.i386 0:1.7.2p1-6.el5_5 set to be updated
---> Package sysklogd.i386 0:1.4.1-46.el5 set to be updated
---> Package system-config-securitylevel-tui.i386 0:1.6.29.1-5.el5 set to be updated
---> Package tar.i386 2:1.15.1-30.el5 set to be updated
---> Package tcpdump.i386 14:3.9.4-15.el5 set to be updated
---> Package tcsh.i386 0:6.14-17.el5 set to be updated
---> Package tzdata.i386 0:2010i-1.el5 set to be updated
---> Package vconfig.i386 0:1.9-3 set to be updated
---> Package yum.noarch 0:3.2.22-26.el5.centos set to be updated
base/filelists                                                                                         | 2.9 MB     00:06
smeaddons/filelists_db                                                                                 |  563 B     00:00
smeextras/filelists_db                                                                                 |  91 kB     00:00
smeos/filelists_db                                                                                     | 492 kB     00:00
smeupdates/filelists_db                                                                                |  581 B     00:00
updates/filelists_db                                                                                   | 428 kB     00:00
--> Finished Dependency Resolution
memcached-1.4.2-1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.2-1.el5.i386 (installed)
Error: Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.2-1.el5.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.

Can you help me please ?

Best
Viribus unitis

Offline Daniel B.

  • *
  • 1,693
    • Firewall Services, la sécurité des réseaux
Re: yum update dependency ?
« Reply #1 on: May 19, 2010, 02:54:48 PM »
Hi.

This is a bug in the memcached package provided in the sogo repository. This bug has been reported in sogo bug tracker: http://www.scalableogo.org/bugs/view.php?id=605

Regards, Daniel
C'est la fin du monde !!! :lol:

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: yum update dependency ?
« Reply #2 on: May 19, 2010, 02:58:22 PM »
Yes, try and ignore memcached like this:

Code: [Select]
yum update --exclude=memcached
Otherwise remove memcached as that is an additional package as well and try again. It does not come with the default installation.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: yum update dependency ?
« Reply #3 on: May 19, 2010, 02:59:23 PM »
Please do not post SME Server 8 related posts in SME Server 7.x related forums. Moving this topic to General Discussion as it is more appropriate there. Thanks.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline fpausp

  • *
  • 728
Re: yum update dependency ?
« Reply #4 on: May 19, 2010, 06:00:11 PM »
OK, thanks for your help.

Best
Viribus unitis

Offline fpausp

  • *
  • 728
Re: yum update dependency ?
« Reply #5 on: May 19, 2010, 06:11:59 PM »
Hi,

yum update with --exclude=mem... :

Code: [Select]
[root@serever ~]# yum update --exclude=memcached
Loaded plugins: fastestmirror, protect-packages, smeserver
Loading mirror speeds from cached hostfile
 * base: centos.mirroraustria.at
 * smeaddons: smemirror.fullnet.co.uk
 * smeextras: smemirror.fullnet.co.uk
 * smeos: smemirror.fullnet.co.uk
 * smeupdates: smemirror.fullnet.co.uk
 * updates: centos.mirroraustria.at
Excluding Packages in global exclude list
Finished
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package apr-util.i386 0:1.2.7-11.el5 set to be updated
---> Package at.i386 0:3.1.8-84.el5 set to be updated
---> Package audit.i386 0:1.7.17-3.el5 set to be updated
---> Package audit-libs.i386 0:1.7.17-3.el5 set to be updated
---> Package audit-libs-python.i386 0:1.7.17-3.el5 set to be updated
---> Package automake.noarch 0:1.9.6-2.3.el5 set to be updated
---> Package binutils.i386 0:2.17.50.0.6-14.el5 set to be updated
---> Package centos-release.i386 10:5-5.el5.centos set to be updated
---> Package centos-release-notes.i386 0:5.5-0 set to be updated
---> Package chkconfig.i386 0:1.3.30.2-2.el5 set to be updated
---> Package cpuspeed.i386 1:1.2.1-9.el5 set to be updated
---> Package cups-libs.i386 1:1.3.7-18.el5 set to be updated
---> Package curl.i386 0:7.15.5-9.el5 set to be updated
---> Package dbus.i386 0:1.1.2-14.el5 set to be updated
---> Package dbus-libs.i386 0:1.1.2-14.el5 set to be updated
---> Package device-mapper.i386 0:1.02.39-1.el5 set to be updated
---> Package device-mapper-event.i386 0:1.02.39-1.el5 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-34.el5 set to be updated
---> Package dhclient.i386 12:3.0.5-23.el5 set to be updated
---> Package dhcp.i386 12:3.0.5-23.el5 set to be updated
---> Package dmidecode.i386 1:2.10-3.el5 set to be updated
---> Package dmraid.i386 0:1.0.0.rc13-63.el5 set to be updated
---> Package dmraid-events.i386 0:1.0.0.rc13-63.el5 set to be updated
---> Package dosfstools.i386 0:2.11-9.el5 set to be updated
---> Package ethtool.i386 0:6-4.el5 set to be updated
---> Package filesystem.i386 0:2.4.0-3.el5 set to be updated
---> Package freeradius.i386 0:1.1.3-1.6.el5 set to be updated
---> Package glibc.i686 0:2.5-49 set to be updated
---> Package glibc-common.i386 0:2.5-49 set to be updated
---> Package hal.i386 0:0.5.8.1-59.el5 set to be updated
---> Package hmaccalc.i386 0:0.9.6-3.el5 set to be updated
---> Package httpd.i386 0:2.2.3-43.el5.centos set to be updated
---> Package hwdata.noarch 0:0.213.18-1.el5.1 set to be updated
---> Package iproute.i386 0:2.6.18-11.el5 set to be updated
---> Package iptstate.i386 0:1.4-2.el5 set to be updated
---> Package kernel-PAE.i686 0:2.6.18-194.3.1.el5 set to be installed
---> Package kpartx.i386 0:0.4.7-34.el5 set to be updated
---> Package kudzu.i386 0:1.2.57.1.24-1.el5.centos set to be updated
---> Package less.i386 0:436-2.el5 set to be updated
---> Package libXt.i386 0:1.0.2-3.2.el5 set to be updated
---> Package libacl.i386 0:2.2.39-6.el5 set to be updated
--> Processing Dependency: libevent-1.1a.so.1 for package: memcached
---> Package libevent.i386 0:1.4.13-1 set to be updated
---> Package libgcc.i386 0:4.1.2-48.el5 set to be updated
---> Package libobjc.i386 0:4.1.2-48.el5 set to be updated
---> Package libpcap.i386 14:0.9.4-15.el5 set to be updated
---> Package libsepol.i386 0:1.15.2-3.el5 set to be updated
---> Package libstdc++.i386 0:4.1.2-48.el5 set to be updated
---> Package lm_sensors.i386 0:2.10.7-9.el5 set to be updated
---> Package lvm2.i386 0:2.02.56-8.el5_5.1 set to be updated
---> Package mdadm.i386 0:2.6.9-3.el5 set to be updated
---> Package microcode_ctl.i386 1:1.17-1.50.el5 set to be updated
---> Package mkinitrd.i386 0:5.1.19.6-61.el5_5.1 set to be updated
---> Package mod_ssl.i386 1:2.2.3-43.el5.centos set to be updated
---> Package module-init-tools.i386 0:3.3-0.pre3.1.60.el5 set to be updated
---> Package nash.i386 0:5.1.19.6-61.el5_5.1 set to be updated
---> Package net-snmp.i386 1:5.3.2.2-9.el5 set to be updated
---> Package net-snmp-libs.i386 1:5.3.2.2-9.el5 set to be updated
---> Package net-snmp-utils.i386 1:5.3.2.2-9.el5 set to be updated
---> Package net-tools.i386 0:1.60-81.el5 set to be updated
---> Package newt.i386 0:0.52.2-15.el5 set to be updated
---> Package openldap.i386 0:2.3.43-12.el5 set to be updated
---> Package openldap-servers.i386 0:2.3.43-12.el5 set to be updated
---> Package openssh.i386 0:4.3p2-41.el5 set to be updated
---> Package openssh-clients.i386 0:4.3p2-41.el5 set to be updated
---> Package openssh-server.i386 0:4.3p2-41.el5 set to be updated
---> Package pciutils.i386 0:2.2.3-8.el5_4 set to be updated
---> Package perl-XML-SAX.noarch 0:0.14-8 set to be updated
---> Package policycoreutils.i386 0:1.33.12-14.8.el5 set to be updated
---> Package procps.i386 0:3.2.7-16.el5 set to be updated
---> Package shadow-utils.i386 2:4.0.17-15.el5 set to be updated
---> Package squid.i386 7:2.6.STABLE21-6.el5 set to be updated
---> Package sudo.i386 0:1.7.2p1-6.el5_5 set to be updated
---> Package sysklogd.i386 0:1.4.1-46.el5 set to be updated
---> Package system-config-securitylevel-tui.i386 0:1.6.29.1-5.el5 set to be upd                                              ated
---> Package tar.i386 2:1.15.1-30.el5 set to be updated
---> Package tcpdump.i386 14:3.9.4-15.el5 set to be updated
---> Package tcsh.i386 0:6.14-17.el5 set to be updated
---> Package tzdata.i386 0:2010i-1.el5 set to be updated
---> Package vconfig.i386 0:1.9-3 set to be updated
---> Package yum.noarch 0:3.2.22-26.el5.centos set to be updated
--> Finished Dependency Resolution
memcached-1.4.2-1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.                                              2-1.el5.i386 (installed)
Error: Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4                                              .2-1.el5.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.




yum remove memch...

Code: [Select]
[root@servere ~]# yum remove memcached-1.4.2-1.el5.i386
Loaded plugins: fastestmirror, protect-packages, smeserver
Setting up Remove Process
Resolving Dependencies
--> Running transaction check
---> Package memcached.i386 0:1.4.2-1.el5 set to be erased
--> Processing Dependency: memcached for package: sogo
--> Running transaction check
---> Package sogo.i386 0:1.2.1-1.el5 set to be erased
--> Processing Dependency: sogo for package: smeserver-sogo
--> Running transaction check
---> Package smeserver-sogo.noarch 0:0.5.3-1.el5.sme set to be erased
--> Finished Dependency Resolution

Dependencies Resolved

==============================================================================================================================
 Package                         Arch                    Version                             Repository                  Size
==============================================================================================================================
Removing:
 memcached                       i386                    1.4.2-1.el5                         installed                  160 k
Removing for dependencies:
 smeserver-sogo                  noarch                  0.5.3-1.el5.sme                     installed                  6.5 k
 sogo                            i386                    1.2.1-1.el5                         installed                  6.8 M

Transaction Summary
==============================================================================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       3 Package(sB

Is this ok [y/N]:



But i dont like to remove sogo, should i wait until the bug is fixed ?

Regards
Viribus unitis

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: yum update dependency ?
« Reply #6 on: May 19, 2010, 07:43:10 PM »
Strange, what does this do?

Code: [Select]
yum update --exclude=memcached*
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline byte

  • *
  • 2,183
Re: yum update dependency ?
« Reply #7 on: May 19, 2010, 09:20:59 PM »
Before you try that remember to clean your yum cache.

Code: [Select]
yum clean all
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

Offline fpausp

  • *
  • 728
Re: yum update dependency ?
« Reply #8 on: May 19, 2010, 09:27:18 PM »
@ cactus

Code: [Select]
[root@server ~]# yum update --exclude=memcached*
Loaded plugins: fastestmirror, protect-packages, smeserver
Loading mirror speeds from cached hostfile
 * base: ftp-stud.fht-esslingen.de
 * smeaddons: ftp.nluug.nl
 * smeextras: ftp.nluug.nl
 * smeos: ftp.nluug.nl
 * smeupdates: ftp.nluug.nl
 * updates: centos.intergenia.de
Excluding Packages in global exclude list
Finished
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package apr-util.i386 0:1.2.7-11.el5 set to be updated
---> Package at.i386 0:3.1.8-84.el5 set to be updated
---> Package audit.i386 0:1.7.17-3.el5 set to be updated
---> Package audit-libs.i386 0:1.7.17-3.el5 set to be updated
---> Package audit-libs-python.i386 0:1.7.17-3.el5 set to be updated
---> Package automake.noarch 0:1.9.6-2.3.el5 set to be updated
---> Package binutils.i386 0:2.17.50.0.6-14.el5 set to be updated
---> Package centos-release.i386 10:5-5.el5.centos set to be updated
---> Package centos-release-notes.i386 0:5.5-0 set to be updated
---> Package chkconfig.i386 0:1.3.30.2-2.el5 set to be updated
---> Package cpuspeed.i386 1:1.2.1-9.el5 set to be updated
---> Package cups-libs.i386 1:1.3.7-18.el5 set to be updated
---> Package curl.i386 0:7.15.5-9.el5 set to be updated
---> Package dbus.i386 0:1.1.2-14.el5 set to be updated
---> Package dbus-libs.i386 0:1.1.2-14.el5 set to be updated
---> Package device-mapper.i386 0:1.02.39-1.el5 set to be updated
---> Package device-mapper-event.i386 0:1.02.39-1.el5 set to be updated
---> Package device-mapper-multipath.i386 0:0.4.7-34.el5 set to be updated
---> Package dhclient.i386 12:3.0.5-23.el5 set to be updated
---> Package dhcp.i386 12:3.0.5-23.el5 set to be updated
---> Package dmidecode.i386 1:2.10-3.el5 set to be updated
---> Package dmraid.i386 0:1.0.0.rc13-63.el5 set to be updated
---> Package dmraid-events.i386 0:1.0.0.rc13-63.el5 set to be updated
---> Package dosfstools.i386 0:2.11-9.el5 set to be updated
---> Package ethtool.i386 0:6-4.el5 set to be updated
---> Package filesystem.i386 0:2.4.0-3.el5 set to be updated
---> Package freeradius.i386 0:1.1.3-1.6.el5 set to be updated
---> Package glibc.i686 0:2.5-49 set to be updated
---> Package glibc-common.i386 0:2.5-49 set to be updated
---> Package hal.i386 0:0.5.8.1-59.el5 set to be updated
---> Package hmaccalc.i386 0:0.9.6-3.el5 set to be updated
---> Package httpd.i386 0:2.2.3-43.el5.centos set to be updated
---> Package hwdata.noarch 0:0.213.18-1.el5.1 set to be updated
---> Package iproute.i386 0:2.6.18-11.el5 set to be updated
---> Package iptstate.i386 0:1.4-2.el5 set to be updated
---> Package kernel-PAE.i686 0:2.6.18-194.3.1.el5 set to be installed
---> Package kpartx.i386 0:0.4.7-34.el5 set to be updated
---> Package kudzu.i386 0:1.2.57.1.24-1.el5.centos set to be updated
---> Package less.i386 0:436-2.el5 set to be updated
---> Package libXt.i386 0:1.0.2-3.2.el5 set to be updated
---> Package libacl.i386 0:2.2.39-6.el5 set to be updated
--> Processing Dependency: libevent-1.1a.so.1 for package: memcached
---> Package libevent.i386 0:1.4.13-1 set to be updated
---> Package libgcc.i386 0:4.1.2-48.el5 set to be updated
---> Package libobjc.i386 0:4.1.2-48.el5 set to be updated
---> Package libpcap.i386 14:0.9.4-15.el5 set to be updated
---> Package libsepol.i386 0:1.15.2-3.el5 set to be updated
---> Package libstdc++.i386 0:4.1.2-48.el5 set to be updated
---> Package lm_sensors.i386 0:2.10.7-9.el5 set to be updated
---> Package lvm2.i386 0:2.02.56-8.el5_5.1 set to be updated
---> Package mdadm.i386 0:2.6.9-3.el5 set to be updated
---> Package microcode_ctl.i386 1:1.17-1.50.el5 set to be updated
---> Package mkinitrd.i386 0:5.1.19.6-61.el5_5.1 set to be updated
---> Package mod_ssl.i386 1:2.2.3-43.el5.centos set to be updated
---> Package module-init-tools.i386 0:3.3-0.pre3.1.60.el5 set to be updated
---> Package nash.i386 0:5.1.19.6-61.el5_5.1 set to be updated
---> Package net-snmp.i386 1:5.3.2.2-9.el5 set to be updated
---> Package net-snmp-libs.i386 1:5.3.2.2-9.el5 set to be updated
---> Package net-snmp-utils.i386 1:5.3.2.2-9.el5 set to be updated
---> Package net-tools.i386 0:1.60-81.el5 set to be updated
---> Package newt.i386 0:0.52.2-15.el5 set to be updated
---> Package openldap.i386 0:2.3.43-12.el5 set to be updated
---> Package openldap-servers.i386 0:2.3.43-12.el5 set to be updated
---> Package openssh.i386 0:4.3p2-41.el5 set to be updated
---> Package openssh-clients.i386 0:4.3p2-41.el5 set to be updated
---> Package openssh-server.i386 0:4.3p2-41.el5 set to be updated
---> Package pciutils.i386 0:2.2.3-8.el5_4 set to be updated
---> Package perl-XML-SAX.noarch 0:0.14-8 set to be updated
---> Package policycoreutils.i386 0:1.33.12-14.8.el5 set to be updated
---> Package procps.i386 0:3.2.7-16.el5 set to be updated
---> Package shadow-utils.i386 2:4.0.17-15.el5 set to be updated
---> Package squid.i386 7:2.6.STABLE21-6.el5 set to be updated
---> Package sudo.i386 0:1.7.2p1-6.el5_5 set to be updated
---> Package sysklogd.i386 0:1.4.1-46.el5 set to be updated
---> Package system-config-securitylevel-tui.i386 0:1.6.29.1-5.el5 set to be updated
---> Package tar.i386 2:1.15.1-30.el5 set to be updated
---> Package tcpdump.i386 14:3.9.4-15.el5 set to be updated
---> Package tcsh.i386 0:6.14-17.el5 set to be updated
---> Package tzdata.i386 0:2010i-1.el5 set to be updated
---> Package vconfig.i386 0:1.9-3 set to be updated
---> Package yum.noarch 0:3.2.22-26.el5.centos set to be updated
--> Finished Dependency Resolution
memcached-1.4.2-1.el5.i386 from installed has depsolving problems
  --> Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.2-1.el5.i386 (installed)
Error: Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.2-1.el5.i386 (installed)
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
The program package-cleanup is found in the yum-utils package.


@ byte

yum clean all was done before
Viribus unitis

Offline byte

  • *
  • 2,183
Re: yum update dependency ?
« Reply #9 on: May 19, 2010, 09:34:17 PM »
yum clean all was done before

Ok, try a more brutal way :)

rm -rf /var/cache/yum/*

Then try again.
--[byte]--

Have you filled in a Bug Report over @ http://bugs.contribs.org ? Please don't wait to be told this way you help us to help you/others - Thanks!

Re: yum update dependency ?
« Reply #10 on: May 21, 2010, 07:53:01 AM »
Hi

a quick workaround is to remove the updated libevent with

code:
yum remove libevent

then reinstall libevent-1.1a (found on a centos mirror with rpmfind) with the following commands:

code:
wget ftp://mirror.switch.ch/pool/3/mirror/centos/5.4/os/i386/CentOS/libevent-1.1a-3.2.1.i386.rpm
yum localinstall libevent-1.1a-3.2.1.i386.rpm

a finally
signal-event yum-modify

brings sogo back to life

Offline fpausp

  • *
  • 728
Re: yum update dependency ?
« Reply #11 on: May 21, 2010, 08:18:17 PM »
Hi,

Thanks for all your comments, i removed libevent and sogo. I installed libevent-1.1a-3.2.1.i386.rpm
and after that sogo again. It looks good but there havent been a solid test.

Regards
fpausp
Viribus unitis