Koozali.org formerly Contribs.org

SOLVED!! Peer not found in SAIL

Offline psoren

  • *
  • 369
SOLVED!! Peer not found in SAIL
« on: March 08, 2010, 09:37:57 AM »
Hi.

I am trying to get my new installation to work. It's sail-2.4.1-10, asterisk with dahdi

If i go to Trunklines and click on the icon under the "S", i should see reg. info. But i only see "Peer musimi not found."

If i check sip.conf the peer seems there.

The reg. info on the SIP supplier side looks correct.

I can not do calls.

What do i do?

Per
« Last Edit: March 09, 2010, 03:52:49 PM by psoren »

Offline psoren

  • *
  • 369
ADDITIONAL INFO: Peer not found in SAIL
« Reply #1 on: March 09, 2010, 08:52:00 AM »
Some more info:

I have moved hardware because of hardware problems.
I had SAIL working for a loooong time on the old hardware, but that was asterisk 1.2 and zaptel. i don't remember SAIL version.
I used AFFA to move to the new hardware and then i removed all selintra db  and files i could find to start fresh since i read somewhere that i could not upgrade directly over so many versions.
asterisk and all is installed and compiled from source, and i have tried different versions of SAIL 2.4.1
After that, i have not been able to get it to work at all.

I also tried to input my SIP info into different carriers in the dropdown menu and at one stage i actually got some reg. info, but i am not able to reproduce it.

I don't know what to try now so i need a little help. I am afraid to suggest it's a bug in SAIL since i haven't seen any similar posts.

Could i have caused problems when manualy removing all the selintra files and stuff??

Per

Offline psoren

  • *
  • 369
Re: SOLVED!! Peer not found in SAIL
« Reply #2 on: March 09, 2010, 04:03:13 PM »
Ok, the problem was "-"   :-o

After trying different machines with fresh installs, both virtuel and physical. i found out that when i define the peer name, i can NOT write "musimi-40" but instead "musimi40".
Worst thing is i think this caught me once before a couple of years back :shock:

When i look in the trunklines page to set up a line, i don't see what i am allowed to type there. It says in the documentation here: http://sarkpbx.com/twiki/bin/view/Main/DocChapter092  to use  "Any valid contiguous alphanumeric string".
If that means i cant use "-", then i screwed up. but i don't know what it means  :-?
Maybe some thing to put in a tooltip box??

Per -  Learned something again today....
« Last Edit: March 09, 2010, 07:59:50 PM by psoren »

Offline SARK devs

  • ****
  • 2,806
    • http://sarkpbx.com
Re: SOLVED!! Peer not found in SAIL
« Reply #3 on: March 11, 2010, 09:55:17 AM »
Apologies Per.

The validation routines in SAIL can be a bit brutal at times.  It won't accept "-" but it will accept "_".   We are doing a fair bit of work on validation for Version 3 to make it clearer and easier to use.

Kind Regards