Koozali.org formerly Contribs.org

SOGO for Sme

Offline moo2

Re: SOGO for Sme
« Reply #165 on: August 09, 2012, 02:58:59 PM »
Then please tell me, why not use gpg when it is available?

Or tell me that it won't work with gpg - but only telling "do as it written down" is a no answer of any of my questions.

Offline _alex

  • ***
  • 103
Re: SOGO for Sme
« Reply #166 on: August 09, 2012, 03:05:50 PM »
Because someone is maintaining a SME server specific SOGo repository, that's why.

Basically, follow the wiki, You'll get help and support, do otherwise and be on your own.

Re: SOGO for Sme
« Reply #167 on: August 09, 2012, 08:42:24 PM »
1.3.17 will work if you follow the wiki.

Though on Mac OS X 10.8 carddav is broken.
Greetings, Johannes

Re: SOGO for Sme
« Reply #168 on: August 27, 2012, 06:03:11 PM »
There was a bug filed in the SOGO bug tracker which describes, how to solve the problems when using Mac OS X Mountain Lion 10.8:

http://www.sogo.nu/bugs/bug_view_advanced_page.php?bug_id=1957

Could the dev of the sogo-smeserver contrib please have a look into that? Your help would be very appreciated!
Greetings, Johannes

Offline miroj

Re: SOGO for Sme
« Reply #169 on: April 14, 2013, 06:54:36 PM »
Hi, I have successfully installed SOGo 2.0.5 on SME 8 with all updates. I was using the wiki guidance on SOGo contrib. Everything went well, in the mails I can use Cyrillic but I can't within the calendar. Everything in Cyrillic goes in ????. The browser char set is set to UTF-8, as well I was adding the AddDefaultCharset UTF-8 as proposed in http://forums.contribs.org/index.php?topic=48792.0

All other is working like a charm, integration with Thunderbird+Lightning+Connector+Integrator, the same is with Evolution 3.4.2, but in all cases I do have issues with Cyrillic support within the calendar.

What I'm missing?
« Last Edit: April 14, 2013, 09:07:03 PM by miroj »
---
"Open Source will apear on your machines anyway"
Paolo Malinverno
Vice President, Gartner Research

Re: SOGO for Sme
« Reply #170 on: May 23, 2013, 12:49:28 AM »
I am wondering if I am missing something here. I have set up Sogo using the wiki instructions but am unable to login. I tried using the passwd modification suggestion but was still unsuccessful.

Am I correct to assume that the current Mail user accounts should automatically work in SOGo?

Any guidance would be appreciated.

Thank you.

Offline stephdl

  • *
  • 1,505
    • Linux et Geekeries
Re: SOGO for Sme
« Reply #171 on: May 23, 2013, 07:26:49 AM »
I am wondering if I am missing something here. I have set up Sogo using the wiki instructions but am unable to login. I tried using the passwd modification suggestion but was still unsuccessful.

Am I correct to assume that the current Mail user accounts should automatically work in SOGo?

Any guidance would be appreciated.

Thank you.
did you apply this workaround  ? did you restart the sogo service or eventually restart the server
http://wiki.contribs.org/Sogo#Login_doesn.27t_operate
because i had the same behaviour before to make the trick and when i wrote and apply it i'm now  able to log in sogo
« Last Edit: May 23, 2013, 07:29:11 AM by stephdl »
See http://wiki.contribs.org/Koozali_Foundation
irc : Freenode #sme_server #sme-fr

!!! Please write your knowledge to the Wiki !!!

Re: SOGO for Sme
« Reply #172 on: May 23, 2013, 02:29:00 PM »
did you apply this workaround  ? did you restart the sogo service or eventually restart the server
http://wiki.contribs.org/Sogo#Login_doesn.27t_operate
because i had the same behaviour before to make the trick and when i wrote and apply it i'm now  able to log in sogo

Yes I have made the modifications as noted but still get a Wrong username or password error when trying to login with my username and password (which does work for horde etc).



Offline stephdl

  • *
  • 1,505
    • Linux et Geekeries
Re: SOGO for Sme
« Reply #173 on: May 23, 2013, 09:14:30 PM »
What about this sogo log, can you try to log and paste the latter lines of this log.

Code: [Select]
less /var/log/sogo/sogo.log
See http://wiki.contribs.org/Koozali_Foundation
irc : Freenode #sme_server #sme-fr

!!! Please write your knowledge to the Wiki !!!

Re: SOGO for Sme
« Reply #174 on: May 24, 2013, 03:11:00 AM »
What about this sogo log, can you try to log and paste the latter lines of this log.

Code: [Select]
less /var/log/sogo/sogo.log

May 23 07:32:50 sogod [3298]: <0x0x9ef05dc[SOGoCache]> Using host(s) 'localhost' as server(s)
2013-05-23 07:32:51.191 sogod[3298] Note(SoObject): SoDebugKeyLookup is enabled!
2013-05-23 07:32:51.192 sogod[3298] Note(SoObject): SoDebugBaseURL is enabled!
2013-05-23 07:32:51.192 sogod[3298] Note(SoObject): relative base URLs are enabled.
2013-05-23 07:32:51.963 sogod[3298] WOCompoundElement: pool embedding is on.
2013-05-23 07:32:51.963 sogod[3298] WOCompoundElement: id logging is on.
192.168.1.231 - - [23/May/2013:07:32:51 GMT] "GET /SOGo HTTP/1.1" 302 0/0 1.052 - - 2M
2013-05-23 07:32:52.964 sogod[3298] WARNING(-[NSNull(misc) count]): called NSNull -count (returns 0) !!!
192.168.1.231 - - [23/May/2013:07:32:53 GMT] "GET /SOGo/ HTTP/1.1" 200 3889/0 1.108 11838 67% 1M
May 23 07:32:55 sogod [3298]: <0x0xa1e6dec[LDAPSource]> <NSException: 0x9f28484> NAME:LDAPException REASON:operation bind failed: Can't contact LDAP server (0xFFFFFFFF) INFO:{login = "cn=jsmith,ou=groups,dc=ourfamilyslife,dc=com"; }
May 23 07:32:55 sogod [3298]: <0x0xa1d6d74[LDAPSource]> <NSException: 0xa1ea964> NAME:LDAPException REASON:operation bind failed: Can't contact LDAP server (0xFFFFFFFF) INFO:{login = "uid=jsmith,ou=users,dc=ourfamilyslife,dc=com"; }
May 23 07:32:55 sogod [3298]: SOGoRootPage Login from '192.168.1.231' for user 'jsmith' might not have worked - password policy: 65535  grace: -1  expire: -1  bound: 0
192.168.1.231 - - [23/May/2013:07:32:55 GMT] "POST /SOGo/connect HTTP/1.1" 403 34/63 0.387 - - 448K
64.56.140.60 - - [23/May/2013:09:25:24 GMT] "GET /SOGo HTTP/1.1" 302 0/0 0.002 - - 0
2013-05-23 09:25:24.880 sogod[3298] WARNING(-[NSNull(misc) count]): called NSNull -count (returns 0) !!!
64.56.140.60 - - [23/May/2013:09:25:24 GMT] "GET /SOGo/ HTTP/1.1" 200 3871/0 0.017 11814 67% 24K
May 23 09:25:41 sogod [3298]: <0x0xa1e6dec[LDAPSource]> <NSException: 0xa21a31c> NAME:LDAPException REASON:operation bind failed: Can't contact LDAP server (0xFFFFFFFF) INFO:{login = "cn=jsmith,ou=groups,dc=ourfamilyslife,dc=com"; }
May 23 09:25:41 sogod [3298]: <0x0xa1d6d74[LDAPSource]> <NSException: 0xa2f4174> NAME:LDAPException REASON:operation bind failed: Can't contact LDAP server (0xFFFFFFFF) INFO:{login = "uid=jsmith,ou=users,dc=ourfamilyslife,dc=com"; }
May 23 09:25:41 sogod [3298]: SOGoRootPage Login from '64.56.140.60' for user 'jsmith' might not have worked - password policy: 65535  grace: -1  expire: -1  bound: 0
64.56.140.60 - - [23/May/2013:09:25:41 GMT] "POST /SOGo/connect HTTP/1.1" 403 34/83 0.004 - - 0
May 23 09:25:43 sogod [3298]: <0x0xa1e6dec[LDAPSource]> <NSException: 0xa2160ac> NAME:LDAPException REASON:operation bind failed: Can't contact LDAP server (0xFFFFFFFF) INFO:{login = "cn=jsmith,ou=groups,dc=ourfamilyslife,dc=com"; }
May 23 09:25:43 sogod [3298]: <0x0xa1d6d74[LDAPSource]> <NSException: 0x9ef05c4> NAME:LDAPException REASON:operation bind failed: Can't contact LDAP server (0xFFFFFFFF) INFO:{login = "uid=jsmith,ou=users,dc=ourfamilyslife,dc=com"; }
May 23 09:25:43 sogod [3298]: SOGoRootPage Login from '64.56.140.60' for user 'jsmith' might not have worked - password policy: 65535  grace: -1  expire: -1  bound: 0
64.56.140.60 - - [23/May/2013:09:25:43 GMT] "POST /SOGo/connect HTTP/1.1" 403 34/83 0.004 - - 0

Hopefully that sheds some light on things...

Offline stephdl

  • *
  • 1,505
    • Linux et Geekeries
Re: SOGO for Sme
« Reply #175 on: May 24, 2013, 04:29:02 PM »
I have tested on another SME virtual to validate the howto and it works
https://gist.github.com/anonymous/5643880

So these have to work on your sme :p...
2 questions

do you have done the signal-event command after the sogo and memcached installation
 from epel and sogo/nethsme repository ?
do you have restart the sogo service after you have made the trick which concerns /etc/passwd ?

Otherwise you could try to remove all packages installed and install the again.
« Last Edit: May 24, 2013, 04:30:36 PM by stephdl »
See http://wiki.contribs.org/Koozali_Foundation
irc : Freenode #sme_server #sme-fr

!!! Please write your knowledge to the Wiki !!!

Re: SOGO for Sme
« Reply #176 on: May 24, 2013, 04:34:58 PM »
I have tested on another SME virtual to validate the howto and it works
https://gist.github.com/anonymous/5643880

So these have to work on your sme :p...
2 questions

do you have done the signal-event command after the sogo and memcached installation
 from epel and sogo/nethsme repository ?
do you have restart the sogo service after you have made the trick which concerns /etc/passwd ?

Otherwise you could try to remove all packages installed and install the again.

I did the signal-event commands after each of the installs. I used the restart command on the sogo service, tested then stopped and started, tested then rebooted computer.

This is the second install attempt of SOGo as the original ended the same way. But I only uninstalled and reinstalled SOGo not memcached. Would memcached affect SOGo in such a fashion???

Offline stephdl

  • *
  • 1,505
    • Linux et Geekeries
Re: SOGO for Sme
« Reply #177 on: May 24, 2013, 04:53:25 PM »
Is it a a sme8 ?
32 or 64 ?

can you past the return of this command to see if another contrib could make a mess

/sbin/e-smith/audittools/newrpms
See http://wiki.contribs.org/Koozali_Foundation
irc : Freenode #sme_server #sme-fr

!!! Please write your knowledge to the Wiki !!!

Re: SOGO for Sme
« Reply #178 on: May 24, 2013, 04:57:30 PM »
Is it a a sme8 ?
32 or 64 ?

can you past the return of this command to see if another contrib could make a mess

/sbin/e-smith/audittools/newrpms

Yes it is SME 8 i386 install that was initially started at 8b6 and just upgraded to its present state over the years.

I will have to get the output of that command in about 7 hours as I will not be near it again until then.

I appreciate your help.

Re: SOGO for Sme
« Reply #179 on: May 25, 2013, 08:21:31 AM »
Is it a a sme8 ?
32 or 64 ?

can you past the return of this command to see if another contrib could make a mess

/sbin/e-smith/audittools/newrpms

Loaded plugins: fastestmirror, protect-packages, smeserver
Loading mirror speeds from cached hostfile
 * base: centos.mirror.ca.planethoster.net
 * smeaddons: mirror.canada.pialasse.com
 * smeos: mirror.canada.pialasse.com
 * smeupdates: mirror.canada.pialasse.com
 * updates: centos.mirror.rafal.ca
Extra Packages
dimp-h3.noarch                       1.1.6-1.el5.sme                   installed
epel-release.noarch                  5-4                               installed
gnustep-base.i386                    1.23.0-1                          installed
gnustep-make.i386                    2.6.1-1                           installed
jdk.i586                             2000:1.6.0_23-fcs                 installed
jre.i586                             1.6.0_22-fcs                      installed
kronolith-h3.noarch                  2.3.5-1.el5.sme                   installed
libffi.i386                          3.0.10-1                          installed
libmemcached.i386                    0.34-1                            installed
memcached.i386                       1.4.5-1.el5                       installed
mimp-h3.noarch                       1.1.3-1.el5.sme                   installed
mnemo-h3.noarch                      2.2.4-1.el5.sme                   installed
nag-h3.noarch                        2.3.6-1.el5.sme                   installed
rpmforge-release.i386                0.5.2-2.el5.rf                    installed
smeserver-dimp.noarch                1.0-2.el5.sme                     installed
smeserver-kronolith.noarch           2.2-13.el5.sme                    installed
smeserver-mimp.noarch                1.1-3.el5.sme                     installed
smeserver-mnemo.noarch               2.2-5.el5.sme                     installed
smeserver-nag.noarch                 2.2-8.el5.sme                     installed
smeserver-sogo.noarch                0.6-1.el5.nh                      installed
sogo.i386                            2.0.5a-1.el5                      installed
sogo-tool.i386                       2.0.5a-1.el5                      installed
sope49-appserver.i386                4.9-20130416_1664.el5.1           installed
sope49-cards.i386                    2.0.5a-1.el5                      installed
sope49-core.i386                     4.9-20130416_1664.el5.1           installed
sope49-gdl1.i386                     4.9-20130416_1664.el5.1           installed
sope49-gdl1-contentstore.i386        2.0.5a-1.el5                      installed
sope49-gdl1-mysql.i386               4.9-20130416_1664.el5.1           installed
sope49-ldap.i386                     4.9-20130416_1664.el5.1           installed
sope49-mime.i386                     4.9-20130416_1664.el5.1           installed
sope49-sbjson.i386                   2.3.1-20130416_1664.el5.1         installed
sope49-xml.i386                      4.9-20130416_1664.el5.1           installed
sun-javadb-client.i386               10.5.3-0.2                        installed
sun-javadb-common.i386               10.5.3-0.2                        installed
sun-javadb-core.i386                 10.5.3-0.2                        installed
sun-javadb-demo.i386                 10.5.3-0.2                        installed
sun-javadb-docs.i386                 10.5.3-0.2                        installed
sun-javadb-javadoc.i386              10.5.3-0.2                        installed