Koozali.org formerly Contribs.org

SOGO for Sme

Re: SOGO for Sme
« Reply #150 on: November 24, 2011, 05:53:45 PM »
i have problem in install sogo on sme server 8 beta 6

Re: SOGO for Sme
« Reply #151 on: November 24, 2011, 06:51:39 PM »
i have tried this :yum update sogo sope49-gdl1-contentstore sope49-cards --enablerepo=sogo --disablerepo=epel
but receve this error

No Packages marked for Update
 and sogo is down

Offline janet

  • ****
  • 4,806
Re: SOGO for Sme
« Reply #152 on: November 24, 2011, 10:14:31 PM »
ilconte

see http://wiki.contribs.org/Sogo
It has a different procedure to that which you are using
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Offline Mat78

Re: SOGO for Smehttp://forums.contribs.org/Themes/core/images/bbc/quote.gif
« Reply #153 on: November 25, 2011, 12:51:03 AM »
Quote
It would be a lot easier if you were to also tell us the exact error message, now you leave us guessing which makes it hard to help you. We do not have a crystal ball...

When I turn on my test server I get this messages in SOGo Log:

Nov 25 00:00:15 sogod [2914]: version 1.3.9 (build root@vizzini.openchange.local 201110291437) -- starting
Nov 25 00:00:15 sogod [2914]: vmem size check enabled: shutting down app when vmem > 384 MB
Nov 25 00:00:23 sogod [2914]: <0x0x98cab94[SOGoProductLoader]> SOGo products loaded from '/usr/lib/GNUstep/SOGo':
Nov 25 00:00:23 sogod [2914]: <0x0x98cab94[SOGoProductLoader]>   Mailer.SOGo, AdministrationUI.SOGo, MailerUI.SOGo, SchedulerUI.SOGo, Contacts.SOGo, Appointments.SOGo, MainUI.SOGo, CommonUI.SOGo, PreferencesUI.SOGo, ContactsUI.SOGo, MailPartViewers.SOGo
Nov 25 00:00:27 sogod [2914]: <0x0x998715c[WOWatchDog]> listening on 127.0.0.1:20000
Nov 25 00:00:27 sogod [2914]: <0x0x998715c[WOWatchDog]> watchdog process pid: 2914
Nov 25 00:00:27 sogod [2914]: <0x0x3745a0[WOWatchDogChild]> watchdog request timeout set to 10 minutes
Nov 25 00:00:27 sogod [2914]: <0x0x998715c[WOWatchDog]> preparing 1 children
Nov 25 00:00:27 sogod [2914]: <0x0x998715c[WOWatchDog]> child spawned with pid 3227

And this is my messages log:

Nov 25 00:19:26 testserver slapd[2525]: conn=0 fd=13 ACCEPT from IP=127.0.0.1:41831 (IP=0.0.0.0:389)
Nov 25 00:19:26 testserver slapd[2525]: conn=0 op=0 BIND dn="" method=128
Nov 25 00:19:26 testserver slapd[2525]: conn=0 op=0 RESULT tag=97 err=0 text=
Nov 25 00:19:26 testserver slapd[2525]: conn=0 op=1 SRCH base="ou=groups,dc=testserver,dc=local" scope=2 deref=0 filter="(cn=admin)"
Nov 25 00:19:26 testserver slapd[2525]: conn=0 op=1 SRCH attr=dn
Nov 25 00:19:26 testserver slapd[2525]: conn=1 fd=16 ACCEPT from IP=127.0.0.1:41832 (IP=0.0.0.0:389)
Nov 25 00:19:26 testserver slapd[2525]: conn=1 op=0 BIND dn="" method=128
Nov 25 00:19:26 testserver slapd[2525]: conn=1 op=0 RESULT tag=97 err=0 text=
Nov 25 00:19:26 testserver slapd[2525]: conn=1 op=1 SRCH base="ou=users,dc=testserver,dc=local" scope=2 deref=0 filter="(uid=admin)"
Nov 25 00:19:26 testserver slapd[2525]: conn=1 op=1 SRCH attr=dn
Nov 25 00:19:26 testserver slapd[2525]: conn=0 op=1 SEARCH RESULT tag=101 err=0 nentries=0 text=
Nov 25 00:19:26 testserver slapd[2525]: conn=1 op=1 SEARCH RESULT tag=101 err=0 nentries=1 text=
Nov 25 00:19:26 testserver slapd[2525]: conn=2 fd=18 ACCEPT from IP=127.0.0.1:41833 (IP=0.0.0.0:389)
Nov 25 00:19:26 testserver slapd[2525]: conn=2 op=0 BIND dn="uid=admin,ou=users,dc=testserver,dc=local" method=128
Nov 25 00:19:26 testserver slapd[2525]: conn=2 op=0 BIND dn="uid=admin,ou=Users,dc=testserver,dc=local" mech=SIMPLE ssf=0
Nov 25 00:19:26 testserver slapd[2525]: conn=2 op=0 RESULT tag=97 err=0 text=
Nov 25 00:19:26 testserver slapd[2525]: conn=2 op=1 UNBIND
Nov 25 00:19:26 testserver slapd[2525]: conn=2 fd=18 closed

On thunderbird side everything seems to work correctly (there is nothing in Thunderbird Error Consol) but I can't use "Sogo-Integrator" advantage (shared folder, shared calendar).

Offline alefattorini

  • **
  • 61
  • www.nethserver.org
    • www.nethserver.org
Re: SOGO for Sme
« Reply #154 on: December 01, 2011, 05:03:20 PM »
My diff for smeserver.sogo.rpm for 1.3.9 is:


Code: [Select]
diff --git a/root/etc/e-smith/templates/etc/httpd/conf/httpd.conf/85SOGoAccess b/root/etc/e-smith/templates/etc/httpd/conf/h
index ff781fc..2921b88 100644
--- a/root/etc/e-smith/templates/etc/httpd/conf/httpd.conf/85SOGoAccess
+++ b/root/etc/e-smith/templates/etc/httpd/conf/httpd.conf/85SOGoAccess
@@ -11,12 +11,12 @@ ProxyPassReverse /SOGo http://127.0.0.1:{$sogod{'TCPPort'}}/SOGo
        RequestHeader set "x-webobjects-server-url"  "https://%\{REQUEST_HOST\}e/SOGo"
 </Location>
 
-Alias /.woa/WebServerResources/ /usr/GNUstep/System/Library/SOGo/WebServerResources/
-Alias /SOGo.woa/WebServerResources/ /usr/GNUstep/System/Library/SOGo/WebServerResources/
-Alias /SOGo/WebServerResources/ /usr/GNUstep/System/Library/SOGo/WebServerResources/
-AliasMatch /SOGo/so/ControlPanel/Products/(.*)/Resources/(.*) /usr/GNUstep/System/Library/SOGo/$1.SOGo/Resources/$2
+Alias /.woa/WebServerResources/ /usr/lib/GNUstep/SOGo/WebServerResources/
+Alias /SOGo.woa/WebServerResources/ /usr/lib/GNUstep/SOGo/WebServerResources/
+Alias /SOGo/WebServerResources/ /usr/lib/GNUstep/SOGo/WebServerResources/
+AliasMatch /SOGo/so/ControlPanel/Products/(.*)/Resources/(.*) /usr/lib/GNUstep/SOGo/$1.SOGo/Resources/$2
 
-<Directory "/usr/GNUstep/System/Library/SOGo/WebServerResources/">
+<Directory "/usr/lib/GNUstep/SOGo/">
     AllowOverride None
     Options +ExecCGI -Includes
     Order allow,deny

 

Offline alefattorini

  • **
  • 61
  • www.nethserver.org
    • www.nethserver.org
Re: SOGO for Sme
« Reply #155 on: December 13, 2011, 12:04:38 PM »
We have update this http://smeserver.nethesis.it/sogo/
with smeserver-sogo rpm for 1.3.9 (is compatible with 1.3.10 and 11 too)

Re: SOGO for Sme
« Reply #156 on: December 13, 2011, 06:38:57 PM »
when install sogo my sme return this error :

memcached-1.4.2-1.el5.i386 from sogo has depsolving problems
  --> Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.2-1.el5.i386 (sogo)
Error: Missing Dependency: libevent-1.1a.so.1 is needed by package memcached-1.4.2-1.el5.i386 (sogo)


why?

Re: SOGO for Sme
« Reply #157 on: December 13, 2011, 06:47:29 PM »
Install compat-libevent-11a-3.2.1-1.el5.rf.i386.rpm

Available here:
http://apt.sw.be/redhat/el5/en/i386/rpmforge/RPMS/compat-libevent-11a-3.2.1-1.el5.rf.i386.rpm

Download and use "Yum localinstall compat-libevent-11a-3.2.1-1.el5.rf.i386.rpm"

That will take care of that old dependency...

Offline mdo

  • *
  • 355
Re: SOGO for Sme
« Reply #158 on: December 13, 2011, 08:43:42 PM »
We have update this http://smeserver.nethesis.it/sogo/
with smeserver-sogo rpm for 1.3.9 (is compatible with 1.3.10 and 11 too)

Many Thanks for the update which avoids all manual changes. Worked very well here (now on Sogo version 1.3.11).
Michael
...

Re: SOGO for Sme
« Reply #159 on: December 13, 2011, 11:05:35 PM »
oki have installed sogo but i receve other error :

/usr/sbin/sogod: error while loading shared libraries: libgnustep-base.so.1.20: cannot open shared object file: No such file or directory

sogo not loaded

Offline mdo

  • *
  • 355
Re: SOGO for Sme
« Reply #160 on: December 13, 2011, 11:27:22 PM »
I suspect you have not all required rpms installed (which normally works automatically if you follow the install/update instructions in the Wiki).

Did you follow them correctly? http://wiki.contribs.org/Sogo

Maybe run again (should not harm):
 
yum install smeserver-sogo --enablerepo=nethsme --enablerepo=sogo
yum update --disablerepo=* --enablerepo=sogo
/etc/rc7.d/S85sogod restart
...

Offline moo2

Re: SOGO for Sme
« Reply #161 on: August 09, 2012, 11:32:54 AM »
Hi,

and thanks for your work for making sogo install possible even for people like me :)

Actually I'm planing to install sogo on sme 8.0. But I have some questions left.

Is it possible to use/install the current 1.3.17 Version of sogo, or would it be 1.3.11 like postet in this thread a few month ago?

The Sogo website says (for debian) that it offers gpg signed packages now.
Quote
Since 2011-07-14, the builds are signed.  In order to verify their signature, our GPG public key has to be added into apt keyring. To do so, run the following commands:

sudo apt-key adv --keyserver keys.gnupg.net --recv-key 0x810273C4
sudo apt-get update
From that point, apt-get should not complain about package signatures anymore.

So, could I change the installation described in the wiki the way, signed packages goes.
I mean would it work if I copy&paste their key into a file and save it as "RPM-GPG-KEY-sogo"
and than change the wiki guide a bit - into:

Quote
db yum_repositories set sogo repository \
     BaseURL http://inverse.ca/downloads/SOGo/RHEL5/i386 \
     EnableGroups yes \
     GPGCheck yes \
     Name "Inverse SOGo Repository" \
     Visible yes \
     status disabled

rpm --import RPM-GPG-KEY-sogo

Or do I have an error in my "plan"?
« Last Edit: August 09, 2012, 11:34:39 AM by moo2 »

Offline _alex

  • ***
  • 103
Re: SOGO for Sme
« Reply #162 on: August 09, 2012, 12:08:16 PM »
You should follow the wiki by the book.

Offline moo2

Re: SOGO for Sme
« Reply #163 on: August 09, 2012, 12:38:20 PM »
Yes but the book is old, maybe there was no gpg key back then, when it was written...

Offline _alex

  • ***
  • 103
Re: SOGO for Sme
« Reply #164 on: August 09, 2012, 12:45:01 PM »
Old? It actually is less than 2 months old.