Koozali.org formerly Contribs.org

SOGO for Sme

Offline soprom

  • *
  • 589
    • www.logiciel-libre.org
Re: SOGO for Sme
« Reply #45 on: March 20, 2010, 10:55:24 PM »
yum remove and then yum install didn't solved the problem.
Sophie from Montréal

Offline kevinb

  • *
  • 237
Re: SOGO for Sme
« Reply #46 on: March 20, 2010, 11:18:53 PM »
soprom, can you post your file "/home/sogo/GNUstep/Defaults/.GNUstepDefaults" ?

Offline soprom

  • *
  • 589
    • www.logiciel-libre.org
Re: SOGO for Sme
« Reply #47 on: March 21, 2010, 02:42:16 AM »
Here it goes...

Code: [Select]
/*
 * ------------------------------------------------------------
 *        !!DO NOT MODIFY THIS FILE!!
 * 
 *  Manual changes will be lost when this file is regenerated.
 *
 *  Please read the developer's guide, which is available
 *  at http://www.contribs.org/development/
 *
 *  Copyright (C) 1999-2006 Mitel Networks Corporation
 * ------------------------------------------------------------
 */
{
    NSGlobalDomain = {
    };
    sogod = {
        NGUseUTF8AsURLEncoding = YES;
        OCSFolderInfoURL = "mysql://sogo:qjraB.e8xgvPqgt....FLSq+sGhpYjthgL@localhost/sogo/sogo_folder_info";
        SOGoACLsSendEMailNotifications = YES;
        SOGoAppointmentSendEMailNotifications = YES;
        SOGoAppointmentSendEMailReceipts = YES;
        SOGoAuthenticationMethod = LDAP;
        SOGoDraftsFolderName = Drafts;
        SOGoFoldersSendEMailNotifications = YES;
        SOGoIMAPServer = localhost;
        SOGoMailDomain = sophieromano.com;
        SOGoMailingMechanism = sendmail;
        SOGoProfileURL = "mysql://sogo:qjraB.e8xgvPqgtQffu+QiXEF....hpYjthgL@localhost/sogo/sogo_user_profile";
        SOGoSMTPServer = localhost;
        SOGoSentFolderName = Sent;
        SOGoSuperUsernames = (
            admin
        );
        SOGoTimeZone = America/Montreal;
        SOGoTrashFolderName = Trash;
        SOGoUserSources = (
            {
                CNFieldName = cn;
                IDFieldName = uid;
                UIDFieldName = uid;
                baseDN = "dc=sophieromano,dc=com";
                bindDN = "cn=root,dc=sophieromano,dc=com";
                bindFields = uid;
                bindPassword = "Oj....n6lTrSP";
                canAuthenticate = YES;
                displayName = "Utenti Locali";
                hostname = localhost;
                id = directory;
                isAddressBook = YES;
                port = 389;
                type = ldap;
            }
        );
        WOMessageUseUTF8 = YES;
        WOParsersUseUTF8 = YES;
        WOPort = 20000;
        WOUseRelativeURLs = YES;
    };
}

oops... I'll need to change mysql password.
« Last Edit: March 21, 2010, 02:45:40 AM by soprom »
Sophie from Montréal

Offline kevinb

  • *
  • 237
Re: SOGO for Sme
« Reply #48 on: March 21, 2010, 09:02:31 PM »
Hi Sophie, I do not see anything wrong in your file. I am at a loss. Sorry

Offline alefattorini

  • **
  • 61
  • www.nethserver.org
    • www.nethserver.org
Re: SOGO for Sme
« Reply #49 on: March 22, 2010, 09:28:44 AM »
yum remove and then yum install didn't solved the problem.

Do you have modified .GNUstepDefaults manually? Don't do this, you should use "defaults write.." command as described in documentation. I think that there is some sintax problem. You can try
expand-template /home/sogo/GNUstep/Defaults/.GNUstepDefaults
/etc/init.d/sogod restart

Search in google site:mail.opengroupware.org
or ask in sogo@opengroupware.org

Offline alefattorini

  • **
  • 61
  • www.nethserver.org
    • www.nethserver.org
Re: SOGO for Sme
« Reply #50 on: March 22, 2010, 09:29:58 AM »
Hello Alessio,
Everyone, I updated the WIKI with instuctions on how to setup the Thunderbird Integrator.
 
Kevin

Thank you very much, good work!

Offline soprom

  • *
  • 589
    • www.logiciel-libre.org
Re: SOGO for Sme
« Reply #51 on: March 22, 2010, 03:35:26 PM »
Do you have modified .GNUstepDefaults manually?

I just realized that the template /etc/e-smith/templates/home/sogo/GNUstep/Defaults is now empty!
So is /home/sogo/GNUstep/Defaults probably because of the expand-template.

That should explain the errors but why did it disappeared, I don't know!
Sophie from Montréal

Offline alefattorini

  • **
  • 61
  • www.nethserver.org
    • www.nethserver.org
Re: SOGO for Sme
« Reply #52 on: March 22, 2010, 03:59:50 PM »
I just realized that the template /etc/e-smith/templates/home/sogo/GNUstep/Defaults is now empty!
So is /home/sogo/GNUstep/Defaults probably because of the expand-template.

That should explain the errors but why did it disappeared, I don't know!

Happens, sometimes when you edit .GNUstepDefaults manually (with user not-sogo or with bad sintax) . You should use properly commands or expand template.

Offline soprom

  • *
  • 589
    • www.logiciel-libre.org
Re: SOGO for Sme
« Reply #53 on: March 22, 2010, 04:21:59 PM »
trying to repair sogo:

# remove sogo
yum -y remove smeserver-sogo sogo
mysql -e "drop user sogo;"
mysql -e "drop database sogo;"
rm -rfd /home/sogo
config delete sogod
signal-event post-upgrade; signal-event reboot; exit

# reinstall sogo
yum -y install smeserver-sogo --enablerepo=nethsme --enablerepo=sogo
signal-event post-upgrade; signal-event reboot; exit

# checking
After these steps, there is nothing in
/etc/e-smith/templates/home/sogo/GNUstep/Defaults
/home/sogo/GNUstep/Defaults
Sophie from Montréal

Offline Daniel B.

  • *
  • 1,694
    • Firewall Services, la sécurité des réseaux
Re: SOGO for Sme
« Reply #54 on: March 22, 2010, 04:26:33 PM »
The config file for sogo is hidden:

/home/sogo/GNUstep/Defaults/.GNUstepDefaults

And the templates are in /etc/e-smith/templates/home/sogo/GNUstep/Defaults/.GNUstepDefaults/

No need to remove/re-install if something went wrong (hey, we're not running windows do we ? ;))

A simple
Code: [Select]
signal-event sogo-modify
Should put the configuration back to normal.

Regards
C'est la fin du monde !!! :lol:

Offline soprom

  • *
  • 589
    • www.logiciel-libre.org
Re: SOGO for Sme
« Reply #55 on: March 22, 2010, 04:31:08 PM »
Ok for hidden files. I see them now.

I applied signal-event sogo-modify but it's a no-go...

Logs say:
SOGo watchdog[4337] unable to get status of descriptor 2 - Mauvais descripteur de fichier (bad file descriptor)

Scanner initialised with nil string


Sophie from Montréal

Offline soprom

  • *
  • 589
    • www.logiciel-libre.org
Re: SOGO for Sme
« Reply #56 on: March 22, 2010, 04:43:24 PM »

/etc/init.d/sogod status says
sogod est mort mais le fichier pid existe
(sogo is dead but pid file still exists)
Sophie from Montréal

Offline alefattorini

  • **
  • 61
  • www.nethserver.org
    • www.nethserver.org
Re: SOGO for Sme
« Reply #57 on: March 22, 2010, 05:02:58 PM »
/etc/init.d/sogod status says
sogod est mort mais le fichier pid existe
(sogo is dead but pid file still exists)

ps ax | grep sogod

/etc/init.d/sogod stop

ps ax | grep sogod
is there any pid? kill it and start again

Offline soprom

  • *
  • 589
    • www.logiciel-libre.org
Re: SOGO for Sme
« Reply #58 on: March 22, 2010, 05:14:44 PM »
No change...

ps ax | grep sogod
 4789 pts/0    S+     0:00 grep sogod

cat /var/run/sogo/sogo.pid
4696

/etc/init.d/sogod status
sogo is dead but pid file still exists

rm -f /var/run/sogo/sogo.pid
/etc/init.d/sogod status
sogod is stopped

/etc/init.d/sogod start
sogod: SOGo watchdog[4916] unable to get status of descriptor 2 - Mauvais descripteur de fichier

/etc/init.d/sogod stop
sogo not running

/etc/init.d/sogod status
sogo is dead but pid file still exists

cat /var/run/sogo/sogo.pid
4916
Sophie from Montréal

Offline soprom

  • *
  • 589
    • www.logiciel-libre.org
Re: SOGO for Sme
« Reply #59 on: March 22, 2010, 05:17:48 PM »
..deleted...
« Last Edit: March 22, 2010, 05:24:08 PM by soprom »
Sophie from Montréal