Koozali.org formerly Contribs.org

SOGO for Sme

Offline alefattorini

  • **
  • 61
  • www.nethserver.org
    • www.nethserver.org
SOGO for Sme
« on: March 02, 2010, 05:33:37 PM »
We have made rpm for Sme, install notes here:
http://smeserver.nethesis.it/sogo/

What's sogo?
http://www.scalableogo.org

Your Comments Are Appreciated

Offline kevinb

  • *
  • 237
Re: SOGO for Sme
« Reply #1 on: March 02, 2010, 08:40:32 PM »
WOOHOO !!!!
 
I have been waiting for this day!
 
Unfortunately it will be several weeks before I can test this.
 
Alessio, do you want to create a Wiki entry for this? If not I will.
 
How do you authenticate? LDAP? SQL?
 
What database do you use? SME Mysql? Postgresql?
 
Thanks,
 
Kevin

Offline Stefano

  • *
  • 10,779
  • Skype account: maghissimo
    • Smeserver italian community
Re: SOGO for Sme
« Reply #2 on: March 02, 2010, 09:09:47 PM »
WOOHOO !!!!
 
I have been waiting for this day!
 
Unfortunately it will be several weeks before I can test this.
 
Alessio, do you want to create a Wiki entry for this? If not I will.
 
How do you authenticate? LDAP? SQL?
 
What database do you use? SME Mysql? Postgresql?
 
Thanks,
 
Kevin

Kevin, Alessio forgot to say that the rpms are only for SME8 :-)
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Offline alefattorini

  • **
  • 61
  • www.nethserver.org
    • www.nethserver.org
Re: SOGO for Sme
« Reply #3 on: March 03, 2010, 09:20:00 AM »
Kevin, Alessio forgot to say that the rpms are only for SME8 :-)

Offline daniel

  • ***
  • 146
  • Platinum Sponsor
    • http://www.charton-mgmt.com
Re: SOGO for Sme
« Reply #4 on: March 03, 2010, 05:37:16 PM »
Working on setting up sogo on my test 8beta4 server. 

Found these problems so far with the instructions at http://smeserver.nethesis.it/sogo/
The Sogo repo BaseURL didn't work, I had to manually change it from http://inverse.ca/downloads/SOGo/RHEL5/$basearch to http://inverse.ca/downloads/SOGo/RHEL5/i386 in order to see the rpms.

#yum install smeserver-sogo --enablerepo=nethsme --enablerepo=sogo

This shows 18 packages to install but before they start installing I get this message
Package sope49-cards-1.2.1-1.e15.i386.rpm is not signed

No further installation occurs.

I did follow the procedure
# wget http://smeserver.nethesis.it/releases/RPM-GPG-KEY-nethesis
# rpm --import RPM-GPG-KEY-nethesis

Do I need another key from the sogo server to make this install work?  What next?


Offline alefattorini

  • **
  • 61
  • www.nethserver.org
    • www.nethserver.org
Re: SOGO for Sme
« Reply #5 on: March 03, 2010, 06:03:30 PM »
Sorry, "GPGCheck no" for sogo repository, they'are not signed. I have fixed it

# db yum_repositories set sogo repository \
      BaseURL http://inverse.ca/downloads/SOGo/RHEL5/$basearch \
      EnableGroups yes \
      GPGCheck no \
      Name "Inverse SOGo Repository" \
      Visible yes \
      status disabled

Offline daniel

  • ***
  • 146
  • Platinum Sponsor
    • http://www.charton-mgmt.com
Re: SOGO for Sme
« Reply #6 on: March 03, 2010, 07:23:16 PM »
Thank you, that took care of the install issue.  I now have a SOGo install on my test server.  My issue now is it will not let me login with any of the two test users I have in the system. 
I have e-smith-ldap-5.2.0-3.el5.sme.noarch installed, so if SOGo is using LDAP I must have something set wrong.  I checked the mysql SOGo databases to see if I could figure out what username and password I could login with, there is no data in the sogo user profile table.

I'm at a loss as to how to authenticate into SOGo and go from here.  What can I check next?

Offline daniel

  • ***
  • 146
  • Platinum Sponsor
    • http://www.charton-mgmt.com
Re: SOGO for Sme
« Reply #7 on: March 03, 2010, 07:29:15 PM »
Further Information.
I checked my messages log and found this each time I try to login.
Mar  3 13:26:55 linux slapd[4275]: conn=2 fd=11 ACCEPT from IP=127.0.0.1:60798 (IP=0.0.0.0:389)
Mar  3 13:26:55 linux slapd[4275]: conn=2 op=0 BIND dn="cn=root,dc=charton-mgmt,dc=com" method=128
Mar  3 13:26:55 linux slapd[4275]: conn=2 op=0 BIND dn="cn=root,dc=charton-mgmt,dc=com" mech=SIMPLE ssf=0
Mar  3 13:26:55 linux slapd[4275]: conn=2 op=0 RESULT tag=97 err=0 text=
Mar  3 13:26:55 linux slapd[4275]: conn=2 op=1 SRCH base="dc=charton-mgmt,dc=com" scope=2 deref=0 filter="(uid=danielr)"
Mar  3 13:26:55 linux slapd[4275]: conn=2 op=1 SRCH attr=dn
Mar  3 13:26:55 linux slapd[4275]: conn=2 op=1 SEARCH RESULT tag=101 err=32 nentries=0 text=
Mar  3 13:26:55 linux slapd[4275]: conn=2 op=2 UNBIND
Mar  3 13:26:55 linux slapd[4275]: conn=2 fd=11 closed

I'm guessing LDAP is working, just giving back an error that SOGo won't accept. 

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: SOGO for Sme
« Reply #8 on: March 03, 2010, 09:24:52 PM »
Mar  3 13:26:55 linux slapd[4275]: conn=2 op=1 SEARCH RESULT tag=101 err=32 nentries=0 text=
LDAP might be working but error code 32 normally means no entry found, hence nentries is set to zero as well.

Perhaps your filter is incorrect as I am not sure if the username is stored in the uid field, or your search DN is incorrect.
« Last Edit: March 03, 2010, 09:30:27 PM by cactus »
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline daniel

  • ***
  • 146
  • Platinum Sponsor
    • http://www.charton-mgmt.com
Re: SOGO for Sme
« Reply #9 on: March 03, 2010, 10:41:00 PM »
Thanks Cactus,

Looks like I have an LDAP issue.  I've installed the latest e-smith-LDAP with
# yum install e-smith-ldap --enablerepo=smetest --enablerepo=smeupdates-testing --exclude=*+ldap
I also installed the phpldapadmin.  This tells me"    ?    dc=charton-mgmt,dc=com  This base entry does not exist.Create it? "  Of course create won't do anything but I would assume I have a problem with LDAP in V8beta4 somewhere based on that message.   I'll have to do some more testing to see where the LDAP issue is.    Does anyone know of any quick commands to see if LDAP is working right on SME8Beta4.  I'm not an expert on LDAP, yet.    :)

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: SOGO for Sme
« Reply #10 on: March 04, 2010, 07:24:05 AM »
Code: [Select]
yum install e-smith-ldap --enablerepo=smetest --enablerepo=smeupdates-testing --exclude=*+ldap
Why did you exclude other related (and most likely needed) *+ldap packages?
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline Daniel B.

  • *
  • 1,690
    • Firewall Services, la sécurité des réseaux
Re: SOGO for Sme
« Reply #11 on: March 04, 2010, 07:29:53 AM »
Because the *+ldap packages are not needed anymore to get basic LDAP auth working in SME8. See http://bugs.contribs.org/show_bug.cgi?id=5720.

Regards.
C'est la fin du monde !!! :lol:

Offline daniel

  • ***
  • 146
  • Platinum Sponsor
    • http://www.charton-mgmt.com
Re: SOGO for Sme
« Reply #12 on: March 04, 2010, 01:05:28 PM »
I was following the wiki instructions
http://wiki.contribs.org/LDAP

Offline daniel

  • ***
  • 146
  • Platinum Sponsor
    • http://www.charton-mgmt.com
Re: SOGO for Sme
« Reply #13 on: March 04, 2010, 04:16:29 PM »
Not sure why, but today after adding a new user in SME, LDAP is working to where SOGo is authenticating to LDAP for all existing users.   Thanks to Alessio for the contrib and howto.  Now once we get a good outlook connector to SOGo then we have a good exchange replacement contender.

Offline Stefano

  • *
  • 10,779
  • Skype account: maghissimo
    • Smeserver italian community
Re: SOGO for Sme
« Reply #14 on: March 04, 2010, 04:25:01 PM »
Not sure why, but today after adding a new user in SME, LDAP is working to where SOGo is authenticating to LDAP for all existing users.   Thanks to Alessio for the contrib and howto.  Now once we get a good outlook connector to SOGo then we have a good exchange replacement contender.

a little OT but: AFAIK the project of a outlook connector for SOGO is aborted.. I read in the SOGO's ML that the choice is funambol 
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia