Koozali.org formerly Contribs.org

SME Server 6.5 question

Offline pssl

SME Server 6.5 question
« on: November 18, 2009, 04:01:44 AM »
It appears that the forum only deals with version 7. Is this correct?  If so, where can I get help with my version?  I'm running 6.5 because 7 wouldn't load on the machine I'm using, a VIA (a very small, bare essentials machine)...at least the last time I tried (a few years ago) it didn't work. 

The server has been running without a problem for years, but now I've had to reboot twice in the last two days because I could not access the internet.  A scan of the Message log shows that Squid is crashing.  I don't know what Squid does exactly, but it appears to handle retrieving of web pages, so I assume a symptom of Squid not running is no access to the internet.  A search of the internet indicates that if the Squid log files are two big (>2gig) it will have problems.  They suggest that the logs should be forced to cycle more often.  How do I do this in SME?  Or is there another solution?

Offline janet

  • ****
  • 4,682
Re: SME Server 6.5 question
« Reply #1 on: November 18, 2009, 11:18:59 AM »
pssl

If you look further down the list of forums you will see Obselete releases.
I don't think you will get too much help there, although you can try.

I realise your predicament re hardware, BUT you are being very unwise to keep using a web connected server running an old and insecure version of sme. There have been no updates for sme 6.5 for probably 2 years or more, sme 7.x has been released for at least that length of time, and you would be wise to upgrade, even if it means a hardware upgrade.

Your problem could have many possible causes, including having been hacked. Log files are regularly rotated in sme, so I doubt that's your problem.
I don't think anyone here will want to diagnose sme6.5 problems, most of us have forgotten about the inner workings of sme6.5 anyway.
At a wild guess I'd suggest looking at memory usage using
top -i
and
htop
(I think htop was in sme6.5 but I can't remember, there's the problem for us).
Please search before asking, an answer may already exist.
The Search & other links to useful information are at top of Forum.

Offline Stefano

  • *
  • 10,779
  • Skype account: maghissimo
    • Smeserver italian community
Re: SME Server 6.5 question
« Reply #2 on: November 18, 2009, 11:25:49 AM »
It appears that the forum only deals with version 7. Is this correct?  If so, where can I get help with my version?  I'm running 6.5 because 7 wouldn't load on the machine I'm using, a VIA (a very small, bare essentials machine)...at least the last time I tried (a few years ago) it didn't work. 

you should/could retry

Quote
A scan of the Message log shows that Squid is crashing.  I don't know what Squid does exactly, but it appears to handle retrieving of web pages, so I assume a symptom of Squid not running is no access to the internet.  A search of the internet indicates that if the Squid log files are two big (>2gig) it will have problems.  They suggest that the logs should be forced to cycle more often.  How do I do this in SME?  Or is there another solution?

you should read in squid's log file the exact error.. with it and a little search on Google you should find the way (I suspect you have to stop squid, delete its logs  then start it again)

anyway, as Mary told you, you really should start an upgrade program
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Offline pssl

Re: SME Server 6.5 question
« Reply #3 on: November 18, 2009, 02:05:41 PM »
Mary and Stefano,

Thanks very much.  I did not consider having been hacked.  I guess it's time to look at replacing some hardware.  Again, thanks much for your reply.