Koozali.org formerly Contribs.org

HylaFAX v6

HylaFAX v6
« on: June 02, 2009, 04:57:54 AM »
For all those that like to keep up to date with the latest, I have installed the the 6.0.2 HylaFAX rpms.

Tested and working just fine...

If you have a previous version installed you need to uninstall just the hylafax rpm, nothing else. I use yum...

To install the new version;

1) Download both the client and server rpm's from hylafax.org for redhat/centos4

2) yum --enablerepo=base --enablerepo=updates localinstall hylafax-client-6.0.2-1rhel4.i386.rpm hylafax-server-6.0.2-1rhel4.i386.rpm

3) re-run faxsetup followd by faxaddmodem for each installed modem

4) fire it up

For fresh installs;

yum --enablerepo=base --enablerepo=updates localinstall hylafax-client-6.0.2-1rhel4.i386.rpm hylafax-server-6.0.2-1rhel4.i386.rpm
signal-event post-upgrade
signal-event reboot

after reboot followed by;

faxsetup
faxaddmodem

then to make eveything stick;

mkdir -p /etc/e-smith/templates-custom/etc/inittab
cd /etc/e-smith/templates-custom/etc/inittab
echo 'fax:23457:respawn:/usr/sbin/faxgetty ttySx' >> 85hylafax (adjust the x for your com port)
/sbin/e-smith/expand-template /etc/inittab
init q

ln -s /etc/rc.d/init.d/hylafax /etc/rc.d/rc7.d/S95hylafax
mv /etc/cron.daily/hylafax /etc/cron.weekly/
service hylafax restart


Chaloner Hale
email@chaloner.ca

« Last Edit: June 02, 2009, 05:12:30 AM by chaloner »

Re: HylaFAX v6
« Reply #1 on: June 27, 2009, 10:21:36 PM »
I also tried hylafax 6.0.1-2, but not 6.0.2

It's not compatible with smeserver-hylafax...

Stephen Noble, can you update this contrib?
You wrote:
   SMERPFax should be added to smecontribs and / or panels should be converted to utf-8, perhaps it should be merged with smeserver-hylafax

Currently, smeserver-hylafax is not compatible with SMERPFax.
I would also like to have many modems

thank you
anne
« Last Edit: June 27, 2009, 10:24:57 PM by ecureuil »

Re: HylaFAX v6
« Reply #2 on: June 28, 2009, 11:07:59 PM »
For all those that like to keep up to date with the latest, I have installed the the 6.0.2 HylaFAX rpms.

Thanks for the update. Have you noticed any tangible improvements over the 4.4.4 version? It claims to have better T.30 handling which may be useful.
SME since 2003

Re: HylaFAX v6
« Reply #3 on: July 01, 2009, 10:06:14 AM »
Quote
If you have a previous version installed you need to uninstall just the hylafax rpm, nothing else. I use yum...

yum remove hylafax
==============================================================
WARNING: Additional commands may be required after running yum
==============================================================
Loading "installonlyn" plugin
Loading "smeserver" plugin
Loading "fastestmirror" plugin
Loading "protect-packages" plugin
Setting up Remove Process
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package hylafax.i386 20080423:4.4.4-1.el4.sme set to be erased
--> Running transaction check
Setting up repositories
smeaddons                 100% |=========================| 1.9 kB    00:00
smeextras                 100% |=========================| 1.9 kB    00:00
base                      100% |=========================| 1.1 kB    00:00
updates                   100% |=========================|  951 B    00:00
smeos                     100% |=========================| 1.9 kB    00:00
smeupdates                100% |=========================| 1.9 kB    00:00
Loading mirror speeds from cached hostfile
Reading repository metadata in from local files
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
Excluding Packages from CentOS - os
Finished
Excluding Packages from CentOS - updates
Finished
--> Processing Dependency: hylafax >= 4.3 for package: smeserver-hylafax
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package smeserver-hylafax.noarch 0:0.9-6.el4.sme set to be erased
--> Running transaction check

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Removing:
 hylafax                 i386       20080423:4.4.4-1.el4.sme  installed         2.7 M
Removing for dependencies:
 smeserver-hylafax       noarch     0.9-6.el4.sme    installed          22 k

Transaction Summary
=============================================================================
Install      0 Package(s)
Update       0 Package(s)
Remove       2 Package(s)

@chaloner: what has to be uninstalled? Only the hylafax-rpm or also the dependency smeserver-hylafax? Could you advise please?

Thank you.
And then one day you find ten years have got behind you.

Time, 1973
(Mason, Waters, Wright, Gilmour)