Koozali.org formerly Contribs.org

PPPoe Server Only Mode

PPPoe Server Only Mode
« on: November 22, 2008, 02:01:59 AM »
I have a (very) remote SME6 server that uses dialup.  It's currently set as Server/Gateway and the only current requirement is mail/web proxy.  It only has 1 NIC

Until I can get a separate wan router or NIC to the location, I am looking at changing it to Server Only but use PPPoE to connect to the Internet. 

I am thinking that the simplest way to do this is create a script called in rc.local to do the following:

create a rc.local call for a script that brings up the PPPoE connection - and assume that it will replace the eth0 addresses as the default gateway?; and

bring up an eth0:1 alias for the local net to talk to the server - I assume the server will still act as a proxy server on that network.

As I can't get to the machine physically (or ssh after the change) and have no real support at that end, I want to check if anyone has any thoughts on whether this would work or not.  Or any better/other suggestions?


thanks

Klaus
......

Offline David Harper

  • *
  • 653
  • Watch this space
    • Workgroup Technology Solutions
Re: PPPoe Server Only Mode
« Reply #1 on: November 23, 2008, 05:13:50 AM »
Whoa, this sounds complicated.... and why are you still using SME 6.x?

SME Server was never designed to do what you are trying to achieve here, so I don't think anybody is going to be able to offer much advice (prove me wrong folks!). What I would suggest is, if you are keen, try installing a copy of SME 6 in a virtual machine (VMware Server maybe) and then trial your plan and iron out any kinks in it.

Re: PPPoe Server Only Mode
« Reply #2 on: November 23, 2008, 08:05:03 AM »
Why SME6? There were issues with dialup in SME7 at the time of building this server.  The server is in an area serviced by poor and expensive phone lines, even the just installed 'broadband' is around a good dialup speed!

With the unreliable lines, poor connections and lack of tech support in the area, upgrading remotely has been an issue.  Once I get it on the broadband I will upgrade step by step.

I have tried on a VM but can't emulate the PPPoE connection at this location.

Yes a little complicated, was just hoping that someone may have a simpler solution.
......