Koozali.org formerly Contribs.org

Hylafax 4.4.4-1 - Problem sending Faxes via e-mail

Hylafax 4.4.4-1 - Problem sending Faxes via e-mail
« on: November 07, 2008, 06:59:46 PM »
Problem sending fax (Receiving is OK). Installed sme-hylafax contrib (with Hylafx 4.4.4-1 reh4 package) following contrib install instructions. Single serial port ttyS0 - external modem; sending (inside Horde) a fax message with recipient name@number.fax i can find in mail log the following error:

Quote
@400000004914583730b8fbfc new msg 1953179
@400000004914583730b91754 info msg 1953179: bytes 7319 from <faxsender@chester-perry.priv> qp 6087 uid 453
@4000000049145837321ea67c starting delivery 28: msg 1953179 to local faxsender-Nome.Cognome@0115033xxx.fax
@4000000049145837321ec5bc status: local 1/10 remote 0/20
@40000000491458373361771c delivery 28: success: faxmail:_No_Destination/Dialstring_specified./sendfax:_No_input_data;_tranmission_aborted./did_0+0+1/
@400000004914583733637abc status: local 0/10 remote 0/20
@400000004914583733646134 end msg 1953179

It seems that faxmail is executed with wrong command line parameters. Does anyone know something about this ?

Bye

Nicola
« Last Edit: November 08, 2008, 03:33:46 PM by nicolatiana »
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia.

Re: Hylafax 4.4.4-1 - Problem sending Faxes via e-mail
« Reply #1 on: November 08, 2008, 10:05:45 AM »
The problem is Hylafax release: the current smeserver-hylafax contrib (0.9.6) works fine only with Hylafax 4.3.4-1, at least for how concerns the use as e-mail to fax gateway that is its main purpouse.
You may find some informations here:

http://lists.contribs.org/pipermail/contribteam/2008-January/001183.html

Maybe the problem concerns the different behaviour of faxmail 4.4.x respect to 4.3.x (From Hylafax site: http://www.hylafax.org/content/Email_to_Fax_Gateway):
Quote
*** NOTE*** This describe the old pre 4.4 version of faxmail. Begining with version 4.4.0, faxmail now handles attachments natively, according to the same typerules logic as sendfax.

Installing Hylafax 4.3.4-1 I've the fax gateway working fine rx and tx, except an extra blank page put at the end of the fax when I attach a pdf or tiff file. Maybe a Hylafax 4.4.0 manually configured to work with qmail will work fine the same.

Any other contribution is welcomed.

Nicola
« Last Edit: November 08, 2008, 03:34:06 PM by nicolatiana »
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia.

Re: Hylafax 4.4.4-1 - Problem sending Faxes via e-mail - Solved
« Reply #2 on: April 14, 2010, 09:27:56 PM »
The Hylafax contrib page has been modified:

http://wiki.contribs.org/HylaFax

You'll find the instructions to manage Hylafax 4.4.xx

Bye

Nicola
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia.