Koozali.org formerly Contribs.org

openfire install issues

Offline GGD

openfire install issues
« on: May 25, 2008, 04:09:55 PM »
I followed the instructions on the contib  http://wiki.contribs.org/Openfire and I cannot get the application to setup correctly.  When I get to the “create your data base” part specifically the line where it mentions “mysql openfiredb < openfire_mysql.sql” I enter that line into the server and it spits back out an error message of "ERROR 1170 (42000) at line 77: BLOB/TEXT column 'jid' used in key specification without a key length"  and it will not do the action, also when I go to the web admin website and go to the data base- standard connection  and enter the Database URL: jdbc:mysql://localhost:3306/openfiredb and click continue after putting in the user name and password, it says "The Openfire database schema does not appear to be installed. Follow the installation guide to fix this error."  Currently I am using both the sark-sme-7.3-2.2.1-617 and the SME 7.3 (the one that is currently available for download on the website). I am also using the following openfire rpm: openfire-3.5.1-1.i386. And I am getting the same error messages.  Any ideas as to what the issue would be?

thank you for your time


Dave

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: openfire install issues
« Reply #1 on: May 25, 2008, 06:08:57 PM »
I followed the instructions on the contib  http://wiki.contribs.org/Openfire and I cannot get the application to setup correctly.  When I get to the “create your data base” part specifically the line where it mentions “mysql openfiredb < openfire_mysql.sql” I enter that line into the server and it spits back out an error message of "ERROR 1170 (42000) at line 77: BLOB/TEXT column 'jid' used in key specification without a key length"  and it will not do the action
It seems there are some errors with the DB import, therefore you are presented an error that the database is not properly initialized, unfortunately I have no experience with openfire. Did you install the same version as mentioned in the wiki?
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline GGD

Re: openfire install issues
« Reply #2 on: May 25, 2008, 06:14:22 PM »
I went to the website that was mentioned in the wiki and I downloaded the version that is on there...  I tried to find that particular version that was on the wiki but it wasn't there...  the current version was thou (I think it was a later version than what was in the wiki)

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: openfire install issues
« Reply #3 on: May 25, 2008, 06:16:27 PM »
I went to the website that was mentioned in the wiki and I downloaded the version that is on there...  I tried to find that particular version that was on the wiki but it wasn't there...  the current version was thou (I think it was a later version than what was in the wiki)
Perhaps a bug has slipped in the routine to create the database... perhaps worth mentioning on the Discussino tab of before mentioned wiki page, perhaps more people will notice or even have a workaround for it, perhaps you should contact the packager and send them a notice of your error so they can diagnose and try and fix it.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline GGD

Re: openfire install issues
« Reply #4 on: May 25, 2008, 06:19:18 PM »
I sent an email to the author of the wiki and they told me to post it on the fourms....  who would be the "packager"? 


Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: openfire install issues
« Reply #5 on: May 25, 2008, 06:24:29 PM »
who would be the "packager"? 
Don't know but most likely to be found on the site you downloaded the package from.
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline GGD

Re: openfire install issues
« Reply #6 on: May 25, 2008, 06:28:49 PM »
understood....  I will see if they have anything on this issue there....

thanks

Dave

Offline fixit

  • *
  • 216
    • http://www.fixitcomputers.com.au
Re: openfire install issues
« Reply #7 on: May 26, 2008, 04:39:53 AM »
It looks as if the latest version of openfire requires mysql 5. Try this link here to download the same version as in the howto http://www.igniterealtime.org/downloadServlet?filename=openfire/openfire-3.4.4-1.i386.rpm

or use

wget http://www.igniterealtime.org/downloadServlet?filename=openfire/openfire-3.4.4-1.i386.rpm

also

you have to remove openfire-3.5.1-1.i386 with the following command

/etc/rc.d/init.d/openfire stop

yum remove openfire

rm -Rf /opt/openfire

mysqladmin drop openfiredb

config delete openfire

signal-event remoteaccess-update

Reinstall commands

cd /tmp

wget http://www.igniterealtime.org/downloadServlet?filename=openfire/openfire-3.4.4-1.i386.rpm

yum localinstall openfire-3.4.4-1.i386.rpm

and follow the rest of the installation procedures

Russell
« Last Edit: May 26, 2008, 04:54:58 AM by fixit »
.........

Offline dmay

  • *
  • 450
    • http://myezserver.com
Re: openfire install issues
« Reply #8 on: May 26, 2008, 05:51:20 AM »
Lets see if anyone replies:

http://www.igniterealtime.org/community/thread/33137

BTW, I'm currently using 3.5.1 on SME just fine. I did this via upgrade from earlier releases so did not encounter this fresh db install issue. The same should work for you.

Darrell

Offline fixit

  • *
  • 216
    • http://www.fixitcomputers.com.au
Re: openfire install issues
« Reply #9 on: May 26, 2008, 07:40:48 AM »
I tried a fresh install using the openfire howto and faced the same problem, I did try and make modification to openfire_mysql.sql @ line 321 and changed the number from 16 to 13

INSERT INTO jiveVersion (name, version) VALUES ('openfire', 13);

and the database loaded

I will try 3.4.4-1 to 3.5.1 and see what happens

Well either way, the howto has been updated anyway

Russell
.........