Koozali.org formerly Contribs.org

Need to Disable Squid Completely

Need to Disable Squid Completely
« on: March 07, 2008, 10:37:33 PM »
I hope someone can help me with this problem, it's been driving me insane for a while now.  We have a firewall which, for reasons too long, convoluted, and mired in corporate mud, still runs 6.0.1 and cannot be upgraded.  We need to disable the Squid transparent proxy completely, as it is interfering with some other functionality on our network.  We have filtering and web control handled using another product, so we don't need this functionality at all.

I found the link;

http://wiki.contribs.org/Firewall#Bypass_Proxy

Which, with a minor edit, allows me to bypass it for one or more specific sites, which is nice, but what we really need to do is just remove Squid from the equation completely.

A preemptive thank you to anyone who can assist with this, and save what little of my hair I have left!

Re: Need to Disable Squid Completely
« Reply #1 on: March 07, 2008, 10:41:44 PM »
And of course I now feel like a total ass, as three posts down, I get this information;

/sbin/e-smith/db configuration setprop squid Transparent no
/sbin/e-smith/expand-template /etc/squid/squid.conf
/etc/init.d/squid restart

Can I express my sorrow to all involved?  I will research a problem before I ask a question next time, promise :)


Re: Need to Disable Squid Completely
« Reply #2 on: March 07, 2008, 11:29:22 PM »
Ah hah, but now time for a second response to my own question!  If I set it to transparent no, users are not able to surf, getting the error;

ERROR
The requested URL could not be retrieved

While trying to retrieve the URL: /

The following error was encountered:

    * Invalid URL

Some aspect of the requested URL is incorrect. Possible problems:

    * Missing or incorrect access protocol (should be `http://'' or similar)
    * Missing hostname
    * Illegal double-escape in the URL-Path
    * Illegal character in hostname; underscores are not allowed

Offline raem

  • *
  • 3,972
Re: Need to Disable Squid Completely
« Reply #3 on: March 08, 2008, 05:05:46 AM »
ropetin

I think you need to specify the proxy port (3128) in the browser, rather than use the auto detect setting.

For some related info see
http://wiki.contribs.org/Dansguardian#Filter_Groups_and_Auth_login
...

Re: Need to Disable Squid Completely
« Reply #4 on: March 11, 2008, 09:16:13 PM »
That would probably work, but what I want to do is allow users unfettered access to the Internet, without a transparent proxy in the way, and without them needing to specify any settings.

Any suggestions?

Offline raem

  • *
  • 3,972
Re: Need to Disable Squid Completely
« Reply #5 on: March 13, 2008, 11:09:13 AM »
ropetin

I know you said you can't/don't want to, but if you upgrade to sme7.3 you can utilise this:
http://wiki.contribs.org/SME_Server:Documentation:FAQ#Bypass_Proxy
...

Offline william_syd

  • ****
  • 1,608
  • Nothing to see here.
    • http://www.magicwilly.info
Re: Need to Disable Squid Completely
« Reply #6 on: March 13, 2008, 11:34:07 AM »

Which, with a minor edit, allows me to bypass it for one or more specific sites, which is nice, but what we really need to do is just remove Squid from the equation completely.

A preemptive thank you to anyone who can assist with this, and save what little of my hair I have left!

Does squid have to running for browsing via SME to work? I can't remember much about sme 6 but does the squid service have a status property?

/sbin/e-smith/db configuration show squid

If it does, try changing it from enabled to disabled. Then expand and stop.







Regards,
William

IF I give advise.. It's only if it was me....