Koozali.org formerly Contribs.org

[UPDATE] smeserver-sysmon

[UPDATE] smeserver-sysmon
« on: February 04, 2008, 09:33:10 AM »
Hello all,

Following this post here, I've update the sysmon contrib this weekend.
I add a new graph to display the number of users that are connected to server using samba.

RPM:
smeserver-sysmon-5.1-1.noarch.rpm

sRPM:
smeserver-sysmon-5.1-1.src.rpm

Regards,
MasterSleepy.

Offline Jáder

  • *
  • 1,061
    • LinuxFacil
Re: [UPDATE] smeserver-sysmon
« Reply #1 on: February 04, 2008, 02:35:28 PM »
Hi

Thanks by the rpm, but I have problems:

1) not sure what repo must be enable to install using yum localinstall (rpm -Uvh fail by dependencies)
I used --enablerepo=* ... but do not like to do.

2) After installed, must do "signal-event post-upgrade; signal-event reboot" ??
Without it I got a 403 error!
Code: [Select]
Forbidden

You don't have permission to access /server-manager/cgi-bin/sysmon on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.

3) After reboot, I still get same error message.

This is a newly installed server, just have 2 or 3 extra rpm (ModIndex, LAT and displayconf installed and already removed)


 
...

Offline kevinb

  • *
  • 237
Re: [UPDATE] smeserver-sysmon
« Reply #2 on: February 04, 2008, 03:39:46 PM »
Thanks MasterSleepy,

I really enjoy this contrib. I'll try an update later today.

I noticed that there is a new version of "rrdtool" (1.2.23-3.el4) on the repo smecontribs that would break the previous version of smeserver-sysmon. Can this new version use it? Also, will you be addeing your contribs to the smecontribs repo?


BTW ... I can't get "wget" to work with your links. do i need to use and special switches?


Thanks again


Kevin
« Last Edit: February 04, 2008, 03:45:29 PM by kevinb »

Re: [UPDATE] smeserver-sysmon
« Reply #3 on: February 04, 2008, 04:03:23 PM »
Hello,

@Kevinb
Actually I didn't test with the new version of rrdtool, in a near future I'll do that ;-)
For wget the file, try :
Code: [Select]
wget "http://www.vanhees.cc/index.php?name=CmodsDownload&file=index&req=getit&lid=300"To add rpm to repo, I have to take some time to know it work, but I don't really have time for that.

@jader
I'll check for that soon and come back when I've a solution.

Regards.

Offline kevinb

  • *
  • 237
Re: [UPDATE] smeserver-sysmon
« Reply #4 on: February 04, 2008, 04:15:40 PM »
Thanks MasterSleepy,

But, I get the same errors as jader.

Has anyone gotten this resolved?

Can anyone point me to a place I can get the old RPM?


Kevin

Re: [UPDATE] smeserver-sysmon
« Reply #5 on: February 04, 2008, 04:21:51 PM »

Offline Franco

  • *
  • 1,171
    • http://contribs.org
Re: [UPDATE] smeserver-sysmon
« Reply #6 on: February 04, 2008, 04:59:03 PM »
[Mon Feb 04 13:55:06 2008] [error] [client 127.0.0.1] Symbolic link not allowed: /etc/e-smith/web/panels/manager/cgi-bin/sysmon, referer: https://sme7/server-manager/navigation

To fix, delete the old entry (incomplete)
Quote
rm -rf /etc/e-smith/web/panels/manager/cgi-bin/sysmon
then make a new one:
Quote
cd /etc/e-smith/web/panels/manager/cgi-bin/
ln -s ../../../functions/sysmon sysmon
« Last Edit: February 04, 2008, 05:03:58 PM by stuntshell »

Offline Jáder

  • *
  • 1,061
    • LinuxFacil
Re: [UPDATE] smeserver-sysmon
« Reply #7 on: February 04, 2008, 05:38:04 PM »
[Mon Feb 04 13:55:06 2008] [error] [client 127.0.0.1] Symbolic link not allowed: /etc/e-smith/web/panels/manager/cgi-bin/sysmon, referer: https://sme7/server-manager/navigation

To fix, delete the old entry (incomplete)then make a new one:

That fixed the 403 error... but still no graphs! (and yes... I wait more than 5 minute!)

AND I cannot see a SambaUsers  on top menu, just :

System Monitor
Code: [Select]
System:
CPU Load/CPU Memory Proc/Que Drives Uptime
Hosts:

'Hourly' Graph (1 Minute Average)

'Daily' Graph (5 Minute Average)

'Weekly' Graph (30 Minute Average)

'Monthly' Graph (2 Hour Average)

'Yearly' Graph (1 Day Average)
« Last Edit: February 04, 2008, 05:39:44 PM by jader »
...

Re: [UPDATE] smeserver-sysmon
« Reply #8 on: February 04, 2008, 07:39:55 PM »
Hello all,

Here is the version 5.1-2 that solved the problem i the server-manager panel.

RPM:
smeserver-sysmon-5.1-2.noarch.rpm

sRPM:
smeserver-sysmon-5.1-2.src.rpm

@jader:
Please make an install of the new version please. A new entry should appear below Hosts.

Regards,
MasterSleepy.

Offline Franco

  • *
  • 1,171
    • http://contribs.org
Re: [UPDATE] smeserver-sysmon
« Reply #9 on: February 04, 2008, 08:31:33 PM »
Does the statement to clean the /var/lib/rrd/ apply?
Last time I did it and as Jader points out, it does not create new ones.

Thanks,

Re: [UPDATE] smeserver-sysmon
« Reply #10 on: February 04, 2008, 08:48:17 PM »
No you don't have to clean all rrd.
Just a new one will be create.

Reg,
MasterSleepy.

Offline kevinb

  • *
  • 237
Re: [UPDATE] smeserver-sysmon
« Reply #11 on: February 04, 2008, 10:02:22 PM »
OK,

I upgraded (yum localupdate *) to smeserver-sysmon-5.1-1, then to smeserver-sysmon-5.1-2, re-configure, rebooted and deleted all the files in /var/lib/rrd and the page access error went away but I now have no graphics (its been about 15 minutes now). I also do not have any files /var/lib/rrd and the sysmon log is empty.

I only have the images (they are broken links now) I had before .... I do not see any images for system sensors, UPS, Samba, etc.

Please let me know what I should try next.

Thanks,

Kevin

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: [UPDATE] smeserver-sysmon
« Reply #12 on: February 04, 2008, 10:11:11 PM »
I upgraded (yum localupdate *) to smeserver-sysmon-5.1-1, then to smeserver-sysmon-5.1-2, re-configure, rebooted and deleted all the files in /var/lib/rrd and the page access error went away but I now have no graphics (its been about 15 minutes now). I also do not have any files /var/lib/rrd and the sysmon log is empty.
I did the same and it seems that since the time of installation of the faulty (5.1-1) smeserver-sysmon no data is graphed even after an upgrade to the new version (5.1-2).

Just out of interest... do you test before releasing?
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)

Offline Franco

  • *
  • 1,171
    • http://contribs.org
Re: [UPDATE] smeserver-sysmon
« Reply #13 on: February 04, 2008, 10:20:21 PM »
This is a no-go :(
After install it no longer graphs.

Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: [UPDATE] smeserver-sysmon
« Reply #14 on: February 04, 2008, 10:50:23 PM »
I did the same and it seems that since the time of installation of the faulty (5.1-1) smeserver-sysmon no data is graphed even after an upgrade to the new version (5.1-2).

Just out of interest... do you test before releasing?
I tried to locate the logfiles, and in /var/log I find a sysmon and a sysmon.old, but they both have a size of 0 bytes... :-(

On doing some further investigation it seems that the scripts that init scripts are not symlinked properly:
Code: [Select]
[root@homer etc]# ll /etc/rc.d/rc*.d/*sysmon
lrwxrwxrwx  1 root root 12 Feb  4 21:22 /etc/rc.d/rc0.d/K03sysmon -> ../init.d/sy
lrwxrwxrwx  1 root root 12 Feb  4 21:22 /etc/rc.d/rc1.d/K03sysmon -> ../init.d/sy
lrwxrwxrwx  1 root root 12 Feb  4 21:22 /etc/rc.d/rc2.d/K03sysmon -> ../init.d/sy
lrwxrwxrwx  1 root root 12 Feb  4 21:22 /etc/rc.d/rc3.d/K03sysmon -> ../init.d/sy
lrwxrwxrwx  1 root root 12 Feb  4 21:22 /etc/rc.d/rc4.d/K03sysmon -> ../init.d/sy
lrwxrwxrwx  1 root root 12 Feb  4 21:22 /etc/rc.d/rc5.d/K03sysmon -> ../init.d/sy
lrwxrwxrwx  1 root root 12 Feb  4 21:22 /etc/rc.d/rc6.d/K03sysmon -> ../init.d/sy
lrwxrwxrwx  1 root root 16 Feb  4 22:54 /etc/rc.d/rc7.d/S97sysmon -> ../init.d/sy

Since the broken symlinks prevent the sysmon service from starting no graphdata is collected,
I have fixed all symlinks manually and started sysmon after that. I will wait a few minutes, but my guess is the collecting of data will resume.
« Last Edit: February 04, 2008, 11:00:48 PM by cactus »
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)