Koozali.org formerly Contribs.org

Howto: Shared Calendar with Outlook 2007

Offline David Harper

  • *
  • 653
  • Watch this space
    • Workgroup Technology Solutions
Howto: Shared Calendar with Outlook 2007
« on: December 28, 2007, 08:25:57 AM »
I've been experimenting with Outlook 2007 and SME, and to my great delight it is now possible to have a shared calendar (sort of) without any of the complicated groupware procedures that have never really worked for me (okay so I am new :cool: ).

Anyway, here are the instructions:

Shared Calendar in Outlook 2007

This will let you create a shared calendar that will be accessible to all users who have Outlook 2007 installed.

Before you begin, you should decide who you want to manage the calendar. Changes to the calendar can only be made through Horde, so if your users are only familiar with Outlook it might make sense to train one or two people to manage the calendar through Horde; the rest of your users can email the necessary details through to the nominated maintainer(s). Alternatively, if your users are comfortable with web-based applications and you are happy to let them modify the shared calendar, you can give them access to the calendar through Horde.

First, let’s configure the calendar.

1. Install the Kronolith Horde module from http://mirror.contribs.org/contribs/jbennett/sme7/horde3.1.x/RPMS/
2. Login to Horde as the user who will be primarily responsible for managing the calendar and select  Organising > Calendar
3. Click on the My Calendars icon at the top of the screen
4. In the Create Calendar area, enter a name for the new calendar and click Create.
5. Log out and log back in again to initialise the new calendar (this appears to be a bug)

Now we can set appropriate permissions for the new calendar.

1. Login to Horde as the user who will be primarily responsible for managing the calendar and select  Organising > Calendar
2. Click on the My Calendars icon at the top of the screen
3. In the Edit Calendar area, select the calendar you created earlier from the drop-down list, and click the Edit button
4. If you wish to grant all users in your company access to the calendar, enable the appropriate permissions in the All Authenticated Users area
5. Enable the Show and Read permissions for Guests; this will allow Outlook to access the calendar
6. Click Save and Finish to save your settings
7. Copy the Remote Subscription URL for use with Outlook

Lastly, we can configure Outlook to show the shared calendar.

1. On the target machine, open Outlook and select Options > Account Settings
2. Go to the Internet Calendars tab and click New
3. Paste the Remote Subscription URL that you previously saved and click OK
4. Enter a meaningful name and description for the calendar in the resulting dialog and click OK
5. Close the Account Settings dialog
6. Open the Calendar view
7. In the All Calendar items area at the left hand side of the screen, check the box next to the Other Calendar whose name matches the one that you configured earlier

Outlook will display the shared calendar alongside the user’s standard calendar.

If you have granted other users access to the calendar from within Horde, it is easy for them to configure their Horde settings to display events from the new shared calendar.

1. Login to Horde and select  Organising > Calendar
2. In the Display Calendars area, check the box corresponding to the calendar that you wish to display events from

Unlike Outlook, Horde integrates events from the two calendars into a single display version. When creating a new event, the user is able to select the calendar to which the event should be saved. The list of calendars that may be added to depends on the permissions that have previously been set.

Security Note
The Remote Subscription URL is accessible from any location and is not protected by a password. If your server is an Internet web server, then the only protection you have against unauthorised users accessing your calendar is the complex URL.
« Last Edit: December 28, 2007, 08:35:24 AM by davidiwharper »

Re: Howto: Shared Calendar with Outlook 2007
« Reply #1 on: January 04, 2008, 01:50:07 PM »
Installed and configured as per spec.

Unable to save Remote URL in Outlook, needs .ics file?



Thanks

Chris
...

Offline David Harper

  • *
  • 653
  • Watch this space
    • Workgroup Technology Solutions
Re: Howto: Shared Calendar with Outlook 2007
« Reply #2 on: January 05, 2008, 12:20:20 AM »
Try opening the calendar URL in Internet Explorer. Do you get an error or does it allow you to download the calendar .ics file?

If you get an error, go back and check your permissions. If you don't get an error, try updating to Office 2007 SP1, which is what I did the testing on.

Re: Howto: Shared Calendar with Outlook 2007
« Reply #3 on: January 11, 2008, 06:54:37 AM »
Hi There,

Updated Office to SP1.

The calendar file created by Horde is not a .ics file, Outlook refusing to accept the Remote Subscription URL.

The file created by Horde looks like this:
https://192.168.10.20/horde/kronolith/ics.php?c=123b73fca7e5187859a5185da91d4a4f

Am I doing the wrong thing here?

I even tried to create a calendar with .ics, still the same type URL.


Thanks
...

Offline David Harper

  • *
  • 653
  • Watch this space
    • Workgroup Technology Solutions
Re: Howto: Shared Calendar with Outlook 2007
« Reply #4 on: January 11, 2008, 12:15:43 PM »
Let me run another test this weekend. AFAIK the reason why there is a URL and not a file is that the actual ICS is dynamically generated when you access the URL.

During my tests with this solution, when I browsed to the remote subscription URL, Internet Explorer came up with the Open/Save file dialog for an ICS file. Does this happen for you when you browse to the URL?

Also, have you made sure that when you go to the Kronolith URL you aren't prompted for a password? I found that Outlook can't cope with a password requirement.

Offline David Harper

  • *
  • 653
  • Watch this space
    • Workgroup Technology Solutions
Re: Howto: Shared Calendar with Outlook 2007
« Reply #5 on: January 12, 2008, 06:55:22 AM »
Okay, I have done the tests again.

What should happen is this:

1. You create the calendar, with Show and Read permissions for guests
2. When you go to the Remote Subscription URL, the browser will be passed an ICS file to download, without being prompted for a password.
3. You paste the Remote Subscription URL (not an ICS file URL directly) into Outlook

Re: Howto: Shared Calendar with Outlook 2007
« Reply #6 on: July 14, 2009, 11:23:23 AM »
Hi

I have used this and works great, to get the ICS file and download it use IE, It will ask you to save it.

Maybe add to wiki??

Cheers

Offline David Harper

  • *
  • 653
  • Watch this space
    • Workgroup Technology Solutions
Re: Howto: Shared Calendar with Outlook 2007
« Reply #7 on: July 14, 2009, 11:56:34 AM »
This has been superceded by Funambol support in some cases, but sure, will do.

Offline David Harper

  • *
  • 653
  • Watch this space
    • Workgroup Technology Solutions

Re: Howto: Shared Calendar with Outlook 2007
« Reply #9 on: October 12, 2009, 04:01:03 PM »
While I'm able to load the calendar via IE (ie download/open ICS file), I'm unable to have Outlook 07 recognise the URL - using SP2 - via the add Internet Calendar.  It states it cannot verify or add the link.

The URL is formatted as:

https://<servername>/horde/kronolith/ics.php?c=<calendar_user>%40<valid_domain>

It's accessible via any browser and has guest read/view permissions set.

Is it suggested that you need to manually download and display the .ics file each day?  Or is there something I'm missing here to get Outlook to sync with the SME server?

Suggestions?


Thanks
......

Offline Stefano

  • *
  • 10,779
  • Skype account: maghissimo
    • Smeserver italian community
Re: Howto: Shared Calendar with Outlook 2007
« Reply #10 on: October 12, 2009, 04:53:13 PM »
sounds like a certificate issue (https) in outlook
Consulente di Smeserver.it -  Soluzioni e supporto su Sme server in Italia

Re: Howto: Shared Calendar with Outlook 2007
« Reply #11 on: October 12, 2009, 11:52:11 PM »
Thanks Stefano

Good clue!  However, just removing the 's' won't work as horde seems to force a secure connection and returns it.

The solution (found after a lot of messing with MS product!!!) is to add the certificate as follows:

In Internet Explorer 8 (not sure of behaviour or requirement in IE6 and 7), navigate to the SME server;

When told "There is a problem with this website's security certificate", choose "Continue to this website (not recommended)";

Select Tools->Internet Options;
Select Security->Trusted sites->Sites;
Confirm the URL matches, and click "Add" then "Close";
Close the "Internet Options" dialog box with either "OK";
Refresh the current page.

When told "There is a problem with this website's security certificate.", choose "Continue to this website (not recommended)";
Click on "Certificate Error" at the right of the address bar and select "View certificates";
Click on "Install Certificate...", then in the wizard, click "Next";
On the next page select "Place all certificates in the following store";
Click "Browse", select "Trusted Root Certification Authorities", and click "OK";
Back in the wizard, click "Next", the "Finish";
If you get a "Security Warning" message box, click "Yes";
Click "OK" on the message box.

Select Tools->Internet Options;
Select Security->Trusted sites->Sites;
Select the URL you just added, click "Remove", then "Close".

Then shut down and restart IE and test the site, it should go straight there with no warning.

You should now be able to add the Internet Calendar into Outlook 2007 as per previous instructions.


Cheers

Klaus

« Last Edit: October 13, 2009, 01:43:47 AM by kadybee »
......

Re: Howto: Shared Calendar with Outlook 2007
« Reply #12 on: February 08, 2010, 07:46:16 AM »
Was having trouble with outlook not saving my calender shortcut found this from another site.

Quote
I have had the same problem. I enter the *.ics calendar subscriptions and they seem to be entered and state they are "pending" but they never show up as registered in my 'Other Calendars.'

What worked for me was using this menu sequence (instead of Using File -> Data File Management -> Internet Calendars):

Tools -> Account Settings -> Internet Calendars

I don't know why this works (for me) but it does.

I do have my Outlook data file in a different location than the standard one Outlook uses by default but the "Internet Calendar Subscriptions.pst" file is still in the default location. I don't know if that is what causes the problem or not.


For me it was the oposite I had to use Tools, Account, Internet Calendars.  Something to keep in the back of your head :P