Koozali.org formerly Contribs.org

7.2 not installable & looking for php-pear rpm for 6.0.1

7.2 not installable & looking for php-pear rpm for 6.0.1
« on: December 27, 2007, 03:04:29 PM »
Hi

I want to run egroupware which needs php >= 4.3 on my machine which currently runs 6.0.1-01.

First I thought this was a good reason to update to SME 7.2, but unfortunately it seems not to be possible to install it on my machine due to my scsi setup. The machine is an AcerAltos 1100E which has a Symbios 53c895 card inside. SME 6 never had a problem with it but with 7.2 setup says no hard drives detected. I'm then asked to choose the driver from a list and choose the Symbios 53c89x driver from the list. Then "running anaconda..." appears and soon exits with a "setup exited abnormally" error. I jad backed the server up and wanted to run an update install btw. If anyone knows what to do in this case please let me know.

So I updated php alone with Dan Brown's php-4.3.10 rpms which worked fine, but I'm still missing pear. I have not found an rpm which can be installed, does anyone have one?

Regards
Martin
« Last Edit: December 27, 2007, 03:16:34 PM by atlantis »

Offline raem

  • *
  • 3,972
Re: 7.2 not installable & looking for php-pear rpm for 6.0.1
« Reply #1 on: December 27, 2007, 03:29:50 PM »
atlantis

You should lodge a bug report at bugzilla regarding your upgrade & hardware problems.
The devs may have an answer for you.

It's not wise to continue using your sme6.x server as it is no longer secure.
There have been no upgrades for over 18 months now.

You would be wise to sort out the hardware issues and upgrade asap, even if this involves a hardware upgrade too.
...

Re: 7.2 not installable & looking for php-pear rpm for 6.0.1
« Reply #2 on: December 27, 2007, 03:43:43 PM »
Hi Ray

It may be a good idea to make a bugzilla report and see if there turns out an answer.

When it comes to a hardware upgrade this is definitely a no-go. If there's no other (simple enough) solution the system needs to continue work as is now (but with pear).

Thanks
Martin

Re: 7.2 not installable & looking for php-pear rpm for 6.0.1
« Reply #3 on: January 04, 2008, 01:07:37 PM »
First of all I agree with Ray that the "best alternative" it to move to SME7.x.

If upgrading your php is your only option You can use php-rpms (version 4.4.4) I compiled some time ago. (AT YOUR OWN RISK!!!)
http://ergin.dyndns.org/download/index.php?dir=/sme6_contribs/php/RPMS

If you search forums you will find a lot of information how to upgrade php.

Good luck.


Offline cactus

  • *
  • 4,880
    • http://www.snetram.nl
Re: 7.2 not installable & looking for php-pear rpm for 6.0.1
« Reply #4 on: January 04, 2008, 01:51:30 PM »
When it comes to a hardware upgrade this is definitely a no-go.
I am curious to know why you are so serious about not updating your hardware... perhaps willing to share on this?
Be careful whose advice you buy, but be patient with those who supply it. Advice is a form of nostalgia, dispensing it is a way of fishing the past from the disposal, wiping it off, painting over the ugly parts and recycling it for more than its worth ~ Baz Luhrmann - Everybody's Free (To Wear Sunscreen)