Koozali.org formerly Contribs.org

HOW-TO (draft): Mythtv as a backend on sme server

Re: HOW-TO (draft): Mythtv as a backend on sme server
« Reply #75 on: February 19, 2008, 12:35:12 PM »
OK, did some experimenting...
Tried compiling new cx88 modules which seemed to compile ok but I'm not 100% certain - I couldn't find newer than 0.0.4 code.
Installed SME v8.0rc1, downloaded the centosplus kernel and copied the cx88 divers but I get...
Code: [Select]
modprobe cx88xx
FATAL: Error inserting cx88xx (/lib/modules/2.6.18-53.1.4.el5/kernel/drivers/media/video/cx88/cx88xx.ko): Operation not permitted
As an experiment I installed the 8.0rc1 kernel onto my test 7.3 system and again copied the cx88 modules.  I get exactly the same error when I try to modprobe.  After the modprobe attempt I get...
Code: [Select]
dmesg
ksign: module signed with unknown public key
- signature keyid: bf480b47c3099a4a ver=3
on both systems.  Any ideas please?

N

Re: HOW-TO (draft): Mythtv as a backend on sme server
« Reply #76 on: February 19, 2008, 01:17:09 PM »
Updates...

Booting the 7.3 system with the 2.6.18-53.1.4.el5.centos.plus kernel from SME 80rc1 finds my card ok...
Code: [Select]
ACPI: PCI Interrupt 0000:00:1f.3[B] -> GSI 17 (level, low) -> IRQ 185
Linux video capture interface: v2.00
cx2388x v4l2 driver version 0.0.6 loaded
ACPI: PCI Interrupt 0000:02:02.0[A] -> GSI 17 (level, low) -> IRQ 185
CORE cx88[0]: subsystem: 0070:9002, board: Hauppauge Nova-T DVB-T [card=18,autodetected]
TV tuner 4 at 0x1fe, Radio tuner -1 at 0x1fe
tveeprom 1-0050: Hauppauge model 90003, rev C2B0, serial# 2427567
tveeprom 1-0050: MAC address is 00-0D-FE-25-0A-AF
tveeprom 1-0050: tuner model is Thompson DTT75105 (idx 110, type 4)
tveeprom 1-0050: TV standards ATSC/DVB Digital (eeprom 0x80)
tveeprom 1-0050: audio processor is None (idx 0)
tveeprom 1-0050: decoder processor is CX882 (idx 25)
tveeprom 1-0050: has no radio, has IR remote
cx88[0]: hauppauge eeprom: model=90003
input: cx88 IR (Hauppauge Nova-T DVB-T as /class/input/input2
cx88[0]/0: found at 0000:02:02.0, rev: 5, irq: 185, latency: 64, mmio: 0xfb000000
cx88[0]/0: registered device video0 [v4l2]
cx88[0]/0: registered device vbi0
cx2388x blackbird driver version 0.0.6 loaded
However, the card doesn't appear in mythtv-setup  :sad:

Two forward, one back...

Eeek! - Just noticed that my card comes up in mythtv-setup as:
Card type: pcHDTV DVB-T capture card (w/V4L drivers)
/dev/video0
Hauppauge Nova-T DVB-T [cx8800]

Confused...
« Last Edit: February 19, 2008, 01:45:44 PM by ntblade »

Re: HOW-TO (draft): Mythtv as a backend on sme server
« Reply #77 on: May 27, 2008, 11:06:14 PM »
Been having another go at this as part of an experiment.  Everything goes fine until the x Forwarding.  When I try to connect using Xming I get:
Code: [Select]
Server sent disconnect message type 2 (protocol error): "Bad packet length nnnnnnnnnnnnn."Funny thing is that I managed to connect first time before I realised that I missed the MYSQL old password step.

Fresh SME 7.3 +all updates + Mythtv install.

I'm currently setting up a virtual PC and take snapshots as I go.

Any ideas anyone?

N

Re: HOW-TO (draft): Mythtv as a backend on sme server
« Reply #78 on: May 31, 2008, 05:45:35 PM »
Added info to the wiki ( http://wiki.contribs.org/MythTV ) on how to enable Mythweb. 99% 'stolen' from an old post by Duncan ;-)

Verified and works on SME Server 7.3

HF,
I tried your How-to for mythweb. I had to make the following changes in my environment to get it to work. Did you or have I made a mistake somewhere?

Changes from How-to:
1) to 99mythweb I also had to add: Options FollowSymlinks
2) In .htaccess I also had to uncomment the rewrite rules marked with "*"
3) I had to create index.html with the content "<META http-EQUIV="Refresh" CONTENT="0; url=mythweb.php">:

Does this sound familiar or have missed something else that result in me having to mod these?

Christian
SME since 2003

Re: HOW-TO (draft): Mythtv as a backend on sme server
« Reply #79 on: May 31, 2008, 05:54:33 PM »
Been having another go at this as part of an experiment.  Everything goes fine until the x Forwarding.  When I try to connect using Xming I get:
Code: [Select]
Server sent disconnect message type 2 (protocol error): "Bad packet length nnnnnnnnnnnnn."Funny thing is that I managed to connect first time before I realised that I missed the MYSQL old password step.

I've never used Xming (I usually just run another OS on VirtualBox) but when I did a quick google I got the impression this is related to either an SSH version mismatch or possible too many failed log in attempts. I would verify what SSH Xming is using vs SME and what settings related to it. But what the heck do I know. Sorry I can't be more helpful.
SME since 2003

Re: HOW-TO (draft): Mythtv as a backend on sme server
« Reply #80 on: June 01, 2008, 10:10:26 AM »
Thanks for the reply.
I googled that message too and all seemed to point to ssh protocol versions.  I couldn't figure it out.
Meantime I've setup a Knoopmyth box.  I might give mythdora a try as well as both of these distros' kernels support my TV Cards whereas SME doesn't and I had not luck compiling new modules etc.  :-(

Seems like my dream all-in-one home server/media backend will have to wait until SME 8.0

All the best,
NTB

HOW-TO (modified): Mythtv as a backend on sme server
« Reply #81 on: June 30, 2008, 12:41:11 AM »
I've updated the mythtv How TO: http://wiki.contribs.org/MythTV

Notable changes:
Myth has moved on to 0.21 but it requires mysql5. SME 7 is on mysql4 so I changed the installation to pull in only the latest mysql4 dependent versions; namely 0.20.2.

I removed the dependencies as I don't think they are required yet likely could contribute to a security vulnerability. It also simplifies things.

Christian
SME since 2003