Koozali.org formerly Contribs.org

usb raid grub dead drive problem

usb raid grub dead drive problem
« on: June 29, 2007, 07:01:18 AM »
What a painful day!

In preparation of finally going to 7.x I connected a USB drive to rsync /home.  That seemed to go OK, until I noticed system performance went to zero.  After spending much time fumbling around I finally realized that I had rsynced to the media folder and not to the drive, filling the drive(s) up completely.

Deleted the offending folder.  Everything seemed OK.

Rebooted.  GRUB error. Rebooted. GRUB error.  Rebooted.  System disk failure, along with that sickening knocking sound.  Yikes!

OK, not going to panic, this is why I run sme software raid 1!

Pulled the dead drive.  Gets a little further now - to the GRUB command line. ACK!

Booted up w/ knoppix.  Everything looks to be in the boot partition, but the main partition does not have a recognized file system!  Won’t mount and QtParted shows as unknown file system.

I'm lost at this point.  What, if anything, can I do to get my files back?

Thanks in advance!

usb raid grub dead drive problem
« Reply #1 on: July 03, 2007, 04:52:28 AM »
worked it out.