Koozali.org formerly Contribs.org

Spamassassin installing software problems ??

Spamassassin installing software problems ??
« on: June 07, 2007, 04:38:05 PM »
I was recieveing some errors in the mail log. (see Spamassassin Questions ? May 30 2007, 12:28)

It was recomended kindly by Knuddi to upgrade the software to get rid of a known problem.

However Im having great difficulty installing the software.

Current sofware is  ...
/root/RPMS #rpm -qa |grep -i Spam
sortspam-1.0.0-01
sme-spamfilter-1.3.0-1
spamassassin-3.1.8-1
perl-Mail-SpamAssassin-3.1.8-1

When I try to install .. spamassassin-3.1.1-1*.rpm

/root/RPMS #rpm -Uvh spamassassin-3.1.1-1*.rpm
error: failed dependencies:
        perl-Mail-SpamAssassin = 3.1.1-1 is needed by spamassassin-3.1.1-1

So then I try to install Perl perl-Mail*3.1.1-1*.rpm

/root/RPMS #rpm -Uvh perl-Mail*3.1.1-1*.rpm
error: failed dependencies:
        perl-Mail-SpamAssassin = 3.1.8-1 is needed by spamassassin-3.1.8-1

But its already installed.

Im confused.

How can I install what Im suppose to ?
Thanks.