Koozali.org formerly Contribs.org

eGroupware upgrade to 1.4

Offline raem

  • *
  • 3,972
Re: eGroupware upgrade to 1.4
« Reply #75 on: November 30, 2007, 11:46:17 AM »
ddougan

Quote
/etc/e-smith/templates-custom/etc/httpd/conf/httpd.conf/
/etc/e-smith/templates-custom/etc/httpd/conf/httpd.conf/VirtualHosts/

Check
/etc/e-smith/templates/etc/httpd/conf/httpd.conf/....
as rpms should install fragments into the templates tree rather than the templates-custom tree
...

Re: eGroupware upgrade to 1.4
« Reply #76 on: November 30, 2007, 09:03:56 PM »
Thanks, Ray; however, my installation was from tarball, prior to there being an SME Server RPM. Something is causing the new 1.4 RPM to bork, but as far as I can see I have removed all references to the tarball version. I will double check the templates tree, but it's likely I will rebuild the box (it's my test system) to ensure it installs on a clean box. That still gives me the issue of getting the new version on to my production system...

Des
Des Dougan

Re: eGroupware upgrade to 1.4
« Reply #77 on: December 01, 2007, 03:31:58 PM »
When I go to " https://mysmebox/egroupware " and try to Login I notice on the top of the Login Box: " Your session could not be verified. "

I have crated a admin User Account but as soon as I want to try to Login it says: " Blocked, too many attempts "

Please Help  :-(
Could be a cookie problem... Once you have been kicked by egroupware, you can't reconnect until you wait 30 minutes.
Delete your Internet browser cache&cookies, wait 30 minutes and please try again.

Offline Bud

  • *
  • 487
Re: eGroupware upgrade to 1.4
« Reply #78 on: December 03, 2007, 06:07:07 PM »
Thanks cool34000 that's what the Problem was but Now I have a New one  :?

I have Created an "admin" account and with the admin account I created an account for myself with admin status. All works fine however when I create any other Users (Using the Admin account) they cannot login to the System. Does the user account have to be an existing SME User Account for any user that I need to have access to egroupware or can I just create any new eGroupware User account (without that user having an SME Server Account)

I have tried both ways but the New Users cannot login to egroupware except "admin and myself"

Any help greatly appreciated

Re: eGroupware upgrade to 1.4
« Reply #79 on: December 03, 2007, 06:28:10 PM »
Yes, the default RPM install uses IMAP to authenticate users, so only default SME account can login.
This info is in the wiki ;)

You can change this default behaviour in the setup.

Offline soprom

  • *
  • 589
    • www.logiciel-libre.org
Re: eGroupware upgrade to 1.4
« Reply #80 on: December 04, 2007, 03:08:28 PM »
It is possible to create accounts in EGW matching users on different server/domain.
Usually, accounts will match SME.users but not necessarily.
In cases where one EGW.account is not an SME.user, configuration is more complicated and done in user's preferences. It's a lot of clicking but it works.
Sophie from Montréal

Offline bloodshoteye

  • ****
  • 232
  • Grateful thanks to SME devs
Re: eGroupware upgrade to 1.4
« Reply #81 on: December 26, 2007, 05:34:25 PM »
Greetings,

On a sme 7.2 with smeserver-egroupware-1.4.002-3 installed in /opt/egroupware I can create a website with egroupware's sitemgr easily.
However, the public URL is too cumbersome for my client: http://my.domain.tld/egroupware/sitemgr-site/

I'm battling for the last 2 days to have egroupware's sitemgr generate a site so that http://my.domain.tld will display the main website for public viewing.
Has anyone tried this, and if so would you please share your steps to achieving this?

Thanks a lot,
SME Server is a fantastic product - thank you!

Re: eGroupware upgrade to 1.4
« Reply #82 on: December 26, 2007, 07:28:34 PM »
Hi,

The following method assumes that you don't have any website in Primary ibay (which is the default website when you type http://yourdomain.com)

1st of all, delete default website:
Code: [Select]
rm -f /home/e-smith/files/ibays/Primary/html/index.htmThen create the file index.php in /home/e-smith/files/ibays/Primary/html/ and paste the following in it:
Code: [Select]
<?php
header
('Location: http://yourdomain.com/egroupware/sitemgr-site/');
?>
This will redirect http://yourdomain.com/ to http://yourdomain.com/egroupware/sitemgr-site 8-)

« Last Edit: December 26, 2007, 07:30:33 PM by cool34000 »

Offline bloodshoteye

  • ****
  • 232
  • Grateful thanks to SME devs
Re: eGroupware upgrade to 1.4
« Reply #83 on: December 26, 2007, 07:45:52 PM »
cool34000, your advice:
Quote
1st of all, delete default website
Then create the file index.php in /home/e-smith/files/ibays/Primary/html/ and paste the following in it:
Quote
<?php
header('Location: http://yourdomain.com/egroupware/sitemgr-site/');
?>
has made my day - thanks very much   :-D
« Last Edit: December 26, 2007, 11:06:09 PM by ardugh »
SME Server is a fantastic product - thank you!

Offline bloodshoteye

  • ****
  • 232
  • Grateful thanks to SME devs
Re: eGroupware upgrade to 1.4
« Reply #84 on: December 26, 2007, 08:57:36 PM »
cool34000,
I have another small question:

The site requires an image directory, and  according to site setup:
Quote
Image directory relative to document root (use / !), example: /images
No matter what I try, this result is constant:
Quote
Directory does not exist, is not readable by the webserver or is not relative to the document root!

I wonder if you also experienced this? (or maybe someone else?)

Thanks for your time,
SME Server is a fantastic product - thank you!

Re: eGroupware upgrade to 1.4
« Reply #85 on: December 05, 2008, 04:20:26 PM »
Thanks for your suggestion; however, there aren't any keys set:

[root@blackadder RPMS]# config show egroupware
[root@blackadder RPMS]#                                 



Des


Hi,
I've had the same issue ... and I finally found why.
Make sure that your downloaded rpm file is NOT in /opt when running yum localinstall smeserver-egroupwarexxx ... otherwise, the backup script will run and installation fail.
I did move the rpm file to /root/ prior installation and it worked.
Regards